Help - Search - Members - Calendar
Full Version: pb with tkc soft and the sharp rom 3.13
OESF Forums > General Forums > General Support and Discussion > Software
totoetlititi
I have flashed my zaurus (I used the rom 2.13), abd now my tkc applications don't work...!
When I launch tkcExplorer with a console, I have this message:
"error while loading shared library: libtkc.so.1: cannot load shared object file: No such file or directory"
:cry:
But I have this library in /opt/QtPalmtop/lib ...

I think, it is a problem of link... but where ?
tumnus
The 3.x ROM has a bug. It looks for libraries in /usr/lib, but not /home/QtPalmtop/lib or any link to that.

To fix this I just run the following as root:

cd /usr/lib
for f in /home/QtPalmtop/lib/*; do ln -s $f; done

Ignore any errors about file already exists.
totoetlititi
Thanks !!!
Very good !

Yesterday, I tried to edit the /etc/ld.so.conf, but no result....!

Perhaps, it is a variable (like PATH) for library, it isn't ?
totoetlititi
I searched this week end, and, normally, the evironment variables are in a .profile file.
In my PC, I find this in /etc/.profile
In zaurus, I can't find it... no profile file in /home/etc or /etc or /home/zaurus...
Why ?
tumnus
I think this is a Qtopia problem more than anything. It doesn't use the library paths from anywhere as far as I can see. Even the LD_LIBRARY_PATH variable in /home/QtPalmtop/qpe.sh, which launches Qtopia, does not have any affect on apps launched within Qtopia.
totoetlititi
I find the .profile... !!!!
see /home/root/.profile !!!!
year...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.