Help - Search - Members - Calendar
Full Version: Sound is Dead! Help!!!
OESF Portables Forum > General Forums > General Discussion
eak0703
Hi, ok, definitely this is my fault...and i should be thankful that the Zaurus still works, but a few days ago i dropped it into the sink, while the watter was running. (i unscrewed it and left it to dry in pieces)
At first the PDA just didnt work at all, then somhow it turned on, but the backlight was dead...now even the backlight came back on but whenever i try to use mediaplayer, or any other type of audioplayer (i tried the trial version of the tkcPlayer) the actual mediaplayer application crashes.

Here is more detail on the crash:
I can turn on the Mediaplayer, i can see all the media files, MP3 or wav, i can select the media file. the player screen opens and the seconds start counting while there is no sound. At this point ive tried one of 2 things. 1. pressing any key on the Zaurus freezes the mediaplayer and the only way to get the system back is to reboot.
OR
2. ive let the seconds go up to the actual lenth of the song..at this point the actual length of the song begins incrementing so if it was a 2 minute song at 2.01 what the counter would say is 2:01/2:01...2:02/2:02..etx..

What ive tried: i was using Sharp's V3 upgraded ROM, so i thought that somehow the water corrupted the actual mediaplayer programme. I re-flashed the Zaurus to the old ROM that it first came with. Same exact crash...i then returned the V3 ROM back and once again i have the same crash. I called techsupport and asked if perhaps there was a special processor for Audio on the Z...they said there was not...video and pictures play just fine as long as there is no sound in the video.
Ive tired running the files from both the internal Flas memory and the SD card which i have....i unfortunately do not have a CF card...

i am at a complete loss of what to do and was wondering if there is anyone who might give me some advice on what i should do next...if anything...i suppose that its a miracle in the first place that this thing still works as well as it does.

As far as i can tell there is nothing else that is wrong with my Z...just audio is dead.

Please if anyone has a minute i would really appreciate some advice...and if not i thought that this type of error was really unique and interesting for people anyway smile.gif

anyway look forward to hearging from people.
~EAK
eak0703
UPDATE: umm...now i am just totally lost....i just played an AVI file that had audio...it took forever to load the avi...but it loaded and played unsycronized but the audio definitely did work....however the MP3s still are a no go sad.gif
eak0703
UPDATE2: I think i have found out why im getting the kind of errors that i am: The Zaurus has an internal Audio Codec Chip. My guess is that the data on this chip has become corrupted and this is why some audio does work while other audio does not. Does anyone know if it is possible to Flash this Audio Codec chip?

~EAK
ChanSecodina
If you can get any form of sound at all you should be mostly in the clear. Sharp's version of MediaPlayer is pretty finicky from what I remember. I would suggest that you go to: http://www.mneuroth.de/privat/zaurus/madplay.html
download the latest version of madplay and install it. Its a console program so you'll have to run the terminal program, then run the program followed by the complete path to the mp3 like this
CODE
madplay /root/name_of_mp3.mp3

If you can get sound out of that then its just a software problem with Sharp's media player. The audio codec chip isn't a flash chip, and its not a codec in the way you're probably thinking about it. Any decoding of mp3s and other music formats is done by the Zaurus's main processor, which from what you say appears to work. Besides what I've mentioned I'd try playing different MP3s. There are some mp3s that play fine on my desktop but just don't play at all on the Zaurus. Good luck!

-
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.