Help - Search - Members - Calendar
Full Version: Testers needed: Opie SDK installer script
OESF Portables Forum > General Forums > General Discussion
ironstorm
:idea: See 3rd Message for latest script


Old stuff:

I promised Hugh that I'd release this almost a month ago now... I've been trying to get rid of the last bug, but I can't hack it so time to open it up and see if others can help.

I have a working system able to run the SDK fully built on an old version of Morphix lite from July 2003.

On all other Debian/Knoppix-based systems, I am able to get the OpieSDK (kdevelop 3.0.0) running, but when creating or openning a project I get:
QUOTE
Could not create language plugin for C++


Here is the install script so far, OpieSDK needs about 550MB at its peak and will use about 460 after it is finished. That doesn't include any packages you need to get for dependancies.

CODE
#!/bin/bash

### using Knoppix 3.4 c't as a base

# knoppix lang=us

## k->knoppix->root shell

# wget http://debian.tu-bs.de/knoppix/installer/knx-templates-0.39.tgz

# cp /usr/sbin/knoppix-installer .

# sudo ./knoppix-installer

## Make an install partition of 2.8GB / partition

## choose knoppix-type system install (not debian)



##



# create working dir

mkdir ~/OPIE_SDK_install

cd ~/OPIE_SDK_install



# Install and Prep GCC 3.3.2 ARM cross-compiler be used by OPIESDK

## this is for OZ 3.3.6-pre1, for older versions of OZ you must use gcc 2.95.3

## and this next bit does not apply.  

## ftp://ftp.handhelds.org/toolchain/ # Obsolete Compiler Tool Chain

wget http://www.openzaurus.org/official/toolchain/cross-3.3.2.tar.bz2

# wget http://192.168.0.101/cross-3.3.2.tar.bz2 # Local Mirror for testing

cd /

tar -jxvf ~/OPIE_SDK_install/cross-3.3.2.tar.bz2

cd ~/OPIE_SDK_install

mkdir -p /usr/local/arm/

ln -s /opt/cross /usr/local/arm/2.95.3



rm -f ~/OPIE_SDK_install/cross-3.3.2.tar.bz2





# install SDK

# wget ftp://ftp.handhelds.org/zecke/OpieSdk.tar.bz2 # OPIE SDK Main

# wget http://lorien.handhelds.org/ftp.handhelds.org/zecke/OpieSdk.tar.bz2 # OPIE SDK Mirror

wget http://lorien.handhelds.org/ftp.handhelds.org/zecke/OpieSdk.tar.bz2 # OPIE SDK Mirror

# wget http://192.168.0.101/OpieSdk.tar.bz2 # Local Mirror for testing



cd /

tar -jxvf ~/OPIE_SDK_install/OpieSdk.tar.bz2

cd ~/OPIE_SDK_install



rm -f ~/OPIE_SDK_install/OpieSdk.tar.bz2



df -h





ln -s /usr/lib/libpcreposix.so.3 /usr/lib/libpcreposix.so.0

ln -s /usr/lib/libpcre.so.3 /usr/lib/libpcre.so.0

apt-get install libpng3


To start it up use:
QUOTE
/opt/OpieSdk/start_kdevelop


-G
ironstorm
using ldd -r /opt/OpieSdk/kde/lib/kde3/libkdevcppsupport.so

I found the problem to be libdb-3.3.so was not found
this fixes it:

CODE
ln -s /usr/lib/libdb3.so /usr/lib/libdb-3.3.so
ironstorm
Here is the latest.... Need testers!

CODE
#!/bin/bash

##

## Note: base system is a hdd install of DamnSmallLinux 0.6.3

##  space needed: 125MB dsl base -> 811MB everything installed (~700MB)

##



# create working dir

mkdir ~/OPIE_SDK_install

cd ~/OPIE_SDK_install



# Install and Prep GCC 3.3.2 ARM cross-compiler be used by OPIESDK

## this is for OZ 3.3.6-pre1, for older versions of OZ you must use gcc 2.95.3

## and this next bit does not apply.  

wget http://www.openzaurus.org/official/toolchain/cross-3.3.2.tar.bz2

# wget http://192.168.0.101/cross-3.3.2.tar.bz2 # Local Mirror for testing

cd /

tar -jxvf ~/OPIE_SDK_install/cross-3.3.2.tar.bz2

cd ~/OPIE_SDK_install

mkdir -p /usr/local/arm/

ln -s /opt/cross /usr/local/arm/2.95.3



rm -f ~/OPIE_SDK_install/cross-3.3.2.tar.bz2



# install SDK

# wget ftp://ftp.handhelds.org/zecke/OpieSdk.tar.bz2 # OPIE SDK Main

wget http://lorien.handhelds.org/ftp.handhelds.org/zecke/OpieSdk.tar.bz2 # OPIE SDK Mirror

# wget http://192.168.0.101/OpieSdk.tar.bz2 # Local Mirror for testing



cd /

tar -jxvf ~/OPIE_SDK_install/OpieSdk.tar.bz2

cd ~/OPIE_SDK_install



rm -f ~/OPIE_SDK_install/OpieSdk.tar.bz2



apt-get install libpng3 make libdb3 kdelibs4 perl g++ qte-fonts qt3-dev-tools-embedded qt3-designer

## no kdelibs4 = kdevelop: error while loading shared libraries: libkhtml.so.4: cannot open shared object file: No such file or directory

ln -s /usr/lib/libpcreposix.so.3 /usr/lib/libpcreposix.so.0

ln -s /usr/lib/libpcre.so.3 /usr/lib/libpcre.so.0

ln -s /usr/lib/libdb3.so.3 /usr/lib/libdb-3.3.so

ln -s /usr/bin/make /usr/bin/gmake # no gmake = *** Exited with status: 127 ***

## no xlibmesa-gl-dbg | xlibmesa-gl | mesag3 | nvidia-glx | xlibmesa-gl | mesag3-glide2 | mesag3+ggi = kbuildsycoca/kdevelop: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

## no perl = Can't locate File/Copy.pm in @INC ... BEGIN failed ... *** Exited with status: 2 ***

## no g++ = *** Exited with status: 127 ***

ln -s /usr/share/qte3 /usr/local/qt-embedded # no qte-fonts = Cannot find font definition file /usr/local/qt-embedded/lib/fonts/fontdir - is $QTDIR set correctly?

## no qt3-dev-tools-embedded = no qvfb (frame buffer for testing)

## qvfb: make sure you have glx loaded in your XF86Config | XF86Config-4 (whichever is used on your system)  

## Section "Module"

##         Load  "glx"

## EndSection

## no qt3-designer = no ability to edit application gui layout files (.ui)



## Start the final set-up

qvfb &

/opt/OpieSdk/start_kdevelop



## --== Building a project ==--

## Project -> New Project -> C++ -> Opie Application

## give it a name, next, next, next, finish

## Build -> Build Project

## Build -> Execute Main Program



## --== Package for OZ 3.3.6pre1 ==--

## in QMake Manager (right panel 2nd icon from the top), configuration (wrench):

## Dev/Test: QMake Subproject Configuration -> Make Spec -> Native G++

## Release: QMake Subproject Configuration -> Make Spec -> SL-55xx and SL-50xx

## Build -> Clean Project

## Build -> Build Project

## Build -> Build Package (check mark)

## deploy .ipk to Zaurus

##

## manually create symlink from /opt/Qtopia/bin/quicklauncher to /opt/Qtopia/bin/app, if neccessary

## manually create symlink from your app to /opt/Qtopia/apps/Applications/app.desktop, if neccessary

# i.e.

# lrwxrwxrwx    1 root     root           66 Mar 24 07:51 gt1.desktop -> /mnt/card/oz3.3.6-pre1/opt/QtPalmtop/apps/Applications/gt1.desktop



### ------------- below does not work (qt3-designer breaks compiling) ---------------

## click on file selector (left side panel, top icon)

## click on ?base.ui file

## 'Break layout', add something, 'Layout grid'

## Save .ui

## minimize qt3-designer

## Build -> Build Project

## Build -> Execute Main Program


Cheers,

-G
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.