Help - Search - Members - Calendar
Full Version: 5600/PXA250 and Special Kernels - actual reliability?
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > 5x00 Hardware
cgrieves
I've only had my 5600 (PXA 250) for a couple of days, but one of the first things I did was install the 1.02 and then 1.03 special kernel (with no overclocking). So far I've not had a good experience- random hangs doing things as trivial as moving the cursor, freezes when placing the Zaurus in the cradle, various hangs when starting applications, and a few times the unit has shut itself down for no reason. Each instance required a hard reset. I've put the standard kernel back on a few hours ago, and so far haven't had any more freezs, although the decreasing in speed and responsiveness is very noticeable.

Is this a common experience with the special kernel, or are there 5600 users getting "true" stability?

Also, looking at the notes on the download page for the special kernel, it implies that the Pre-emptiveness of the special kernel provides a speed increase ("almost doubles the responsiveness of the 5600"), while the PXA cache workaround "gives a small speed increase". Is this really the case? If so, would a pre-emptive kernel without the PXA workaround give a significant speed boost without the instability?

Discuss smile.gif
chimyfolkbutter
I have been running the special kernal and (knock on wood) do not have any problems.

-CFB
tangoRomeo
I've had my Zaurus for about 2 wks now running Special kernel 1.03 for most of that time
(admittedly not doing a wide variety of things with it yet... trying to get kismet working).
Note that I upgraded to the Sharp 1.32 ROM prior to going with the Special kernel.
So far I've had only one lock up (hard reset required) when I was trying out the Java
sample applications. I have since used that application successfully so I'm not sure
what the issue was.
xamindar
I have been using it for about a week now. Only thing I have had a problem with is the zaurus complaining about low memory when I try to open some applications which seems to happen if I haven't rebooted the zaurus in a while. Other than that it works great. These problems I am having could also be caused by something else I have installed, I'll have to reflash the sharp kernel and see if these small problems correct themselved. I haven't really had any lockups yet (only when I forget that I had a swap file on my sd card mounted and I eject it).
Mickeyl
Keep the statements coming, this is interesting data for us - since we still have'nt decided whether to enable or disable the cache errata workaround in the next OZ version.
nixmeister
Has anyone tried the special kernel with zynergy5600 yet??? Any tip/feedback???
Greg2
I have successfully used the special kernel v1.3 with zynergy 1.1 and sharp v 1.32 without any problems. There were some problems with the previous versions of this kernel, so be sure to use the latest version 1.3.

Note: there are 2 roms for the 5600- zynergy1.1 and zynergy 5600, and 1 rom for the 5500- zynergy1.0

I currently use sharp v1.32 with the special kernel v1.3 because I had problems installing lardmans usb-storage for 5600 on the zynergy. This was the only bug with the combo that I could find and I'm sure that could be resolved.

One more thing... when installing the special kernel on the zynergy rom v1.1 my personal experience showed better results using the zynergy updater.sh and renaming the zImage.bin to just zImage. Explanation: zynergy updater.sh searches for zImage not zImage.bin like the sharp updater.sh.

Greg
tumnus
QUOTE
Also, looking at the notes on the download page for the special kernel, it implies that the Pre-emptiveness of the special kernel provides a speed increase ("almost doubles the responsiveness of the 5600"), while the PXA cache workaround "gives a small speed increase". Is this really the case?

That's the wrong way around. The pre-emptive patch does very little in terms of a speed increase. It's the turning off of the cache bug workaround that almost double the speed.

Make sure you have flashed the v1.3 kernel. All the other versions should be taken down, but I don't have the access.

I've never had any problems and I can't imagine that there would be such a contrast in experiences.
nixmeister
I've tried to flash the special kernel v 1.3, and it won't seem to take. I'm running zynergy5600, and I've tried both using the sharp updater.sh with zImage.bin, and zynergy5600's updater.sh with just zImage. I get the kernel install progress indicator, and it seems to be doing something. With the zynergy updater it asks me to reset, and with the sharp updater is resets automatically after the flash. When I boot back up, I cat /proc/version, and it doesn't appear to have changed (there's supposed to someone's name in there, can't find what it's supposed to be now). I have no /proc/cccr.... or whatever that is. Running dhry21 still gives me 148. Clearly it didn't take. What the heck am I doing wrong here???
I'm using a CF card, vfat format, and they are in the root directory of the card. All owned by root, and all permissions set to 777. Not sure what else to try....
Any tips???
tumnus
vfat format is the wrong format. It needs to be plain FAT16 also known as DOS FAT.

You should see colin@paravel in /proc/version when it is flashed.
nixmeister
Interesting. Well, I reformatted my card with mkfs.msdos (only had that, minix, vfat, and ext2). After that, I remounted and mount still shows it as a vfat partition. I don't have anyway of plugging the CF card into my computer, just the zaurus. I reflashed, and it's coming up now. Survey says.......didn't work. Same thing. I've flashed a bunch from vfat though, I flashed zynergy and openZaurus with it. Are you sure I need fat16? What's vfat? fat32?? How can I get fat16 on ther if that's really what I need??
tumnus
Technically speaking vFAT is an extension to FAT which is usually applied to FAT32. You may also need to change the partition type to make it completely FAT16 using fdisk.
nixmeister
Well, is the mkfs.msdos the same as fat16? Doesn't appear to be since it shows up as a vfat after I do that. So is the special kernel more picky than other flashes? I'm confused because I've already flashed items from vfat, and the zaurus can read it fine. I would think that the restriction would be based upon what the zaurus update utility can read, not based on what you're flashing.....
Can you clarify for my Tumnus? I haven't had coffee and I'm not thinking straight smile.gif
BTW, thanks a ton for the help!!!
tumnus
Yes, mkfs.msdos does produce a FAT16 filesystem, but there is also the partition type setting which also declares what type of filesystem a partition is. This can only be set with fdisk.

I'm just trying to reduce the factors that could be causing your problems, since many other people have flashed this fine.
Greg2
When you think you have your cf-card ready and flash again, make sure when the flash is finished reset the zaurus again and enter the maintenance menu once more and select format to complete the kernel update.

Good luck,

Greg
nixmeister
Format? I thought that was only for full distro flashes, doesn't that replace the whole filesystem? I didn't think that was needed just to put in a new kernel.....
Can someone verify that you have to format after flashing the special kernel? And what will this delete???
Greg2
When reading your post it sounded like you were switching from sharp to zynergy and back. If not, then just a hard reset after the flash will do...sorry for the confusion.

Greg
cgrieves
Thanks for the replies, I formatted and reflashed back to "factory" settings with the standard kernel , reinstalled the apps I wanted, got Exult and scummVM working ( smile.gif ) and didn't experience any hangs. So with that as my benchmark I've installed the 1.3 Special Kernel and left it at stock CPU speed. I'll let you know how I get on....
nixmeister
Well, I'm kinda stuck in the same place. I have no fdisk on my Z to change the partition type to fat-16, and the link to the .ipk is busted on the killefiz. I think it's most strange that the whole process "completes". It runs the update, I see the progress bar move across, and then it either resets, or asks me to reset (depending on whether I'm using the sharp updater.sh or the zynergy updater). Once I boot up, I'm still running the old kernel. Man, this is way easier on my linux desktops smile.gif
make dep && make bzImage && make modules && make modules_install
lol

While I'm looking for fdisk for my Z, anyone have any other clever ideas on how to get this working for zynergy5600?

Seems no one else has had problems with this. Why me? smile.gif
Is it possible to flash from SD? Maybe my CF card has gone bad. Although, I've flashed lots of stuff from it with no problems, even being a vfat fs according to mount...

Again, thanks for the help on his one folks. I can't wait to get this working Tumnus!
tumnus
Are you sure you've got the right zImage.bin? The md5sum I get for the 1.3 version of the Special kernel is 0f74ae87540767158b3e7caa675a88ce
nixmeister
I'll find out ina second, I just tried the flash again from my SD card.......
Tumnus, I think I need to start up a support contract with you for all this help. How much? smile.gif
nixmeister
errrm. Ok, different checksum. Lemme download it again....
nixmeister
OMG I'm such an idiot. 231 dhrystone. Ok, Tumnus, you rule. I don't know what happened there. I clearly was flashing SOME kernel, just not yours smile.gif
Did I ever tell you you're my hero.....you're everything I wish I could be.... I can fly higher than an eagle....you are the wind beneath my wings........
nixmeister
Wow. over clocked to 471, I cranked out a 270 on the dhrystone. Wow. Tumnus, you rock. Thanks a ton man!!!
ChrisZaurus
Hello,


I have recently purchased a SL-5600, PXA250 - I have installed the zynergy rom, and it works great. I want to install that special kernel, but I am having no luck. I've tried flashing it with the zynergy updater.sh and the zImage_Special5600_No_Preemptive_No_Overclock-c860ROMv1.10.bin file (ver 1.3 right?), which i've renamed to zImage.bin, which I put both files in the root dir of my SD card (this card does also have other files on it... Documents dir, and some more dir in there). When I initiate the update process, it says "modprobe: cant locate module devprobe" (that is on the Sharp screen), after that it says ----Zaurus SD Updater ----- Please Reset. I do the same reset process, and then boot up as normal, what am I doing wrong? Should I format?

Thanks For Your Help!
ChrisZaurus
Okay, I tried flashing with the Sharp version of updater.sh, and it worked. laugh.gif Great.
guh
What information is given for the kernel version when it's OK ?
tumnus
Look for "colin@paravel" and a compile date of 29 Feb 2004 in /proc/version
guh
OK, it's the good one then, it worked smile.gif
loji
I've been using a japanese special kernel for awhile now... and it works wonderfully on my 5600. it's the 1.4b kernel ..

Its' got all the wireless modules, and supports my Linksys card out of the box. It's clocked to the 479MHz max. It also has a customboot process, tux is in the corner, and you can actually see what the hell is going on with your system :-) Plus I notice it's doing an Inode check everytime it boots up.

I'm very pleased with it wink.gif
zenken
where is it?

and have you tried the vnc server on it (fbvncserver)?

I tried the v1.3 kernel on my 5600 but fbvncserver didn't work
loji
Here is the english translation

http://www.excite.co.jp/world/english/web/..._co=excitejapan

Just upgraded to the 1.4c kernel :: works fine smile.gif not only that my IR sensor is working with opie remote biggrin.gif

No I don't use a VNC server ... You've checked here?

http://cmisip.home.insightbb.com/zaurus.htm#SDL
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.