Help - Search - Members - Calendar
Full Version: Kismet with GPS
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 6000 - Tosa
thomasbernie
I have Kismet and Qpegps running (thanks to the experts here). Qpegps reads the Garmin Etrex like a charm. Can't get coordinates with Kismet, however. GPSD must be configured correctly for Qpegps to work. Any ideas?

Thanks,
Tom
lardman
From memory the kismet.conf file has to be altered to tell kismet that you are using gpsd, and possibly also to tell it which port it's running on.

Just a guess though as I've not tried it myself.

Si
thomasbernie
Thanks lardman. kismet.conf has gps=true, with gpsd -p /dev/ttyS0 -s 4800 prior to kismet, kismet shows 0 lat long. gpsd works fine with qpegps and the same port. Some one will figure it out.

Tom
jerbell
Kismet works fine with my garmin gps. I havent tried qpegps. I start gpsd without the -s 4800, I doubt that matters. gpsd version 1.10
thomasbernie
jerbell --

I'm running kismet 3.01c and kismet-qt on my 6000. Kismet will start on the console with sound, but no response to keyboard. I start gpsd first using -p /dev/ttyS0 -s 4800. The lat/long fields show at the bottom of the kismet screen with values of "0.0." My gpsd version comes with qpegps and works fine. I'll uninstall qpegps and try to install gpsd 1.10. Is your setup the same as mine?

Thanks,

Tom
tz
I think one of the default prebuilt kismet configurations for the Z has GPS DISABLED - i.e. no code. I build my own (which also gzips the output files), but I remember having this problem

lsof would show open ports as would the signon of kismet - it will say if it can lock GPS or not. And the kismet_client will display GPS coordinates from kismet if it is working.

Strace might also show if kismet is actually trying to open a socket.
henrysviper
Guys, how did you connect your Z with Garmin etrex? I was thinking of buying one of these units (they seem to be very good for the price)
in order to use it with a C700 but I thought they have only a serial connector. Do you use a self-made cable?

Thanks,
Greg
jerbell
I got a serial cable from serialio.com, the sharp serial cable is the wrong sex and I havent checked to see if it even fits. The connector itself is the same as the one on the 5x00 Z's.
BTW we have 6000's, dont know about C series.

re kismet, I replaced kismet_client with one compiled with panels support, otherwise I'm using the 3.01c ipk. I don't think kismet shows any location data unless it is connected to gpsd. Is the location data in the log files wrong too? Are you getting a .gps log file?
jerbell
BTW I reboot into ttyS0 free mode before starting gpsd. I've never tried otherwise, I just assumed the serial port is running a PPP server by default like on the 5x00 series.
thomasbernie
For the Z to Garmin, I use Serialio 1824. It's 12" long with male db9 (matches the Garmin serial cable).

I get .gps, .xml, .dump files from kismet. -- position data fields "0.0"

Pardon my noobieness, but how do you " I reboot into ttyS0 free mode"?

Thanks, Tom
tz
The default zaurus configuration wants to do a PPP sync session on /dev/ttyS0 by default. You need to fiddle with a few things in /etc to disable this (inittab or /etc/syncsomething). This must be disabled to use GPS via the serial port.

The regular Z serial cable can easily be changed into a DCE from DCE.

I wrote this up (and the PPP stuff above is) on one of the wikis http://www.zauruszone.farplanet.net/wiki/i....php?SerialPort .

Note a standard "null modem" adapter (with the right gender - most plug into PCs) should work with any serial GPS.

For my C760, I use the audio input and a DSPUART program (and a custom gpsd that launches it). At 48kHz sampling, I get 10 samples per serial bit, and although there is some noise, GPS is easily reconstructed. And I use external speakers for Kismet which are louder anyway. This way my serial port is available to access the web (via my cell phone).

You can "telnet localhost 2947" into the GPSD port and type 'R' to see the raw data coming in. there are commands for position, but this should show if it is working.

You can also telnet into 2501 with kismet_server running in the background (preferably with -s). - there is a GPS command that should return what Kismet sees.
jerbell
Select the reboot option from the QT menu and then type a / while its counting down, one of the options you get is to boot with ttyS0 free.
jdv
If you've done all the other things outlined in this thread, try setting the
following lines in your /etc/kismet.conf file:

# Do we have a GPS?
gps=true
# Host:port that GPSD is running on. This can be localhost OR remote!
gpshost=127.0.0.1:2947

I couldn't get kismet or kismet_qt to run nor could I get valid gps data written to file until I changed:
gpshost=localhost:2947
to:
gpshost=127.0.0.1:2947

Once I did that, kismet (and kismet_qt) would stop crashing and I got valid gps data written to log files.

Hope it helps.
bigred
had the same problem here
the gpsd form qpegps won't work with kismet
downloaden the complete gpsdrive packackage for zaurus and extracted it on my pc
in A directory you find gpsd (the one from gpsdrive)
copyed it to /usr/bin and deleted the qpegps program (zaurus uninstall)

now it works fine for me
bigred
QUOTE
The default zaurus configuration wants to do a PPP sync session on /dev/ttyS0 by default.  You need to fiddle with a few things in /etc to disable this (inittab or /etc/syncsomething).  This must be disabled to use GPS via the serial port.

The regular Z serial cable can easily be changed into a DCE from DCE.

I wrote this up (and the PPP stuff above is) on one of the wikis http://www.zauruszone.farplanet.net/wiki/i....php?SerialPort .  

thanx this was what I needed to make my gps work with the zaurus

I made a nice casemod to the docking station of my 5500
it now has an serial connector on top of the sharp i/o bus

is there anyone who now's how to start gpsd automatic when kismet_qt is started ??
tz
Basic Z hacking tip:

You can point the target of the launcher (if you go to the tab setting in settings, or edit /home/QtPalmtop/bin/whatever) to a shell script and have that script start both - you probably will want to use "exec whatever.original" as the final line. Sometimes when something is going badly (like debugging zroadmap), I use strace, or point the output to log files in a tmp directory, or can even add parameters.

Kismet wants the direct GPS feed. You can probably use socat from /dev/ttyS0 or wherever to tcp:2947 and it would likely work.
bigred
sorrie i'm having my zaurus for just A week so I don't now the basics of the zaurus
I'm already learning
thanx for your answer
I'll try it this evening
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.