Help - Search - Members - Calendar
Full Version: Has anyone compiled SDL?
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
So, I've tried running various programs that use SDL, but all of them have had bugs of one sort or another. So, I decide to try compiling my own. I downloaded SDL 1.2.7 and compiled it. But when run an SDL application (even the sample apps in the SDL distribution) nothing appears on the screen! I've added debugging statement at various points, and they are printing out, so I know that SDL is initializing, and the API calls are going through.

I also tried the patch from but it didn't make a difference.

Has anyone successfully built a working SDL library for qtopia?
I've compiled my own SDL 1.2.7 library like this:

NM=arm-linux-nm LD=arm-linux-ld CC=arm-linux-gcc CXX=arm-linux-g++ RANLIB=arm-linux-ranlib AR=arm-linux-ar ./configure --host=arm-linux --build=i686-pc-linux-gnu --enable-video-qtopia --disable-video-dummy --disable-video-fbcon --disable-video-dga --disable-arts --disable-esd --disable-alsa --disable-cdrom --disable-video-x11 --disable-nasm --prefix=/opt/Embedix/tools/arm-linux

And I've wrote my own plasma demo and it works fine (I'm getting 25fs/s).
Did you use stock SDL 1.2.7 or apply patches? I suppose the problem could be with my cross compiler - maybe I should try the Embedix toolchain. Can you send me your SDL binary so I can test it?
ok PM me with yr email
Hi, I'm a newbie, could anyone send me some example code for zaurus sdl app? I've compiled it myself but it run only in root mode and stuck at SDL_SetVideoMode().

Thanks for help.

DINH Anh Minh

Did you look at the .bb files for SDL? Did you apply the same patches, etc.?

First of all, thanks for your attention smile.gif.
But.. I really don't understand what did u say sad.gif?
I can't find any file .bb, I've read README.Qtopia and my script is:

./configure --enable-video-qtopia --disable-video-dummy --disable-video-fbcon --disable-video-dga --disable-arts --disable-esd --disable-alsa --disable-cdrom --disable-video-x11 --disable-nasm --prefix=/opt/Qtopia/sharp --host=arm-linux --build=i686-pc-linux-gnu

I've all done like
what more do I have to do?


DINH Anh Minh


Sorry, I was talking about building SDL - you're talking about using it in an app - I don't know anything about that I'm afraid.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.