Help - Search - Members - Calendar
Full Version: Java Compiling
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus - Everything Development > Personal Java/Jeode/J2ME Personal Profile
Hi Guys,

I have just bought a new SL5600 Zaurus. My main reason for buying this is to develop convenient informatic software.

Anyway I am currently a Java beginner but I would like to compile and run siomple Java programs while on the move. I have recently bought a book which came supplied with some great Java examples however I cant seem to get the simple programs to compile.

The code refers to an IMPORT package called essential.jar. I cant seem to get the compiler to recognise the IMPORT package .....eassential.jar. I have done some reasearch and it seems to be a problem with the CLASSPATH finding the .jar package! Is this the case??? If so can you help update the CLASSPATH to recognise this .jar package????

As I unmderstand it the .jar package contains some classes such as a keyboard class (for recieving imput from the keyborad) and some graph classes (to assist in drwaing simple graphs). Perhaps these clases are not part of the J2ME and only part of the Java 2 language. If this is the case how can I convert simple Java 2 code into understandable code for the Zaurus to compile???????

These are very difficult questions for me to answer becsuse Im just a beginner but any help would be great


There was no built-in java compiler that comes with SL-5600.

Try installing ewe JVM and Jikes java compiler as listed under Learn how to program Java based on the examples under ../classes after the installation.

Suggest to create a java folder as /mnt/cf/java and dump all classes and jars here inclusive Jikes after the installation.

set the classpath and path as follows:

export CLASSPATH=c:/mnt/cf/java
export PATH=/mnt/cf/java:$PATH

Happying Eweing!!!
I would not recommend using the Zaurus to learn Java. You can write code on it and you can compile on it if you install a compiler but in my opinion it would be easier to learn Java on a workstation.

With a workstation, you get to use a full-size keyboard (and monitor), you can run more powerful editors (one's that give you on-line help and code completion) which really help learning the ins and outs of the Java APIs. An open source IDE such as Netbeans will also allow you to test the code within the IDE as well as run debug sessions. THere is also much more documenation on using Java on a workstation so when something does not work you'll have a better chance researching the problem. If it doesn't work on the Zaurus, you'll have a tougher time figuring it out.

Good luck with it either way.
Totally agreed that for a big scale of Java development, using workstation is highly recommended.

For a beginner who has PDA, wIth a good editor, like Zeditor, one can just cut and copy the source code from the examples from Ewe, activate Jikes and run with Ewe JVM to learn how to program Java with Ewe JVM. In addition, you can also use 4 GB Microdrive to store APIs that are provided in html format for reference. In short, it is an idea mobile programming platform.
Hi freizugheit and everybody else

Thanks for the advice! Im trying to install Jikes but when I unzip the jikes.tar.gz file I just get a load of messages with a file called jikes in the folder. Anyway where should I copy the jikes file in the filesystem???

Also I installed the Ewe which is looking interesting but I am trying to open create a folder in the following path like you said


However when I try and create the folder I keep getting an error message.....cannot create folder. I tried again when logged in as root but with no success.....can hyou help again???

Also when i get up and running will I be able to add new .jar files to the /mnt/cf/java folder when I want to run new programs???

Sorry but its all a little new to me but im learning alot.

Thanks Chris

Let solve the problems one by one.

First what level is your Unix knowledge.

- The file 'Jikes' is the binary executed file for Zaurus platform

- Unable to creat /mnt/cf/java folder
- Are you using root access right?

- jar question
- It depends whether it is compiled and archived to work under Zaurus JVMs

- Next task
- Check whether Ewe is installed by issuing the command 'ewe' from desktop.
- If it works you are halfway from your objective

- Post result of "echo $CLASSPATH" and "echo "$PATH" here to check whether the Java programming environment is in place.

My UNIX knowledge is also very basic but that is actually one of the reason why I bought the zaurus. I can study using the terminal commandes as well as practice my Java skills on the go. Its great so far but my level of UNIX and Programming is so low that its proving difficult to get started.

Anyway I am pretty sure the binary version of Jikes is on my Zaurus but im not sure where to put the file in the file system.

I still cant have write access to the /mnt/cf directory. I keep getting a message saying that its read only even when logged in as root. I have tried loggin in as root from the terminal (su -l command) and also I have tried executing the file manger with root privelages but still cant creat/write a new director /mnt/cf/java....... Any advice???

I have a successful installation of EWE which is looking nice with a good editor. I dont see a compile option on the editor though. I will check it out later today.

Im tried running the echo commands echo $PATH and echo $CLASSPATH

The $PATH seems to be no problem but when i echo $CLASSPATH I just get a line return plus a blank line then it line returns again with the terminal promt. In sure what going on here???

Anyway Its a struggle so far but I dont mind im leraning everystep of the way. Sorry if its frustrating................thanks for you help and any help would be great!!!

- As /mnt/cf/java is not created, hence the export command for CLASSPATH is not effective.
- Do you have a Compact Flash Memory card in the CF slot?

- Jikes
You can put the binary in /usr/bin.
After that, you can activate it any way using terminal mode.
Hi freizugheit

Thanks for all you advice so far! Its great but the task of getting Java running on my Zaurus is proving more difficult than I expected Anyway I will keep trying!

In answer to your questions I dont have CF card yet but I do intend to buy one soon. My zaurus is running out of memory fast.

So this is my situatui so far

1) I still havent managed to creat the directory /mnt/cf/java because of access rights. I was thinking about changing the access rights for the cf directory using chmod in the terminal, what do you think???? I also notice that in the cf directory is a file called NotAvailable and it has 0B. Do you need it in there???

2) I have successfully installed and ran the EWE java program no problem.

3) I have also unpacked the jikes compiler (binary) which is now sitting in my /usr/bin directory and is showing a huge 12.7 looks to big.......what do you think????

4) I havent yet downloaded the file because I am unsure of which to download. There seems to be many each representing a different version of JDK. Which do i need??? where should I place the file????

5) Actually I have the Personal Profile from SUN on my zaurus. As I understand it this represents JDK 2 so it will be useful to incorporate this into my programming. How do I make use of this with EWE??? and when I program??

Sorry for my lac of knowledge but your help is really improving my understanding.....Thanks alot!!!!

mnt/cf is for the compact flash card. If you don't have one, how do you expect to put files on it???
are bugger!!!!! yeah I need a cf card thats why it says cf. God i really am idiot! Well I had better buy a cf card pretty soon then.

- If $ is not a concern, try remove 4GB Microdrive from Creative Mu MP3 player. I have put up the procedure in the forum, please search for yourself.

- Download jikes for Zaurus at which is less than 4 MB.

- Get the one in JDK 1.1.8 which is less than 10 MB and place it in /mnt/cf/java

- Personal Profile from Sun & JDK 2
- It does not work under Zaurus.
- Refer to my setting for CLASSPATH and PATH
- To be used with Ewe JVM
jikes - classpath /mnt/cf/java/
ewe myfirstewe (to run your compiled Java code with Ewe JVM)

Happy Eweing!!!!!
QUOTE(cjthorley @ May 23 2004, 08:59 PM)
are bugger!!!!! yeah I need a cf card thats why it says cf. God i really am idiot! Well I had better buy a cf card pretty soon then.


You can also do it from an SD or MMC card is you want, they are generally cheaper and leave the CF slot open for things like your Wireless card.

Then your path will be something like /mnt/card/

and so on and so forth.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.