Help - Search - Members - Calendar
Full Version: Can't get zgcc 2.01 to work.
OESF Forums > General Forums > General Support and Discussion > Software
When executing the sample compile I get the following:

# gcc -o foo -lm foo.c
/mnt/card/.zgcc/bin/ld: cannot find -lm
collect2: ld returned 1 exit status

Any suggestions?
Have you activated "source"?
I cut and pasted the code for from the html file and must have had something wrong. I ran the one on the cramfs and it worked great.
Compilied zip,unzip and ssh 2.4 already.

Great package!

the file mentioned is also in the root of the .zgcc dir, so if it's mounted at /mnt/card/.zgcc, it's /mnt/card/.zgcc/ ... my case i copied to my flash at /home/root/.zgcc and .include respectively, so i had to go through and find/replace the stuff in the file ...

if you changed anything from the stuff in the html walkthrough, you might want to consider making similar changes ..
please post the screen output of the following command to see whether your symbolic links are correct:

ls -l /usr/lib/lib*
Zgcc has been working fine on my SL-5600 with the original Sharp ROM.

However, I encountered the following loader problem during compilation after recent upgrade of Sharp ROM to 1.32:

ld:warning:cannot find entry symbol - start; defaulting to 02000614

My current linux kernel version: 2.4.18-rmk7-pxa3-embedix.

Can someone enlighten?

Thanks in advance!!!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.