Help - Search - Members - Calendar
Full Version: Sorry, MySQL problem again
OESF Portables Forum > General Forums > General Discussion
Anonymous
I have the same problem using MySQL in Cacko ROM on my c860, I've try several method (chown in /var/lib/mysql, using mysqlstart -u daemon)

but MySQL Still cannot start, I've check the log file and it say :
1. Can't start server : Bind on unix socket : Permission denied
(is this part related to permission of /tmp? it's already 777 rights)
2. Do you already have another mysqld server running on socket : /tmp/mysql.sock
(I'm sure that there is no file on /tmp directory)

I've haven't change anything on /etc/my.cnf , is there anything I'm missing?

Thanks for help
w14
In your my.cnf file, find the [mysqld] section and change the "user=" line to user=root.

Mike.
Anonymous
I've tried it before and it still have same error sad.gif

- Change the user as "root" in my.cnf
- Start mysql using root (mysqlstart -u root)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.