Help - Search - Members - Calendar
Full Version: todo & datebook apps won't run
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > 6000 - Tosa
The built-in Todo List and Calendar apps, which were running fine, now won't run.

Both generate the same error when run from the console:

qeclient_sendcommand(): server child accidentally finished!

qeclient_sendcommand(): server child accidentally finished!

Anyone have any ideas as to what went wrong, and, more importantly, how to repair?
I recently uninstalled korganizer. Could that have removed files or broken some links that need to be restored?
Korganiser should not have removed anything necessary for the Sharp Calendar and Todo List.

Firstly have you rebooted? The QuickExec daemons may have simply got messed up.

If that hasn't fixed it then something you have installed/uninstalled recently has either removed a link/library or replaced a library with something incompatible. The quickest way to resolve this is by running the following as root:

cd /
tar xvf /root/.home_default.tar home/QtPalmtop/lib
tar xvf /root/.home_default.tar home/QtPalmtop/binlib
tar xvf /root/.home_default.tar home/QtPalmtop/bin
tar xvf /root/.home_default.tar home/root/usr/lib

Then terminate Qtopia and let it restart. That should in theory restore most of the binaries, libraries, and links back to the default without wiping any data/settings.
I had previously rebooted and retried the apps - to no avail.
I just ran your tar commands, as root - all ran fine, killed Qtopia, and retied the apps. No joy.
I rebooted & retried. Still no joy.
Runing /home/QtPalmtop/bin/todolist generates the same error message in original post. Ditto datebook (Calendar).

Still looking for ideas.
I recently had this. The Todo List app crashed while I was marking stuff in the list. It corrupted the TodoList index, and because the Todo List is shown inside the DateBook program, it meant that the DateBook prog wouldn't work either.

You can check whether it has gone mad by downloading zdbat, which lets you edit/view the databases via the command line. Once it's installed, go to the command line and type "zdbat todo -r". If the file is okay, it should list the contents of your ToDo file, if not it will give you an error.

You'll have to delete the ToDo files. They are in ~Applications/dtm/

You should back them up, just in case (but I doubt you can fix them).
In the terminal, do this:
mkdir ~/Applications/dtm/oldtodo
mv ~/Applications/dtm/SLTODO* ~/Applications/dtm/oldtodo

Your Todo and DateBook should then work okay (although obviously, you've lost your todo list if you had one).

If the above doesn't work, try reading the datebook files with zdbat (zdbat datebook -r) to see if they are okay.
Fromwithin -
Thanks! That was exactly the problem. The file was massively hosed. Removing the file allowed the application to run. Lost the data (at least until get back to work Tues. and sync with the computer there, I hope), but the applications work again.

This is ageat forum - thanks to all who responded!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.