Help - Search - Members - Calendar
Full Version: Cannot connect to Bluetooth Device
OESF Forums > General Forums > General Support and Discussion > Security and Networking
lwong
I have a strange problem connecting to bluetooth device for the past two days: When I type sdptool browse or spdtool search SP, my newly acquired Pharos BT GPS will return:

Failed to connect to SDP server on 11:22:33:44:55:66: Permission denied

where 11:22... is the MA address of the GPS. /etc/bluetooth/givepin has the correct PIN for the GPS. I tried different combinations inside hcid.conf, restarted blueZ, cardctl, cardresume, reboot but nothing works. Z has no problem seeing my BT cellphone though.

I am using old Ambicom BT2000 CF card on SL6000L with BlueZ. Running as root has the same Permission Denied message.

What can be wrong? The strange thing is that it also happened two days ago but suddenly worked fine but return again today.

Oh, the GPS unit pairs with the same card when I use it in my laptop so it's unlikely the culprit.

Thanks in advance for your help

FW
lwong
Ok, I reformatted the Z this morning to start from scratch.

After the refomatting, I installed Qkonsole first, then BlueZ package. Nothing else

Tried "sdptool browse":

>sdptool browse
Inquiring...
Failed to connect to SDP server on 11:22:33:44:55:66: Permission denied
>sdptool browse
Inquiring...
Failed to connect to SDP server on 11:22:33:44:55:66: Protocol error
>sdptool browse
Inquiring...
Failed to connect to SDP server on 11:22:33:44:55:66: Too many level of symbolic links

What on earth is wrong with the connection!!! The GPS is freshly charged, in range and tested find using the same Ambicom BT2000E CF card in my Windows XP laptop. It can;t be the PIN in /etc/bluetooth/givepin, could it? I am just looking for a Serial Profile, not trying to pair with it(yet). "sdptool searh SP" returns the same set of results. I have searched high and low on the internet but no one seems to have encountered this strange error meaasge. Can anyone help?

SL6000L
Default Sharp ROM
Ambicom BT2000E CF card
Bluez

Thanks

FW
tumnus
You might want to try contacting Marcel Holtman on the BlueZ mailing lists with info like your zaurus, CF BT card, GPS model and syslog output when you try a sdptool browse. It looks like an incompatibility between the BlueZ drivers and your GPS since you have got the connection with your mobile phone working fine.
lwong
Thanks for the advice Tumnus.

The strangest thing happened the other day: after I reformatted the Z and still couldn;t get it to connect to GPS, I gave up and restored to the previous setting. Since then, everything works again!!! It's a really strange thing becasue the restoration point was when sdptool gave me the "permission denied" message. I just ended up buying a D-link bluetooth dongle to use on my laptop and just keep the Ambicom CF exclusively (for now) for the Z. Hopefully I don;t have to see that message again...

BTW, since SL6000 has teh USB host feature, is there a way for your BlueZ package to work with dongle instead?

Thanks

FW
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.