Help - Search - Members - Calendar
Full Version: GLIBC_2.3
OESF Forums > General Forums > General Support and Discussion > Software
I need version GLIBC_2.3
Anyone can help me /send me this file ?

Where can i find it ?
You will need a new ROM. What are you trying to run?

i've Zaurus sl6000l and i try to install cups for printing....
i think on sl6000l there is a new library so i'm searching the old version GLIBC_2.3 to try cups work...
The old (and presumably this is the one the Sharp ROM uses) is v2.2. I guess you've found your version of cups either from or from one of the OZ 3.3.6pre1 feeds.

You'll need to recompile it I'm afraid. You can't upgrade libc on its own (without reflashing).
Try this, it's a tarball of the source & binaries. You'll have to make your own ipk, but at least it was linked against libc2.2
If one is deperate to run a binary requiring an incompatible libc (or other lib) and has no source to recompile one could always put that lib somewhere (not /lib) and make a shell script wrapper for the app with LD_LIBRARY_PATH pointing to the location of the new lib. Of course this makes no sense for something readily available like cups but the option as such should be kept in mind.
Anyone knows where I can download a new cups version for Zaurus ?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.