Help - Search - Members - Calendar
Full Version: ar is failing to open opie ipks
OESF Forums > General Forums > General Support and Discussion > Software
ccrandal
I downloaded libpcap0.7.2 and keypebble just now and saw they were in Debain binary package 2.0 format. From my Mac, I tried using `ar -x` to open the package so I could reformat as tgz. However, I just end up with the following output:

ar: debian-binary/: No such file or directory
ar: data.tar.gz/: No such file or directory
ar: control.tar.gz/: No such file or directory

So, I tried to do the extract on my Z. There, I ended up getting the error:

ar: error while loading shared libraries: libbfd-2.9.5.0.14.so: cannot load shared object file: No such file or directory

Are these just bad ipks or is there something wrong with my ar programs? Why do we have 2 different formats for ipks? Any reason ipkg hasn't been modified to handle both formats?

Thanks
Curt
cane_cubo
I had this problem too with ar on a Mac. I ended up doing dearchiving on a linux server in the office -- on linux ar seems to work right. So I suppose the version of ar on OSX needs to be updated or something.
ccrandal
I was hoping fink would have a version of ar available, but it doesn't look that way. :cry:

I suppose this means there's something messed up with ar on my Z too, eh?
Mickeyl
IIRC there have been slight changes in the tar format recently. Don't ask me for details, I just read this on a list or a forum or somewhere. Oh and someone mentioned a --oldgnu switch or so.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.