Help - Search - Members - Calendar
Full Version: some keys don't work with keyz
OESF Forums > General Forums > General Support and Discussion > Software
Snake
Hi!

I have some trouble with keyz 0.5.6-1 on my Zaurus SL-5500G using latest SharpROM 3.13. I need keyz to switch back to the German keyboard layout.

If I aktivate keyz, some keys won't work:
* FN+[' "] should be ~, but nothing happens
* FN+[ENTER] should be >, but nothing happens (sometimes I get a return)
* FN+[<-] should be DELETE, but nothing happens
* FN+[SPACE] should open the symbol table, but nothing happens

The same malfunctions are with the englisch keyz-dafinition, so I think, it's an error in common.xml or the program itself. If I deaktivate keyz with it's applet, all keys are working right (of course I have the wrong layout).

So, there are any hints?

Greets
Frank
lucho
If anyone wants to correct the xml definitions and send me the corrected ones, I'll create a new version. I don't spend much time programming for the Zaurus, so it is unlikely to do it myself.
Snake
QUOTE(lucho @ Jun 26 2004, 02:26 PM)
If anyone wants to correct the xml definitions

I would do this, if anybody could tell my whats wrong.

Ok, I've tried to modify the common.xml. First, there was no entry for unicode 62 ">". I've copied alle entries for unicode 60 "<", changed "Period" to "Enter" und unicode 60 to 62 and now it works fine: FN+ENTER gets a Greater ">".
But now, If I press FN+[' "] (Apostrophe) I get also a ">".
Well, I've deleted all entries für unicode 126, should be Tilde "~" and copied the entries for unicde 60 a second time and changed "Period" to "Apostrophe" and unicode 60 to 126. But now, keyz does not work anymore (Zaurus reboots, zkb applet is hidden).

So long,
Frank
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.