Help - Search - Members - Calendar
Full Version: SLapAss
OESF Forums > General Forums > General Support and Discussion > Software
wizzard
Hi
I was wondering if anyone has tried the Simple Linux access point ASSociator (SLapAss) from http://undertow.2y.net/zaurus/SLapASS/. I tried to install it in my 5600 but it doesn't show up in the packages to be installed. Does it even work with the 5600?
jerrybme
QUOTE(wizzard @ Jun 29 2004, 07:16 AM)
Hi
I was wondering if anyone has tried the Simple Linux access point ASSociator (SLapAss) from http://undertow.2y.net/zaurus/SLapASS/. I tried to install it in my 5600 but it doesn't show up in the packages to be installed. Does it even work with the 5600?

Are you running Opie on your Z? The version of SlapASS your link points to seems to ba an Opie based app.

Cheers,
Jerry
slocaus
From the ZSI description:

QUOTE
SLapASS is a simple tool written only in bourne shell using Opie-SH as a front end.


Only runs on OZ/Opie.
wizzard
"Only runs on OZ/Opie. "

OK. Thats why it didn't show up. Any way this can be made to work under Sharp ROM?
slocaus
You will need to repackage it for the Opie installer (search here for instructions) and then there are probably a bunch of opie libraries you need. Or contact the author of SlapAss?!?
wizzard
Thanks slocaus.
But I couldn't find the instructions. Will ask the author.
Joshp
Has any one got this app to work. I downlad it and whan I hit the icon nothing happens.

JP
Joshp
Never Mind I did not have opie-sh installed.

JP
slocaus
QUOTE(wizzard @ Jun 29 2004, 04:19 PM)
Thanks slocaus.
But I couldn't find the instructions. Will ask the author.

From the "unofficial FAQ"
http://www.zaurususergroup.com/modules.php...parent_id=0#213
wizzard
Thanks again.
Is there a way this can be done entirely on the Z? I got the error message 'ar not found' when I tried to do this from the terminal:
"Peel apart an OPIE package with the 'ar' tool on desktop Linux: ar -x myopiepackage.ipk

Then repackage the bits in the Sharp format:
tar zcvf myopiepackage.ipk ./debian-binary ./data.tar.gz ./control.tar.gz"

Unfortunately I don't run Linux on my desktop nor do I have access to one.
slocaus
The included Zaurus version of busybox does not support ar format:
http://lists.debian.org/debian-arm/2002/06/msg00022.html

Maybe one of these will?
http://www.killefiz.de/zaurus/search.php?q=busybox&x=0&y=0

How I found the above (Google is your friend): wink.gif
http://www.google.com/search?num=100&hl=en...rus&btnG=Search
kcurrie
Hello all, I'm the author of SLapASS. Please *DO* forward any questions to me you have-- I'll try my best to answer them. Email me at kcurrie@undertow.2y.net

SLapASS really IS a simple program-- if you're having problems with it bring open a shell (embeddedKonsole) and run it with tracing:
sh -x /opt/QtPalmtop/bin/SLapASS

..and see what errors you get.

For it to work, assuming you want to use the Kismet functionality you need to have a *working* Kismet configuration. For just using it to switch between preconfigured networks kismet isn't required.

I've got my Z all jacked up with all kinds of programs but I tried to make sure that nothing I have as standard on mine but non-standard elsewhere crept into the program.

As for why it doesn't show up as an installed package on the Sharp rom-- I have no idea, as from what I've read there is no difference between an OZ ipkg and a Sharp ipkg. I built the packages mostly manually as well, just using tar, gzip and md5sum.

To my great surprise there has been ~450 downloads in the last 10-11 days, so apparently there is SOME interest there, although I've only recieved a few emails about it.
I personally got sick of having to manually reconfig my networking under OZ all the time because the Oz network app can't seem to store multiple configs-- even though it has a dropdown box which would appear to offer that functionality...

SLapASS actually was just a simple offshoot of another program I'm writing, and I thought it'd be useful to write it in just /bin/sh so it'd run just about anywhere (except for the Opie-SH requirement). If there is interest, I could *possibly* hack it to work either WITH Opie-SH or just as a command line app. The other program I'm writing has basically the same functionality as SLapASS and only runs via cmd line, but is written in perl, which I'd assume most people don' t have installed.

..if there was a half-deceit replacement to Opie-SH that could be used as a frontend as easily as Opie-SH I'd be thrilled to use... anybody know of such a thing?

I found a bug in SLapASS today yesterday while waiting to go into surgery-- if it fails to associate it tells you so and then tells you it associated :-) Instead of "break" I should have had "exit 1" on that line... a new version should be up soon.
Any other features people would like?

Out of curiosity the other day I also hacked up a simple script which varies the volume of the Z according to the wireless strength. Why you ask? So you can listen to something like a wave file or mp3 and determine if you are getting farther away from an access point or closer without having to look at your Z (or even have if visable) :-)

I've got a ton of other stuff I just haven't bother to package up or even drop in my bin directory too.... stuff like swapd which is a swap daemon which creates swapfiles as required and deletes them when done... works pretty good on the Z for creating swapfiles in the ram disk.... other stuff like a patched proxychains, various hacking tools, etc.
If anybody wants anything really cool out there, please let me know :-)
lardman
I'm running the cacko rom for a little while to see what it's all about, I assume it doesn't handle ar ipks.

Assuming the above is correct you can grab a version of opie-sh which is tar.gz encoded from www.killefiz.de/zaurus

Also the SLapASS package installed fine for me.


Si
wizzard
I gave up. I couldn't even install busybox, so couldn't try the excellent suggestions given. Can only hope that the author will release a version compatible with the Sharp ROM.
kcurrie
Eh? busybox is installed on the Sharprom to begin with, is it not? I mean, that's what nearly all the binaries in /bin are symlinks to-- right?? I haven't run the sharp rom for a while, but I can't image a Z could even boot without busybox installed. If I remember correctly, the shell (sh) that is used on the sharp rom is also part of busybox. In case anybody isn't aware, busybox is a binary that functions as a ton of various commands. To make busybox work as (say) grep, just ensure that there is a symlink pointing to the busybox binary with the name of grep. ...the same goes for the rest of the commands it functions as.


..anyway...

If for some reason the ipk won't install, just do this (assuming you have the SLapASS.ipk file in /mnt/card/tmp);

cd /mnt/card/tmp
tar zxvf SLapASS.ipk
cd /
tar zxvf /sd/tmp/data.tar.gz

Now try running it like this:

/opt/QtPalmtop/bin/SLapASS

If you end up with some errors, you can try running the script with the -x option to /bin/sh so it shows the commands it's executing:

sh -x /opt/QtPalmtop/bin/SLapASS

Is there anybody here who was able to get this working on the Sharp rom?

I'm not aware of anything I've done that would be OZ specific, but I've been running OZ for so long that I may have missed something obvious :-)
slocaus
QUOTE(kcurrie @ Jul 4 2004, 08:31 PM)
Eh?  busybox is installed on the Sharprom to begin with, is it not?

You missed this message when wizzard was tryiing to repackage the ipk from ar to tar:

slocaus Posted: Jun 30 2004, 08:40 AM
The included Zaurus version of busybox does not support ar format:
http://lists.debian.org/debian-arm/2002/06/msg00022.html
Maybe one of these will?
http://www.killefiz.de/zaurus/search.php?q=busybox&x=0&y=0


So the answer is, yes busybox is installed, but not with ar support if you need it.
zmiq2
Hi,

I have the ar program, cross-compiled for gcc2.95: it works on my c750-sharp stock rom.

I tried to upload the file to ZUG downloads, but after filing all fileds and pressing the add-this-file button, I get a 'document-contains-no-data' error message !?!?!

I tried to attach the file to this post, same error.

The file is 1.2M

So, if any of you want the file, just pm me with your email, and I'll send it to you; or can anyone just host that file ?
kcurrie
Ah! I wasn't aware that the Sharp ROMS didn't use a tar.gz based package but rather an ar based packged containing tar.gz files :-)
Oh, I fixed a minor bug in the script as well where if it failed to associate it now quits instead of continuing on with IP allocation.

Let me know if this works!

I also attached it to this message (but had to add a .bin extension to it because otherwise it said: You cannot upload this type of file)

Give it a shot!
kcurrie
Oh, I just STATICALLY compiled ar a few minutes ago. It's pretty big, even after UCLXing it at 336K, but it at least runs on my OZ box and should on a Sharp ROM as well.

I'll attach it to this message or you can get it from the bin dir my website here:

http://undertow.2y.net/zaurus/bin/

The main Z page is here: http://undertow.2y.net/zaurus/
Optogeek
Tried to install either ipk on my sharp rom with the graphical installer but neither worked. Then tried to unpack and re pack the original version of the ipk and install from the command line. This failed with a message saying zcat had found an error in control.tar.gz. which I had re-packed as well.

While I had everything unpacked I tried to run the program from /opt/QtPalmtop/bin/SLapASS. This worked but your script then uses awk which is not installed as standard on the sharp roms.

At work now but will try later to install awk and get this working.
undrwater
Running this on stock sharp of sl-6000.

When I click on the icon, it seems to work, but I never seem to be able to assosciate with any AP. I modified the file to point to kismet, dump, and manuf. I have it set to run as root.

When I execute the sh -x option I get the folowing:
CODE
Aborted
+ mode=134
+ [ 134 = 255 ]
+ [ 134 -lt 3 ]
+ [ /bin/true ]
+ opie-sh -g -m -M SLapASS! Simple Linux A.P. ASSociator
Comments to: kcurrie@undertow.2y.net -0 Quit -1 Find APs! -2 Configured APs


This repeats, and I have to close the terminal.

Another thing: is SLapASS supposed to start the network and kismet, or is that something I need to do manually? If so, does the network get started using the "warwalk" profile?

TIA
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.