Help - Search - Members - Calendar
Full Version: My new SL550 & Socket BT card
OESF Forums > General Forums > General Support and Discussion > General Discussion
WindlePoons
Hi all, Please excuse me if the answeres are elsewere but.....

I have a SL550 which I have flashed with the Rom from sharp si its now

Kernel 2.4.18
Rom 3.10

Im having trouble getting my Socket bluetooth running,
I folowed:

http://bluez.sourceforge.net/download/zaur....zaurus.new.txt


OOPs I've just read the first line.

Maybe I'll try that instruction first?

I'll post this anyhow just incase any one knows some thing else I need to do...

Plan B

# ipkg install bluez-zaurus_2.3_arm.ipk
then
bluez-libs-2.7
bluez-hcidump-1.8
bluez-utils-2.7
bluez-kernel-2.4.18-mh14

and carry on with the rest of the instructions..
tumnus
Those packages are out of date and will not work with Sharp ROM 3.1.

There is a howto on the ZUG that I wrote which explains it all, but the ZUG howtos are currently down and I don't have an up to date copy sad.gif

You also need to specify with Socket BT card you have. The last letter on the top barcode will either be E, F, or G. E and F are easy to setup. G is not.

The correct packages are these:
http://community.zaurus.com/download.php/5...2.4.18d_arm.ipk
http://community.zaurus.com/download.php/4...z_0.9.1_arm.ipk
http://www.cpinkney.org.uk/susp-resume_0.9-3.1.ipk
http://www.zaurususergroup.com/modules.php...q=getit&lid=184
and if you have the Rev G card:
http://community.zaurus.com/download.php/5...ial_0.1_arm.ipk
WindlePoons
Oh great I have a G card. I'd seen people mention that the socket worked fine unless you have a revG.

Thanks for the reply. I supose I'll just have to wait till the HowTo's are back

(typical that it goes down just when I need it most.....)
Zuber
For what it's worth, I have a Socket "G" card and using the standard instructions it works fine with the C750/C860.
At least for what I use it for, which is dial up. Not tried GPRS on this card (only tried it with BlueMonkey card) but I doubt it would be a problem.

Only bit that does not, is the suspend/resume. Even after installing suspend/resume fixes.

I simply quickly pull out and push in the card again and it works fine. Very reliable and consistant infact.
Zuber
I do install the new serial file by the way.

As the how to is not available, you could use the links above and use the how to from our site in the meantime. It is just a simplyfied version of the above how to. All credit to those that did all the work...

http://www.shirtpocket.co.uk/spforum/index.php?showtopic=30
Bane
Is there any news on any kind of a blueZ gui ?

What ever happened to the one pictured here.

Or is that gui from some rom other than the sharp rom ?
WindlePoons
QUOTE(WindlePoons @ Jul 1 2004, 01:24 AM)
Oh great I have a G card. I'd seen people mention that the socket worked fine unless you have a revG.

Well, I downloaded & installed the apps as sugested and other than needing to do a restart on the Bluetooth & pcmcia, things are working OK. I can live with that

Thanks.
biggrin.gif

Now to get it syncing with outlook. sad.gif
Grimwiz
I bought a Bluemonkey Bluetooth CF card from Shirtpocket, and came here following their instructions. However, it doesnt work for me.

By editing the uart file I was able to move to the hciconfig stage but running hciconfig returns:

hci0: Type: UART
BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0 DOWN

when I try and run "hciconfig hci0 up" as /etc/pcmcia/serial tries I get the error

Can't init device hci0. Permission denied(13)

I have installed the following packages:

bluez-csr-serial_0.1_arm.ipk
bluez-zaurus_2.3-2.4.18d_arm.ipk

I am running the CACkO Zaurus Qtopia ROM 1.20 "Daniela"
Grimwiz
Thinking it may be my Daniela (v1.2.0) installation, I tried reflashing last night to Elanor (v1.2.1b), with identical results (e.g.hciconfig shows the device, with address all zeroes).

I then reflashed to pdaxrom-1.0.5, where I saw entirely new behaviour:

When inserting the card the light flashed momentarily then went off. I used xcardctl to enable the card, then "hciattach /dev/ttS0 bcsp" enables hciconfig to show the correct information so I suspect the card works but the Cacko roms are incompatible.

I'll post a summary in the Cacko forums.
Zuber
Had a customer call me the other day with trouble getting it working with cacko.

Problem was that they downloaded the edited file off the site, but somehow the file ended up in Dos format. Need to be sure it is in Unix format.

Otherwise the file has ^M instead of carriage returns causing it to mess up.

After that, card worked fine.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.