Help - Search - Members - Calendar
Full Version: unable to install opera 7 & can't reinstall 6!
OESF Forums > General Forums > General Support and Discussion > Software
justinfw
Hi,

I tried installing the Opera 7 ipk on my 5500 but I get the error:

"The extract of some files are failed. This application may not execute normally. When you cannot operate the application, please remove it."

So I removed it and tried to reinstall opera 6 - same error. Going to the command line to get a better error message, this is the output of the opera 7 install:

# ipkg install opera_sl-5x00-7.30.9965_arm.ipk
Unpacking opera...Done.
Configuring opera...tar: ./opt/QtPalmtop/bin/opera: input/output error -- No space left on device
tar: Bad tar header, skipping
tar: Bad tar header, skipping
tar: Bad tar header, skipping
tar: Bad tar header, skipping
tar: Error exit delayed from previous errors
Done.

Here is the output of df -k prior to the install:

# df -k
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/ram1 44 26 18 59% /dev
/dev/mtdblock1 28785 18845 8404 69% /home
/dev/hda1 250344 216296 34048 86% /usr/mnt.rom/cf

Is 8MB not enough to install opera, or is something else wrong??
Stubear
No I don't think 8Mb is enough to open Opera 7, the package itself is about 5 megs and it needs temp space while it's being unpacked (that usually equals the unpacked size) so you will probably need 10Mb free or more

Stu
justinfw
Well, that was it. I removed Jeode, which left me with 13MB free, and opera 7 installed fine, leaving ~ 8MB free. Interestingly, I was then able to reinstall Jeode and still have 4MB free.

So it appears that Opera needed a lot of temporary space or Jeode's ipk is not compressed very much.

Thanks for your help.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.