Help - Search - Members - Calendar
Full Version: Cross-compilation installation package
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Linux Applications
Ashitaka
Whooo, I finally finished gathering everything needed for a complete cross-compilation environment for the Zaurus, including a set of useful libraries, and writing the scripts to get everything turning.

Just get it on http://www.nautilus6.org/operation/zaurus.html (the second link).

QUOTE
This script will install a complete cross-compiling environment for ARM/Qtopia PDAs.
I use it for Zaurus C750/C760/C860, but it should also work for SL-5xxx and SL-6xxx.
The cross_install-2.95.3.sh script will install:

  - GCC 2.95.3 cross-compilation toolchain
  - libz, precompiled libuuid and libjpeg, X11 development files
  - Qt/X11 2.3.2, Qt/Embedded 2.3.7, Qtopia 1.6.2 and tmake 1.11

The libraries_install.sh script will install:

  - libpng, libogg, libvorbis
  - SDL 1.2.6 for Zaurus by zports.sf.net
  - SDL_image 1.2.3 and SDL_mixer 1.2.5

The Examples/examples-zaurus.sh will install

  - "Hello World!" classic
  - SDL demo
  - Qtopia official example


I would be very happy to have some feedback if ever you use it!
Ashitaka
I updated the package, to correct some installation problems.

Always on the same page...
sylvius
I tried installing it (and am really excited to get it working). The main install works fine, but then the library install crashes. Specifically, I have problems with libSDL compiling:

CODE
/bin/sh ../../libtool --mode=compile arm-linux-as   -c -o SDL_blit_arm.lo `test -f SDL_blit_arm.S || echo './'`SDL_blit_arm.S
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[3]: *** [SDL_blit_arm.lo] Error 1
make[3]: Leaving directory `/home/dan/zaurus/cross_compile/cross_install-2.95/libSDL/src/video'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/dan/zaurus/cross_compile/cross_install-2.95/libSDL/src/video'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dan/zaurus/cross_compile/cross_install-2.95/libSDL/src'
make: *** [all-recursive] Error 1
Problem while installing libSDL!


Any suggestions how to fix that?

Thanks
Mickeyl
Welcome to the wonderful world of cross compilation. Convincing the autotools and libtool (and a whole lot of other freaking build systems) to do what you want is an extremely non-trivial task and it took some very skilled people to come up with a solution which in most cases behaves.

I can't give you different answer than to encourage you to look into OpenEmbedded, which shields you from the complexity of cross compilation and solves a lot of tedious problems.

Didn't you wonder why we gave up work on our nice OpenZaurus distribution when it was very popular? It is because we have a vision and for the last 9 months, we worked very hard to make it real:

OpenEmbedded is the most efficient and flexible open source tool for (cross)building software - from single packages up to whole Linux distributions. From set-top-boxes over PDAs to firewalls and routers. OpenEmbedded is here to stay.
Ashitaka
Argh libtool problems are really a pain in the ***...
What version of libtool do you have ? I installed this package on several different computers without any problems... libSDL comes from zports.sf.net, maybe you should go ask there if you still have the problem.

As for OpenEmbedded I am not really convinced. I am not trying to build packages just for the Zaurus, I am trying to port Linux applications to the Zaurus, which for some reasons has to use the original Sharp ROM. Would OpenEmbedded really be better for me ?

P.S. By the way I just discovered that my installation package does not work with GCC 3.4, which is much more strict...
sylvius
My libtool is:

ltmain.sh (GNU libtool) 1.4.3 (1.922.2.111 2002/10/23 02:54:36)

on a gentoo box running 2.6.7. Let me know what libtool version you know works and I can try that to see if that is the problem. Failing that, I will check with the libSDL folks.

Thanks
Ashitaka
ltmain.sh (GNU libtool 1.1510 2004/06/24 12:21:40) 1.5a

Maybe the problem comes from here smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.