Help - Search - Members - Calendar
Full Version: running duke3d : "undefined symbol: __muldi3"
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Qt/Qtopia
Anybody know what this means and how to fix it?

Tried to cross compile duke3d for the zaurus.

It is part of libgcc. Try adding -lgcc_s to the LIBS.
It cannot find -lgcc_s

/usr/local/arm-linux/bin/ld: cannot find -lgcc_s
collect2: ld returned 1 exit status
make: *** [build] Error 1
If there is a somewhere in your arm devel tree, make a symlink to and try linking with -lgcc_s again. Otherwise try linking with -lgcc .
It seems I dont have this anywhere. I have libgcc.a.

Do I need to build ?

I came upon these instructions :

Is simply the shared version of libgcc.a.

It seems I could build this way.

No need to build Does the linking step find the muldi3 thing with -lgcc ?
Compile does not complain when I add -lgcc. However, when the binary is transferred to the zaurus and run, it complains of not finding muldi3. I dont see any in the zaurus. Maybe I need to transfer the I compiled to the Z?
I created and created a symlink to it with . I copied it over to the lib directory in my laptop arm-linux toolchain. Recompiled duke3d and transferred duke3d to the zaurus along with the shared libgcc_s.

Duke3d is now RUNNING on the Z!
I am using the shareware demo.

Music and sound is a little garbled though. It was also garbled on the laptop with the x86 binary. Maybe I need to tweak the cfg file.

Loading time is a little long but seems to be playable.
Thanks Zazz
can you post a download link? or package it and put it into a feed? thx wink.gif
yeah we need to try this! ;-)
I really need to put more time for zports smile.gif
Its up on my website.

Scroll all the way to the bottom. Instructions are there too.

I wish somebody can figure out how to fix the sound effects.

By the way, you need sdl and sdl-mixer.

Have fun.
NICE biggrin.gif
Has anybody tried it yet?

Poking around at the source, It seems by only loading the smaller sound samples in memory, the problem with the sound samples all playing at the start of the game goes away. I wonder how it works in a machine with 64 MB memory.
any chance that will make it into ipk form anytime soon? I'm certain that the community would really like it smile.gif
Still working on it. Got sidetracked with Sarien, Freesci and Heretic.

I wish somebody with a 64 M machine will try it out though. I am running into a problem with the function that allocates memory for the sound samples. I am wondering if this is because the Z 5600 only has 32 MB of RAM.
I'll quite happily test it on a C760 smile.gif
& I'll happily test it on my SL860.
I use Gentoo linux on PC, and on install process of Duck3D this requieres

timidity and

ph34r.gif I think the sounds inssues can have a soluiton when install timidity!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2016 Invision Power Services, Inc.