Help - Search - Members - Calendar
Full Version: need help w/ ROM update plz OZ 3.2 and 3.3
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus Distro Support and Discussion > Angstrom & OpenZaurus
hi, just got my 5500 yesterday, tried to flash to OZ 3.2 today, but after it finished flashing, when i powered on it just has a blank screen w/ sharp in center, like when you reboot from a sharp rom, and it just stays there until it auto powers off, whats wrong? in the CF card i had initrd.bin and zImage.bin, was there anything else i needed? I also tried OZ 3.3 but again, same problem, plz help, thank you
According to what I have read on sites you have to copy image to file name "zImage", you have the inird file correct. You have to put them in the root of cf card, and also create fat16 file system before you start.
To recap - create fat16 file system, copy image file to "zImage" and initrd.bin to"initrd.bin" to cf root.
I hope this is right, if it isn't I'm sure someone will speakup. I don't even have a Zaurus yet because I am concerned about lack of syncing to Linux. good luck {rh}
Bob_H, I think you are right although most (all?) CF cards are already formatted as FAT16 (I have read the advice NOT to reformat the CF card since this *might* cause problems).

Most likely the names of the files are not correct. If you used a computer with Windows to copy the files to the CF card it could be that they have a suffix that you don't see. E.g., initrd.bin is named initrd.bin.txt and you don't see the additional suffix because the Explorer hides it.

Make sure that the zImage file is named "zImage" and initrd.bin is named "initrd.bin". When you downloaded the files you might have to rename your "zImage-SL-5500-52memory-12storage.bin" (or similar) to "zImage" (no suffix here but leave the suffix in "initrd.bin").
initrd.bin and zImage.bin? this is totaly wrong

initrd.bin and zImage

ohh some have reported problems with ntfs.... download it directly to cf card if you have far, i have not had this problem with the new openzaurus stuff. ntfs kinda blows the images from what i read and needs fat but i recommend the naming of the files like i posted initrd.bin and zImage
have read the advice NOT to reformat the CF card since this *might* cause problems

I have formatted my cards many times. No problems other than those caused by my not being able to use fdisk and mkfs.msdos.

ohh some have reported problems with ntfs

I've never had this problem (running WinXP with an NTFS filesystem), what I have had troubles with is IE corrupting the larger of the two files (initrd.bin). Mozilla/Netscape works fine for me. YMMV.

The most important thing is to check the md5sums of the two files before you try flashing, that way you'll know that they are not corrupt. Best to check them once they are on the CF card and in your Z, that way there'll be no more copying and you can use Linux to ensure that Windows hasn't tacked on any extra file extensions (that said, I've never had any extensions stuck on - I have Explorere set to show all, etc.).

Here is the walk through from

Remember to hit the "Reset" again before you put the battery cover back on once you finish flashing.
hmm ok, well i flashed it again w/ theKompany rom and it worked, when i tried to flash to oz 3.2 and 3.3 i had checked the MD5 and downloaded to CF card directly, maybe i'll try again on a different CF card, thank you for all your responses!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.