Help - Search - Members - Calendar
Full Version: Forum Search
OESF Forums > Everything Else > Site Specific Forums > Site Suggestions, Requests, and Updates
w14
Is there any way the forum search can be improved?

For example, searching for "scp" returns no results. I can't believe no-one has mentioned scp in any post on these forums. I have come across several instances of searches returning no results since the forums moved to the current software.

Searching for "Zonet" has the same effect, despite having posted several times myself regarding these wifi cards.

We all would prefer that people search for the answers before posting commonly asked questions ad nausium, but that seems like a tricky proposition with the current software.

Mike.
offroadgeek
QUOTE(w14 @ Jul 25 2004, 02:03 PM)
Is there any way the forum search can be improved?

For example, searching for "scp" returns no results. I can't believe no-one has mentioned scp in any post on these forums. I have come across several instances of searches returning no results since the forums moved to the current software.

Searching for "Zonet" has the same effect, despite having posted several times myself regarding these wifi cards.

We all would prefer that people search for the answers before posting commonly asked questions ad nausium, but that seems like a tricky proposition with the current software.

Mike.

I get the same thing as you do with a search for "scp"... I'll look into that.

But when I search on "zonet", I get several posts returned. I'm not sure if I'm doing anything different than you. Check to make sure that you are searching "all forums", and not just the forum you were last browsing.

regards

offroadgeek
w14
Deleted ...

Mike.
offroadgeek
QUOTE(w14 @ Jul 25 2004, 11:46 PM)
Deleted ...

Mike.

what do you mean?
w14
I mean I was quite happily typing away, hit the Add Reply button, needed to edit what I had written, then remembered I had to return a rental car before I headed off to work ... I was in a bit of a rush ... London traffic etc ... figured I would explain later. Sorry ... <embarrassed>.

Anyway, you must be right and I was careless about searching, and didn't have the "Search all forums" selected in the case of Zonet.

Searching for ssh gets the same as scp, though. Is this linked to the more than three letters restriction there used to be?

Mike.
omega
would it be possible to have the search link to all-forums by default? I alos get the issue with ssh.
ajaustin
And it seems to me that the search ORs the keywords rather than ANDing them; which is not at all what you want to do to refine a search.
stbrock
The workaround for most search deficiencies is to go to Google advanced search, limit results to the ZUG URL, and use the Google search commands. You pick up results in how-to's etc. as well as in the forums, but that may often be a benefit.

The problems I've noticed with the native Forum Search include the "OR" default, which prevents you from narrowing searches, the refusal to search for three-letter words, i.e., XQt, and the inability to use quotes to search for a phrase.

If any of this can be improved without too much trouble by changing some configuration files, it would be appreciated.
ajaustin
stbrock wrote:

QUOTE
The workaround for most search deficiencies is to go to Google advanced search, limit results to the ZUG URL, and use the Google search commands. You pick up results in how-to's etc. as well as in the forums, but that may often be a benefit.


Excellent suggestion! This has helped me a lot. A proper on-forum solution would still be welcome, though.

Are we using the best BB software? Sites that I use with phpBB seem much better.
tumnus
QUOTE(offroadgeek @ Jul 25 2004, 11:39 PM)
I get the same thing as you do with a search for "scp"... I'll look into that.

But when I search on "zonet", I get several posts returned. I'm not sure if I'm doing anything different than you.

I think what may be happening is that the default minimum keyword length for this forum software is 4 characters. You did something to reduce the number of characters that it came back with an error for, but perhaps the search index is still only using keywords of 4 characters or more.
offroadgeek
QUOTE(tumnus @ Aug 17 2004, 12:53 AM)
QUOTE(offroadgeek @ Jul 25 2004, 11:39 PM)
I get the same thing as you do with a search for "scp"... I'll look into that.

But when I search on "zonet", I get several posts returned.  I'm not sure if I'm doing anything different than you.

I think what may be happening is that the default minimum keyword length for this forum software is 4 characters. You did something to reduce the number of characters that it came back with an error for, but perhaps the search index is still only using keywords of 4 characters or more.

there's actually two components I changed. a) rebuilt the mysql index to allow for 3 char searches, and cool.gif change the settings in the forum software to let it know that I changed the mysql db to allow for searches on 3 char.

for some reason though it's not picking up simple searches like 'scp'. i'll continue to look into it.
offroadgeek
QUOTE(ajaustin @ Aug 14 2004, 03:33 AM)
stbrock wrote:

QUOTE
The workaround for most search deficiencies is to go to Google advanced search, limit results to the ZUG URL, and use the Google search commands. You pick up results in how-to's etc. as well as in the forums, but that may often be a benefit.


Excellent suggestion! This has helped me a lot. A proper on-forum solution would still be welcome, though.

Are we using the best BB software? Sites that I use with phpBB seem much better.

phpbb is what we just moved from. While phpbb has decent searching capabilities, ipb forum software is much less buggy, and it actually handles the latest posts, etc. much better.
Pcghost
A search for 'thekompany' returns zero results. Strange..
Stubear
QUOTE(Pcghost @ Dec 8 2004, 02:35 AM)
A search for 'thekompany' returns zero results. Strange..

THat's cause it takes too long to write wink.gif

Try TKC instead

Stu
gojira
QUOTE(offroadgeek @ Aug 18 2004, 04:08 AM)
there's actually two components I changed.  a) rebuilt the mysql index to allow for 3 char searches, and cool.gif change the settings in the forum software to let it know that I changed the mysql db to allow for searches on 3 char.


How about changing it to 2, or at least mentioning the limit on the search or search results page? (I've been trying to search for problems involving CF cards...) Also, making it more clear that multiple words are automatically a phrase (which is a very unusual default behaviour for a search field) and that OR and AND are available would be nice too biggrin.gif

Thanks.
gojira
Also, I've been getting a lot of timeouts recently when following links in search results. Either this:
QUOTE
Fatal error: Maximum execution time of 30 seconds exceeded in /home/.bluebellblender/miamlh1/oesf.org/forums/sources/topics.php on line 814
or this:
QUOTE
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@oesf.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Stripping the "&hl=..." (which, incidently, includes "and" if AND was used in the search) off the URL seems to fix it, so maybe highlighting should be optional in searches.

Thanks.
lareya
Okay, so if google is better to search with, can you just put a google link on this forum? Like I have seen it on other sites where it says search this site. That would be the simplist for us end users. I too am having trouble searching for different things. I try, but it seems labor intensive. .....just a thought.

Lareya
gojira
QUOTE(lareya @ Feb 6 2005, 04:50 PM)
Okay, so if google is better to search with, can you just put a google link on this forum? Like I have seen it on other sites where it says search this site.  That would be the simplist for us end users.  I too am having trouble searching for different things.  I try, but it seems labor intensive.  .....just a thought. 
*


You can make a site search form or just use a link like this, but google's index is up to a month old and so may not show recent posts, so improving the local search is still worthwhile.
offroadgeek
The searching and the highlighting worked fine before the upgrade, so I think it's probably just a bug in the new version. I will report it to ipb to see if we can get a fix.

offroadgeek
clofland
Maybe this isn't new, but when I do a search and click on a thread that comes up in the search, 90% of the time I get this:

Fatal error: Maximum execution time of 30 seconds exceeded in /home/.bluebellblender/miamlh1/oesf.org/forums/sources/topics.php on line 816

Very annoying. I know the answer is out there, and it is trying to find me, but it keeps timing out . . .
xjqian
Search by Keywords: elog Filter by Member Name (optional): elog checked Match Exact Name

gave me error. However, elog search did return results (including: caselogic, etc) for me.
Miami_Bob
QUOTE(offroadgeek @ Feb 7 2005, 03:15 PM)
The searching and the highlighting worked fine before the upgrade, so I think it's probably just a bug in the new version.  I will report it to ipb to see if we can get a fix.

offroadgeek
*


Have noticed also that, if a search returns more that 1 page of hits, opening the additional pages in a new Opera page tab does not get the highlighting at all.

Minor but just so you are aware.
gojira
QUOTE(clofland @ Feb 9 2005, 08:55 AM)
Maybe this isn't new, but when I do a search and click on a thread that comes up in the search, 90% of the time I get this:

Fatal error: Maximum execution time of 30 seconds exceeded in /home/.bluebellblender/miamlh1/oesf.org/forums/sources/topics.php on line 816

Very annoying. I know the answer is out there, and it is trying to find me, but it keeps timing out . . .
*


See the workaround above.
xjqian
can you put a quick search input area, just as the one on the top right side in OE master page, in each forum (or page) that defauts to search in that forum? Do I make myself clear? unsure.gif
radioz
Is there any hope of fixing the search mechanism to implement 'AND' rather than 'OR'?

It really is a pain not being able to narrow searches down. As was mentioned, Google isn't a very easy approach.

radioz
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.