Help - Search - Members - Calendar
Full Version: /usr/QtPalmtop.rom permissions and slocate
OESF Portables Forum > Everything Else > Archived Forums > Zaurus General Forums > Desktop Operating Systems Issues > Linux Issues
On the SL-C860 with Sharp ROM:

Does anyone know why /usr/QtPalmtop.rom and its subdirectories don't have read and execute permissions for everybody? This is rather silly! This means that some setgid programs needing a library from it, like slocate, won't be able to run under the (default) zaurus account.

zaurus:~> locate
locate: error while loading shared libraries: cannot load shared object file: No such file or directory

Well, I get this when I run locate from Qkonsole, but not from a ssh connection (id outputs uid=500(zaurus) gid=500(qpe) in both cases), even when I set LD_LIBRARY_PATH to the same string. Any idea?
Are you sure it's a permissions problem and not a path problem?

On my 5600 with the Sharp ROM, everything under /usr/QtPalmtop.rom is readable and executable by root and anyone in the qpe group (which includes the zaurus user).

/usr/QtPalmtop.rom/lib isn't in the path at all because just about everything under there is linked from /home/QtPalmtop in one way or another, but for some reason the default shell doesn't have /home/QtPalmtop/lib in the path and only has /usr/lib . ssh and qkonsole may well be running different shells and hence may be getting different environments.

Have you tried putting /home/QtPalmtop/lib in the LD_LIBRARY_PATH variable?
I don't think it is a path problem. The PATH is the same (I checked that). By default, the LD_LIBRARY_PATH isn't the same, but modifying it so that it is the same doesn't change anything. I also thought about other environment variables, and modified them to have an almost identical environment, but again, this doesn't change anything.

Have you tried putting /home/QtPalmtop/lib in the LD_LIBRARY_PATH variable?

It already is in LD_LIBRARY_PATH (except with the ssh connection, where locate works very well). I think I'll need to install the strace package and see the differences...
I've install strace, but it doesn't provide any information since when I use "strace -o strace.out locate", I don't get any error!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.