Help - Search - Members - Calendar
Full Version: Xqt installation
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > X/Qt
NathanA
I am trying to install Xqt on my Zaurus SL-5500 and so far appear to be failing. I followed some instructions I found here (http://www.oesf.org/forums/index.php?showtopic=5381&st=15) which led me to install the following packages:

xqt-fonts-misc
xqt-server
glibc-locale-eucjp
xbase-etc
xlibs
xqt-startup-scripts
xbase-clients
blackbox
gdk-pixbuf
glib-addition
gtk

everything seemed to go smoothly, but when I run Start X, the icon sort of "lights up" but nothing noticeable happens (the icon stays bright until I run something else). If I run X/Qt Server, I get an x-win looking background with the X cursor that behaves strangely. If I enter a letter, the screen goes away and I'm back to Qtopia.

Running xinit from the terminal, I get:
CODE
xinit: No such file or directory (errno 2): no server "X" in PATH

Use the -- option, or make sure that /opt/QtPalmtop/bin is in your path and that "X" is a program or a link to the right type of server for your display.  Possible server names include:

[here there is a pause]

giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error.


I tried unistalling the locale and font ipks since that was a suggestion I read somewhere, but it didn't seem to help.

Any help would be appreciated. Thanks in advance,
Nathan
dhns
I have learned that you have to install Xqt server 0.0.8 and not 0.0.9 on the 5500 series.

-- hns
lardman
@NathanA: Which ROM are you using? If it's OZ then I made some posts a while back about how I got it working - you need to move the files from /home/zaurus to /root and chmod +x the x11r6 (I think) file somewhere under /etc.


Si
NathanA
Okay, I installed X-server 0.0.8 and that seemed to make the cursor behave correctly.

I still can't "startx" or "xinit", though. Here's what I'm trying to do. I need to log in via ssh to a remote linux computer (I can do this) and run an application on the host computer and view the display on the Zaurus. I'm able to do this from another desktop running linux, but the PDA says 'unable to open display ""'.

I'm using ROM Version 2.38.

Thanks,
Nathan
NathanA
What is supposed to happen when I launch "Start X" or "X/Qt Server" from the applications menu?
Bedman
Startx or xinit look for a filename called X but Xqt-server provides only the Xqt binary. So make a symlink from X->Xqt startx will work!

Bedman
NathanA
Excellent, that was easy.

So now XQt seems to be functioning properly, and I can even run my application over ssh like I wanted.

The problem is that everything goes off the screen, like it's using the wrong resolution maybe? Anybody know a fix?

Also, I can't seem to use the software keyboard. Whenever I do, the Xserver goes away

--Nathan
jfv
This is a HowTo for installing and running X/Qt. All this information is probably in the discussion threads but I found them too meandering to be useful.

It is heavily based on a HowTo that I found on the German forum Z-portal Info by JoPeters with some additions by Chris. I used babelfish to translate it to English, tested the instructions on a C860 with the Sharp ROM, fixed some of the translation and added a few things. It worked for me. I tried to put it in the ZUG howtos area but it wouldn't let me log in.

You need to download and install the following packages from the X/Qt site. Make sure to install the packages in that order. The package installer complains of some dependencies but installs everything. I have installed them all in internal flash. According to the very terse howto in here one can install a couple (but not all) of these packages in an ext2-formatted SD card, but I have not tried and JoPeters reported difficulties on the German forum.

1. xqt-fonts-misc
2. xqt-server
3. glibc-locale
4. xbase-etc
5. xlibs
6. xqt-startup-scripts
7. xbase-client
8. blackbox
9. rxvt

After installation two new icons appear on the applications tab:
X/QT server (starts the X/QT server and makes it possible to connect to an
external x server) and
Start X (starts a local x-server and makes it possible for X programs to run)

Start X can also be started from the console:
$ cd /opt/QtPalmtop/bin
$ ./startx-wrapper

In case you don't succeed to start X/QT, you must be sure to kill the running X/QT processes before trying again, otherwise there is no chance that X/QT will run.

I used the Start X icon. One must first disable starting with magnified screen by tap and holding the icon, otherwise it comes out in portrait mode. It takes a little while to start up but once it does you will get a grey background and an rxvt terminal window. Then you can run your X applications from the command line. I tried some Tcl-Tk scripts using tclkit, they seem to run fine but some of them came out too big.

To get out of X and get back to Qt press the menu button on the keyboard and select shutdown from the menu the pops up.

Felipe
myotis
HELP!
I got the Xqt installed on an 5600 with original ROM but the screen parameters are were incorrect.
1. The screen is rotated
2. The screen is devided into two parts the physical screen boundary is not alligned with the virtual screen boundary.
3. The screen is not updated, I need to tap severeal times on the screen and where the pen hits the screen, the "new" contend of that precise spot is shown.

Has anyone observed the same?
and knows a fix, or at least where to find the config-file??


Thanks


Myotis
Karlos
myotis,

If you haven't already done so, try downgrading the xqt-server package to 0.08.
myotis
Thaks,
xqt-server 0.0.8 works fine :-)

myotis
Greg2
@jfv... thanks for the how-to

I had some extra time today so I installed this on my 5600. I have it running on top the sharp rom v1.32 and the special kernel v1.3...works great. (you still need to use the xqt-server _ 0.0.8 on a 5600)

Just one question... can someone translate the rxvt dropdown menu for me?

Thanks,

Greg

I will attach it here
lardman
Did you install one of the japanese localisation files (glibc-locale perhaps?).

I've never had menus in Japanese.


Si
Greg2
QUOTE(lardman @ Oct 18 2004, 05:27 AM)
Did you install one of the japanese localisation files (glibc-locale perhaps?).

Yes I did... it was in the howto I used in this thread. Does it work without it?

When I resize the windows and use fullscreen it looks and works just like my desktop with blackbox or fluxbox... except the configuration menus are in Japanese. I would give you a screenshot except I can't seem to figure out how to do that in fullscreen.

I would really like to find a fix for this or an interpretation to English.
(translation by Stubear maybe?)

Greg
rolleyes.gif
lardman
QUOTE
Does it work without it?


Yes should do. I didn't install anything with 'jp' in the name.

That said, I'm not sure where the text is stored and it may be that you have a Japanese version of rxvt? Anyone know anything about this?


Si
Greg2
Thanks lardman, I will make some changes later this evening when I have more time.

I will attach a screenshot of my 5600 with it's new look to show you more configuration menus in Japanese... I have been slowly figuring it out.

Greg smile.gif
Greg2
QUOTE(lardman @ Oct 18 2004, 05:27 AM)
Did you install one of the japanese localisation files (glibc-locale perhaps?).

You were right lardman... I have removed glibc-local and installed glib-additional.
Now almost everything is in English and it still works...Thanks

Greg smile.gif
ArchiMark
I found that there are 2 different 'glibc-locale' files on the download page listed below. Item number 3 in the quote below just refers to a 'glibc-locale' file....

The 2 files are:

glibc-locale-ja-eucjp_2.2.2-1_arm.ipk

glibc-locale-ja-utf8_2.2.2-1_arm.ipk

Can anyone clarify as to whether I need to install both of them or just one?

If one only, which one??

Thanks!

Mark

QUOTE(jfv @ Sep 6 2004, 12:48 PM)
This is a HowTo for installing and running X/Qt. All this information is probably in the discussion threads but I found them too meandering to be useful.
[SNIP]
You need to download and install the following packages from the X/Qt site. Make sure to install the packages in that order.
[SNIP]

1. xqt-fonts-misc
2. xqt-server
3. glibc-locale
4. xbase-etc
5. xlibs
6. xqt-startup-scripts
7. xbase-client
8. blackbox
9. rxvt

[SNIP]

Felipe
*
jfv
It's the eucjp one.

Felipe
ArchiMark
THANKS for clarifying, Felipe!

Mark


QUOTE(jfv @ Apr 15 2005, 05:47 PM)
It's the eucjp one.

Felipe
*
Ragnorok
QUOTE
You need to download and install the following packages from the X/Qt site.

Sourceforge.org is now "sf.net", with all the negativity that M$ monniker implies. Any links to it for download appear to be broken now; dozens from here and from killfilz.

- I've been trying to d/l and install X/Qt, but it's just not happening. I don't appear to have any of the files listed in the "HowTo" that jfv put in, because I can't get to any links to download anything. When I go directly to "sourceforge.org", I get redirected to "sourceforge.net", and searching for XQt and or X/Qt yields no files found, at least none relating to what I'm looking for. What gives?? Sourceforge, as it looks today, is patently useless.

- It's funny how literally seconds after posting about something, I always find the answer!! (smirk) The URL listed doesn't work, for some reason, but by backing up to "http://xqt.sourceforge.jp", I can follow links to reach the download area, and lo and behold, everything's right there. Go figure! (drool)

- Maybe sf.net being so ugly to use is why the link went to sf.jp to begin with (grin)...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.