Help - Search - Members - Calendar
Full Version: GPS and the 6000L
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 6000 - Tosa
duffman
But has anyone found any USB GPS devices (yes I know most are serial now) that work with the Zaurus? I don't want to end up buying one just to find out it won't work.
lwong
I would really want to know if someone can make it to work too. I have my eyes on the Delorme Earthmate for some time now....

And the follow nup question would be: if USB DOES does work, what do you do about mapping software? I still haven;t figure out how to create maps for qpeGPS.

Eagerly awaiting response,

FW
mdweezer
I would just settle for a standalone, handheld GPS.

I own a Magellen Meridian that I bought for $110, it has 100x the features of my buddy and his pocketPC w/gps card. Mine has a searial interface that I can use with my laptop to use with Microsoft Streets and Trips or I can just use the GPS by itself. It floats in water and has super long battery life.

Not to mention its fun to go geocaching with smile.gif www.geocaching.com

Get something that'll interface with a PC and you'll be set, with the lack of mapping software and the short battery life of the Z, you could spend less on a standalone GPS and you would have a much better time
dmilligan
I purchased a BC-307 compact flash model - works with the 5600 and my laptop. Using qpegps on the Z and MS Streets & Trips on my laptop.
lwong
My primary purpose for having a GPS will be for in car navigation. In this context, not even the $1000 Megellen can rival the display on a SL6000 or on a laptop. If I use GPS frequently for hiking etc, a handhled will make more sense just like you suggested.

The major attraction for Earthmate is that I can plug it intp Z or a laptop depending on the circumstances. It even comes with a copy of Street Atlas. But of course someone has to do the hard work to convert the map into a Z-friendly format.

FW


QUOTE
I would just settle for a standalone, handheld GPS.

I own a Magellen Meridian that I bought for $110, it has 100x the features of my buddy and his pocketPC w/gps card.  Mine has a searial interface that I can use with my laptop to use with Microsoft Streets and Trips or I can just use the GPS by itself.  It floats in water and has super long battery life.

Not to mention its fun to go geocaching with smile.gif www.geocaching.com

Get something that'll interface with a PC and you'll be set, with the lack of mapping software and the short battery life of the Z, you could spend less on a standalone GPS and you would have a much better time
jerbell
I don't have a usb cable that fits the 6000, but I use a serial gps handheld with a USB to serial adopter cable on my laptop running linux. I'm hoping that when I get the 6000 usb cable it will work so I can access the keyboard while using it, which you can't do when using the serial port.
duffman
Well I've found a GPS CF adapter that is recognized in my 6000L (can see it in system info) bu I don't knwo what device (in /dev) corresponds to teh CF port, anyone know?
lardman
Assuming it's the same as on the 5500, and assuming I've remembered correctly then try /dev/ttyS3


Si
dsavard
I am looking forward to buy a GPS to integrate with my Zaurus 6000L and I would like to know if anybody here is having some experience with GPS and the Zaurus.

Seems to me there is two options to consider:

- CompactFlash GPS Card
- Bluetooth enabled GPS with a CF Bluetooth card

On the software side, what kind of SW is available for the Zaurus and how easy will it be to integrate?

Pros and cons for each alternative? Gotchas?

Brands known to work well or not work?

Thanks
bazmi
hi,

i use an ambicom CF GPS (with an external antenna when in the car) and it works good. use zGPS. prioir to ambicom, i used a pharos CF GPS but it died while still under warranty but couldnt get a replacement and just gave up on it.

regarding bluetooth, my advice would be to stay away from it as much as possible - i think that it is really a failed technology - none of my bluetooth devices whether it is my phone/headset combination or usb dongles or CF bluetooth work reliably in any OS - whether windoze, linux or symbian. the connection is at best flaky and even when it is there it is excruciatingly slow.

cheers,

/bazmi.
Zuber
I have a bluetooth phone, bluetooth card in my Zaurus and use a Bluetooth GPS unit.

All work well together. Used to use the last Bluetooth phone with my PC as well, and though fiddly to set up, that used to work fine as well. Not got round to setting up the new phone software on the PC yet.

But Bluetooth failed technology... Just a tad strong.

Anyway, one thing worth considering in deciding between CF v BT GPS unit. How you intend to use it.

e.g.
If you tend to use the device landscape, then you tend to find it pointing the wrong way for a CF card.

If you are out hiking, might find it more hassle carrying 2 seperate units if you go for a BT card. Stick it on the backpack ?

If you use in a car, then I find it quite nice being able to leave the BT GPS unit on the dash (good GPS signal) while using the Zaurus.

I found with GPS units, having them close to the windscreen makes a big diference.

With BT unit, not a problem, can pick up, put down Zaurus as I wish. With CF unit, you would probably be fixed in one spot.

My big issue at present, is I have a mounting kit for the C860 which mounts horizontal, so rules out a CF card for me.

By the way, tried all the units on our site and they work fine with the Zaurus Cxx models and the 5500. Not sure about the 6000, but can't see any reason why they should be different. Especially BT, since you are just using Serial profile.

So Haicom MMF, Holux BT and GlobalSat BT should be ok.
grom
Hello, this week I bought a Hollux GM-270 CF GPS reciever. I pluged it in my zaurus, and ... nothing happend sad.gif
I searched help on internet and a found a page about the SL-5500G. So they suggest to recompile the pcmcia_cs module, but in my SL-6000L there is no pcmcia_cs module sad.gif Perhaps I'm on the wrong way, but in a first time, I'll try to flash the ROM with a newest image and, if there is the same problem try to rebuilt the module or all the kernel.
Has somebody another idea?

thanks for your help
grom
cdollar393
I just got an ambicom cf gps for my sl-6000. Not sure of the differences between units, but I had to issue the command 'cardctl resume' from a terminal to get the gps to power on. From what I understand, the Z automatically puts the CF gps in suspend mode, and the resume command wakes it up. Once I had it resumed the lights on the gps came on and all worked fine.
jansenq
Hi there,

I'm also having a few problems with a cf GPS card (Rayming TN202).

I did find the serial_cs module on the net, and loaded that. After a wack of playing around, I had the card working just fine. Don't know how, as I have never been able to get it to work again.

The cf card works just fine when I plug it into my laptop via the pcmcia port.

When it is plugged into the Z it is turned on right away. The Z thinks it is an anonymous memory card for some reason.

Where to get the latest ROM? I've still got the stock ROM (brand new unit), and have searched high and low for an english ROM with no luck.

Any body got any suggestions?

Thanks,

Quinton
AsLan^
I have the Ambicom CF GPS, it works well with zgps.

If you are having ttrouble getting yours to turn on, I would suggest trying to run gpsd from the command line and passing different arguments for the serial port device until you find which one its using. My card is using serial port device 3 so I would type...

gpsd -p /dev/ttyS3 -s 4800

the -s 4800 is the baud rate of the card, after issuing this command with the right parameters the card should turn on. zgps should do this for you though.

Does anyone know of a gps program that will output in MGRS (military grid reference system) I was hoping to use this for work but lat/longs are useless to me.

Or perhaps does anyone know of a gps program that will output to the standard out so I could write a scipt to automatically convert between lat/long and MGRS ?
jansenq
hmm been there, done that.

the gps is on and functional. it has a gps lock and everything. just need to get the silly serial port up.
Gaines
I second the objection about bluetooth. I love being able to access the internet using my cell phone without cables. I haven't set it up yet on my 6k since it doesn't have internal bluetooth and I haven't gotten my Belkin CF card working yet (see other thread).

As for GPS, I happen to have the Pharos iGPS-CF. It worked great with my iPAQ, but I'm getting a bit worried as I look for software for the 6k. I was using Mapopolis which meant I could download maps (no scanning in images), look up points of interest or addresses, generate a route from my present location to the POI/address, see directions to my route in both text and drawn on the map, and hear audio prompts as I drove. So far the GPS software options for the 6k are looking pretty shoddy...but I'd love to be proven wrong. Anyone?
Gaines
As I mentioned here, I have the Pharos iGPS-CF which worked fine on my iPAQ, but I haven't been able to get it working wiht my 6k. Any tips?
BarryW
Look here, http://seclists.org/lists/fulldisclosure/2004/Oct/0310.html They modified the product id in the hardware with the serial to usb cable. They may have done the same with the cf card. So the gps will power up and everything but the Z doesn't know what drivers to use. I'm currently doing a kernel recompile to fix mine on my laptop.
dsavard
I got the Haicom MMF GPS and it's working fine. I am using zGPS, but as Gaines said, not really impressive. My problem is I didn't find good maps. Since I am not in the USA, I cannot use the maps pointed to by zRoadmap and others.

I found very good maps, but unusable since encrypted and used to be used in conjunction with the editor's software running only on Windows or Windows CE.

Is there any resources on the web to learn maps formats and howto produce them?
lardman
QUOTE
Seems to me there is two options to consider:

- CompactFlash GPS Card
- Bluetooth enabled GPS with a CF Bluetooth card


What about a plain serial link?

Si
DrWily
I was just wondering if anyone has tried hooking up a USB GPS reciever to their Z, or if an adaptor even exists that would convert a USB cable to the size a 6000 could handle.
lwong
I tried the Delorme USB GPS before but didn;t work. Zaurus think it's a HID device. I later read in some GPS forums that the Delorme somehow "cheated" in their config.

Frank W
mjalkut
I've connected a garmin using the SerialIO RS-232 connector.

http://www.serialio.com/products/adaptors/ZThinCable.htm

I was able to read the satelite data with qgps. I only wish I could get better map software for Z. Ideally, I wish I could read the screen bitmap from the Garmin and just duplicate it on the Z. Some time back I thought I saw a Mac or PC gps program that had decyphered enough of the Gramin protocol and knew the secret codes to request a bitmat dump from the garmin. I can't find it anymore though.
jansenq
Hi Guys and Gals...

Just got the ambicom cf-gps.

Plug it in, see the serial port in dmesg

start gpsd -p /dev/ttyS3 -s 4800
telnet localhost 2947
hit r

get a whole bunch of giberish. can't make anything out.

tried zgps, both nmea and sirf mode... nothing.

I did plug the unit into a windows laptop, ran the diag util and saw a bunch of nmea sentences flowing.

Any hints/suggestions?

Thanks,

Quinton
cdollar393
I am using an ambicom cf-gps with qpegps on my sl6000 and it works great. Haven't tried zgps.

QUOTE
Plug it in, see the serial port in dmesg

start gpsd -p /dev/ttyS3 -s 4800
telnet localhost 2947
hit r


Not sure if it is required in your case, but when I start gpsd from the command line I first have to issue a 'cardctl resume' to get the gps to power on and see the blue status light. But if you are seeing lots of messages when you telnet in then you probably are catching that step somewhere.
jansenq
Hmmm...

Maybe I've messed something up then.

Any chance someone can tar up their /etc/pcmcia for me?

(That would be a stock 6000L, with sharp rom.)
chaosteo
Hi Bamzi

What maps software you use with your Ambicom CF GPS card?

thx
chaosteo
Anyone try this software called GPSDrive on their Zaurus ?

GPSDrive Link ph34r.gif
freshroastedpeanut
I would be very interested in hearing about any success with GPSDrive. I use it frequently with my laptop and really hope to get it running with the Z soon. Haven't seen any iplks though, so off to figure out xqt/deb...
geminiabode
i did a google search and came across Zaurus GPS receiver GPS-BR305-Z6
http://serialio.com/products/adaptors/GPS_BR305_Z6.htm

Does anyone have experience with this one as to how it is ?
Also any good map software for the Z like iGuidance v2?
lardman
I have something very similar to this (it uses a ps2 connector, has a magnetic base, and is about the same size and shape). It works fine, though I need to use external power (I spliced in a battery pack to the serial cable (which I had to make).

IMHO, these are far more useful than the CF GPSes as you can then stash your Z somewhere safe and have the GPS in a useful location.

Mine is a Haicom 203e.


Si
freshroastedpeanut
WEll, the ambicom GPS is on its' way from Amazon, I'll let you know how it works.

Here's a teaser: GPSDrive running on the Z, in a VNC session from the PocketWorkstation Debian distro. It doesn't look too bad at all... wink.gif


Cheers, JJ
chaosteo
GPSDrive looks sweet man.. wait for me to get my storage card and ready to install Debian with help from you guys... btw, I was bidding on Ebay for Ambicom gps card ( the old version, the working version) but the bid went to high so off looking for somehting else
BarryW
Anybody get gpsdrive to work natively on the z? I had it on my iPaq when it was flashed with opie.
dsavard
Just to clarify about the HaiCOM 303 MMF CF GPS, this is the one I finally bought, the GPS is foldable and it is coming with an external antenna mounted on a magnet that you can plug in the CF module. So, it is possible to mount the antenna on a backpack, car top, etc and keep the Z in your hands or secured somewhere else. The wire is about 6 ft long and I think the magnet is strong enough to hold the antenna module on the top of a car on a highway (I assume you respect speed limits and there is limits and your car is not a F1).
bazmi
QUOTE(chaosteo @ Nov 28 2004, 09:11 PM)
Hi Bamzi

What maps software you use with your Ambicom CF GPS card?

thx

since i live in india there arent any gps usable maps around so i use a combination of scanned maps for my city(bangalore) along with some maps i downloaded from the net. the software i currently use is qpeGPS which has an option of importing maps. it isnt the best solution but its the best i could manage.

hope this helps.

cheers

/bazmi.
chaosteo
Somone help me out ( i have a SL6000 )

I got a socket rev f and socket bluetooth gps .. anyone knows how to set it up properly to work with qpegps [ it works with zgps after rebooting, able to fix my current postion]

here is my setting qpegps , config> arug -> -p /dev/rfcomm1 localhost port 2947
running qpegps 0.9.2.1 pre and the data status window, it says gpsd ??? .. gps ??? Mp GMT signal received

I already did the following

modify and add the following to rfcomm.conf ( already have rfcomm0 for nokia 6230)
rfcomm1 {
# Automatically bind the device at startup
bind yes;
# Bluetooth address of the device - get from 'hcitool scan'
device xx:xx:xx:xx:xx:xx;
# RFCOMM channel for the connection
channel 1;
# Description of the connection
comment "Socket GPS";
}

both hciconfig and sdptool browse. returns good status of bluetooth cf card and found the network address of bluetooth gps... but i just cannot get them connected or set them up properly in qpegps
pelrun
Sounds like gpsd isn't starting properly.

Try starting gpsd from the commandline "gpsd -p /dev/rfcomm1 -s <baudrate>" then "telnet localhost 2947" to test. If that works then your qpegps configuration is broken. Since you have zgps working, use whatever baudrate it's set at for the -s option above.

My gpsd line in the qpegps config is "-p /dev/rfcomm0 -s 38400"; the localhost and 2974 go in different fields. Haven't had any problems at all.
freshroastedpeanut
A quick reply:

Here's a shot of the Z running GPSDrive under Xqt/Debian. Hatchetman set me straight on how to set up the tty in the chrooted Debian environment so that gpsd would see the GPS on /dev/ttyS3- see here.

So now I chroot and launch gpsd inside the debroot environment. I have also installed mysql for logging wireless APs, again this was done inside the debian chroot. Now that mysql and the GPSDrive gpsd are running I can exit back out of the chroot and launch kismet- woohoo, GPS shows up across the bottom!

Lastly, launching the X/qt and chrooting back into Debian, GPSDrive can be run which will automatically talk to Kismet, gpsd, and MySQL to log any APs you see. The screenshot below shows the stock map (haven't got around to downloading the ones for my area) and some APs I ran across ont eh way home. WooHoo!
neuroshock
freshroastedpeanut ,

Please do me a HUGE favor and when you get a local map setup please give us a screenshot so we can see what it looks like at street level in an urban environment. Also is the map zoomable in GPSDrive? If it proves useful I'm finally going to have to quit shying away from Debian/xqt and make the plunge.

As always thanks a bunch,


-NeuroShock
ken
http://gpsdrive.kraftvoll.at/screenshots.shtml

I would think it'd be like the screenshots
freshroastedpeanut
Hi Ken, Neuroshock,

Sorry I can't currently post piccies - "borrowing" wifi whilst on vacation, but the program is just like Ken posted. GPSdrive takes gif images from expedia and you can download at many different scales to get the detail level you need. The automatic wifi point logging and mysql waypoint management are really sweet. The only thing lacking is good autorouting- it will even use festival to speak directions to you, although I don't know how well that works on an already taxed Z.

Cheers all!

JJ
unplug
I just got Haicom 3033 GPS receiver and was trying to setup GPSDrive. According to readme, I need:
GTK-+2.3 (xqt feed)
pango (xqt feed)
atk (xqt feed)
pcre (??)
xdevel (??)
gettext (??)
libcrypt (??)
glibc (has two in xqt feed)

Where can I find some of those packages? Is there a good instructions about setup GPSDrive?
delta-9
I use a Fortuna U2 USB GPS running on my 6000L

I got a 5-pin USB mini to USB adaptor but had to file away a little of the adaptor to get it to fit
(www.maplin.co.uk Part No A80AH USB AF/Mini USB 5PM)

The U2 needs the pl2303.o kernel module - I had to compile this myself.
the_oak
Making the Globalsat BC-307 Compact Flash GPS device work with Sharp Zaurus SL-6000L using default Sharp ROM version 1.12 and 2.4.18-rmk7-pxa3-embedix
kernel

Preface:
I read here at oesf.org/forums that the Globalsat BC-307 CF GPS worked with the Sharp Zaurus SL-6000L, so I bought one off eBay. When it arrived I expectantly inserted it and......nothing happened!! So off I went to the forums to find out how to make this thing work. That was not as easy as it could have been. Determinedly, I Googled til my fingers bled and compiled the following howto from numerous scattered sources. It is not my intention to take credit for someone else's work, but many of the webpages do not really give much info about whose ideas were there. The following is just a collection of things from user forums, sourceforge.net, this forum, and other places. If I have not given credit where it is due, please let me know and I will edit the info to give proper credit.

1) Software that will help you:
qkonsole (version 0.9.3-20040205) (got it at http://www.zaurususergroup.org/feed/ )
qpegps (version 0.9.2.3) (also at http://www.zaurususergroup.org/feed/ )
treeexplorer (version 1.7.0-2) (also at http://www.zaurususergroup.org/feed/ )

2) First you need to download the serial_cs.o.gz module. I found it at:
http://www.iral.com/~albertr/linux/misc
For those of you who are more talented than me, I would suppose that you can find the source code and compile it yourself. I will also check to see if I can upload this module to the http://www.elsix.org , but I'm not sure if that is a problem with the guy (presumably albert r) who precompiled this and made it available at the above site.

3) I use qkonsole and su to root and cd to folder where you downloaded the module, and type:
gunzip serial_cs.o.gz

4) Create "char" folder in /lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers :
mkdir /lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/char

5) Create "pcmcia" folder inside the "char" folder:
mkdir /lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/char/pcmcia

6) Copy this module to the appropriate Zaurus drivers folder with this command:
cp serial_cs.o /lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/char/pcmcia

7) OR, you can do this much easier with treeexplorer by navigating to the above-mentioned drivers folder and highlighting it and selecting File > New > Folder and naming the folder ("char" and "pcmcia" inside the "char" folder). You can then highlight the folder or files and change ownership and permissions using File > Properties > Security tab. Make the owner "root", and group "root". Give "read" and "execute" permissions to everyone and "write" permission only to "owner".

If you want to do things the old-fashioned way, then cd to the above-mentioned drivers folder and type (as root):
chown root:root /char
chown root:root /char/pcmcia
chown root:root /char/pcmcia/serial_cs.o
chmod 775 /char
chmod 775 /char/pcmcia
chmod 775 /char/pcmcia/serial_cs.o

8) Now restart your Zaurus

9) In qkonsole, su to root and type:
modprobe serial_cs
(or use insmod if modprobe doesn't work)
If someone knows how to add this to some file to make it start automatically, let me know and I will edit this howto to show that info.

10) Start qpegps *without* inserting the CF GPS device.

11) It will complain that it "Cannot connect to GPS". This is because it is trying to connect to the wrong serial port. (Also because it is not yet plugged in). Click the "Ignore" button. Insert the BC-307 card into the CF slot. On the GPS tab change the device to /dev/ttyS3 then either hit the return key on keyboard or the chrome "OK" button on the front of the Zarus. If you have ejected a CF memory card since restarting the Z, then you may have to start qkonsole, without closing qpegps, and issue the command:
cardctl resume
The red light on the BC-307 should come on and blink.

12) Now close qkonsole, and hit the chrome "OK" button and wait for a bit. It may take 20 or 30 seconds to work. You can hit the "OK" button again if necessary, repeat until you see latitude and longitude for your location on the GPS tab. But wait a little between hitting the "OK" button, as the GPS takes a little time to start working. These results are reproducible for me.

13) GOTCHAS:
If you eject the GPS card, then reinsert it, it will *not* just work. You may have to do the following as root:
rmmod serial_cs
modprobe serial_cs
Then start qpegps *without* inserting GPS card, hit "IGNORE" button. Open qkonsole (again without closing qpegps) and type:
cardctl resume
Then close qkonsole and hit the chrome "OK" button again. If worse comes to worse, just restart the Zaurus and go back to step 9

If anyone knows a way to avoid these gotchas when removing and reinserting the card, or how to make this easier, just let me know, and I will include
that info also.

Helpful info: You can download maps from Expedia.com within the qpegps program. Make sure that you download the maps to an SD card, as maps can overfill your internal storage quickly. I created a "maps" folder on my SD card and pointed the download folder to that.
Just start your wifi connection and on the "info" tab, click on "download" at the bottom of page. Select "Download few maps cover area from expedia" and you can set the program to get maps of various resolutions, scales, and diferent sized areas from the latitude and logitude that you input. Or just let the GPS load the latitude and logitude of your current location. This may take quite a while depending on the size and resolution of the maps you are downloading. It may appear that the Zaurus is locked up, but it is just slowly downloading maps. You may want to start with small area maps at first just to play with it and get used to how it works.

EDIT:
Added the following to get serial_cs module to automatically load on reboot:

I wrote a script (seems wrong to call a two-liner a script) as follows:
CODE
#!/bin/bash
insmod serial_cs


I saved it at /etc/rc.d/rc5.d naming the file S49serial_cs
I believe the scripts in this directory are only executed if they begin with an "S" and some number. I presume that the number determines the order in which the scripts are executed, so I gave it a number higher than the rest. (After all it has been previously loaded after the zaurus boots completely.) Also don't forget to make the owner and group of the file root and make it executable, with these commands:

chown root /etc/rc.d/rc5.d/S49serial_cs
chgrp root /etc/rc.d/rc5.d/S49serial_cs
chmod 755 /etc/rc.d/rc5.d/S49serial_cs

Or easier yet, use TreeExplorer File>Properties>Security to change all that stuff.
the_oak
Just so everyone knows, I have edited the above post to include autoloading the serial_cs module on reboot.

Thanks to lardman for info on where to put the script.
rmako
Can you give me some idea how to do this or to get the driver to work. Also trying to get a USB GPS to work.

Thanks,


Bob Makowsky

QUOTE(delta-9 @ Jun 13 2005, 10:31 AM)
I use a Fortuna U2 USB GPS running on my 6000L

I got a 5-pin USB mini to  USB adaptor but had to file away a little of the adaptor to get it to fit
(www.maplin.co.uk Part No A80AH USB AF/Mini USB 5PM)

The U2 needs the pl2303.o kernel module - I had to compile this myself.
*
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.