Help - Search - Members - Calendar
Full Version: dev-img-1.5 tmake
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Qt/Qtopia
angst
I've been trying to set up dev-img-1.5 on my sl6000's ext2 SD card. The cramfs is mounted at /mnt/dev as the instructions say and image_setup.sh completes with no complaints.

I had to add /home/zaurus/develop/bin to the path in /home/QtPalmtop/qpe.sh in order to use g++ and gcc. Small hello world programs compile fine with both.

The problem is that I cannot find tmake anywhere on my zaurus. There are some tmake docs but no executable that i can find. I mounted another copy of dev-img-1.5 on my cf card and searched it with no luck either.

Any ideas? Suggestions?

TIA
clivel
Hi,
You can get Tmake from ftp://ftp.trolltech.com/freebies/tmake/.
Although, if I recall correctly it is written in Perl, which means that you will have to have Perl installed to run it.
Regards,
Clive
angst
Okay. Thanks, clivel. Seeing the tmake docs in the img made me think tmake was in the image.

dev_img-1.5 already has perl 5.8 in it. It spits out the version number when asked though it also complains about some locale (lang, money...) settings. I don't know enough about perl yet to test it out thoroughly.

Thanks.
iamasmith
The locale warning can be got rid of by exporting the variable PERL_BADLANG=0.

I would suggest adding a line to /opt/Qtopia/bin/qpe.sh with the other exports to do this as .bashrc doesn't seem to run when you first start terminal but qpe.sh does.
freizugheit
Angst,

Thanks for the pointer for the location of Perl 5.8.0.

As tmake requires perl to be under /usr/bin, the following step help check dev-img-1.5 installaion and acitvate symbolic linkage for perl :

- To check the installation by typing "which make", it should show "/mnt/card/.zgcc/bin/make" for my case

- To activate symbolic linkage for perl:

ln -s /mnt/card/perl/perl5.8.0/bin/perl /usr/bin/perl

The following has been tested with the t1 tutorial from qt.

- Type "tmake t1.pro > Makefile"
- Type "make" to compile and link the program and the resultant file is t1
- Type "./t1" to activate your qt application.


Voila!!!!
angst
Thanks for the tips iamasmith, freizugheit. I'll get this thing working properly sooner or later. Hopefully sooner than later.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.