Help - Search - Members - Calendar
Full Version: SD card not being auto-mounted
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Cxx0 Hardware
brouhaha
I posted this on another Zaurus board with zero response, so...

It's been a while since I last used my Zaurus (760). I had some obscure ROM on it before that caused me problems and I just quit using it for a while.

A few days ago, I decided to pick it up again and I installed the latest Cacko ROM.

This evening, I stuck my SD card into the slot to install some IPK's and I found that my zaurus is no longer recognizing my SD card.

I only have a single card, so I can't check others, but I know the card is still working with my desktop.

Any ideas? When I put the card in, NOTHING happens. And it never appears under "My Zaurus".
Ganda1f
QUOTE(brouhaha @ Sep 7 2004, 06:03 AM)
I posted this on another Zaurus board with zero response, so...

<skipped>

Any ideas?

I read this on another Zaurus board and responded smile.gif

Well, about "any ideas". After long investigations I got the conclusion that there is some inconsistency between the native driver (aka sharp_mmcsd_m.o) and SD cards protocol, and maybe Zaurus's MMC controller. I had a lot of troubles with some sorts of SD cards until I wrote my own driver. The cards started to work properly and my first reaction was "Aha!!! It's a buggy driver!". Then I was curious what was wrong with Sharp's driver. After disassembling and in-depth exploration I must say that it's the SD cards who is guilty. A lot of them
just don't support or incorrectly perform some commands. With my driver everithing is ok because during debugging I just avoided these commands. Or maybe the problem is in the MMC controller itself...

So, if you still have troubles (and maybe someone else) I can share it for experiments. For now I am intensively using KINGMAX 256M SD card partitioned on two volumes of even sizes. The first one is FAT16, the second partition is ext2.
technojunkie
ganda1f,

what model z did you build your driver for? could you post a link for others to try?
lareya
Yeah please post,

I would like to try your driver, otherwise i just have a read-only card now (1gb) not sandisk card.

lareya
iamasmith
QUOTE(Ganda1f @ Sep 29 2004, 02:14 PM)
I had a lot of troubles with some sorts of SD cards until I wrote my own driver. The cards started to work properly and my first reaction was "Aha!!! It's a buggy driver!". Then I was curious what was wrong with Sharp's driver. After disassembling and in-depth exploration I must say that it's the SD cards who is guilty. A lot of them

Oooh, could you pass on the info for your driver to the OZ guys, I'm sure they would really appreciate some help with removing some of these binary only bits of the Kernel.

- Andy
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.