Help - Search - Members - Calendar
Full Version: Software for openZ 3.3.6-pre1 or 3.3.5
OESF Forums > General Forums > Desktop Operating Systems Issues > Linux Issues
cybrjackle
Title says it all. I've installed this, seems to run ok for the most part but any .ipk's I download and try to install end up with an error.

CODE
Packages was terminated due to signal code SIGSEGV


Is 3.2 just the best rom to install for the 5500? For Linux compatiblity and all?

thx
cybrjackle
Ok, ssh in and did some more digging and it seem my file system is full.....


CODE
# ipkg install ssh-client_3.6.1p1-7_armv4l-strongarm.ipk
ipkg_conf_write_status_files: Can't open status file: /usr/lib/ipkg/status for writing: No space left on device
ipkg_conf_write_status_files: Can't open status file: /mnt/card/usr/lib/ipkg/status for writing: No space left on device
SIGSEGV
# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/mtdblock4           14.1M     14.1M     68.0k 100% /
/dev/mtdblock6           31.0M     18.0k     29.4M   0% /mnt/ram
/dev/hda1               244.0M    556.0k    243.4M   0% /mnt/cf
cybrjackle
So if / is taken up and I really haven't done anything with this, what can I do? Should I use the 32-32 image?
Teletubbie
According to your mtdblock6, you are actually using 32/32
Well 3.3.6-pre1 is compiled with gcc3.3.2. You will need install compat libs, to be able to run other software, that are compiled with gcc2.95

I have recompiled some Packages with gcc 3.3.2

http://teletubbie.hentges.net/feed/

For your place problem there are Solutions to Install software to ram or an ext2 card. You could also take an ext2 card and move home and opt to that and symlink them to /
This is a FAQ Issue and you should find a lot of howtos about.
Here is a good starting point:
http://www.linux-migration.com/ch05.html
It is for OZ 3.2 but it works with few modifications with OZ3.3.6-pre1 too
Have Fun,
Sam
cybrjackle
thx, for the how-to's

I don't understand how the space got taken up when the only thing i've done thus far was installing the new ROM?? Does it take up the whole FS? What size of ROM are you using?
Teletubbie
Hi,
I am using the hentges rom. It is based onoz3.3.6-pre1.
You should take the 1.1.4 Version. It is stated as german. But you can take that. Te calibration screen will be german, then you can choose english as default language and click on finish.
Be aware to take also the Kernels from www.hentges.net and there is a little bug, if you have CF or SD card inserted while first boot. So take all cards out while first boot.
On this rom there is also just little space left on root. But you can uninstall the Pim Apps Calculator and texteditor and install them then to ram or an ext2 formatted card.
Cheers,
Sam
cybrjackle
Thx, I did install that ROM today and that is probably why I was out of space. Is it easy to sync that ROM up with Evolution?
Teletubbie
yes since it is opie, you can just use multisync with evolution.
Cheers,
Sam
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.