Help - Search - Members - Calendar
Full Version: xqt installation?
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
CoreyC
Has anybody been able to install xqt on oz 3.5.1 (opie)?

I read a recent post saying that lardman posted some steps a while back, but I am unable to find it.

I've installed the packages and moved the files in /home/zaurus to /root. I've also made sure that /opt/QtPalmtop/bin was in my PATH. I've link Xqt to X.

Not really sure what is going wrong...
lardman
I installed it on 3.3.6pre1, I've not had time/needed to do so on 3.5.1 yet.

I'll try to take a look at it during the week if I have some spare time. In the meantime what seems to be the problem?


Si
lardman
Just done it:

mkdir /home/zaurus

Install the following (I did this to / on my C750, ymmv):

opie-sh_1.1.6-r0 from new feed
oz-compat_0.5
oz-compat-opie_0.1

xlibs_4.3.0-2_arm.ipk
xbase-clients_4.3.0-2_arm.ipk
xqt-server_0.0.9_arm.ipk
rxvt_2.6.4.1
blackbox_0.65.0.1
xqt-startup-scripts_0.0.2
xbase-etc_4.3.0-2

Restart opie (to get the new icons)

Use make compat to make XQt server compatible (choose list rather than file).

[the line below is not a typo it is supposed to be /.*]
cp /home/zaurus/.* /root
rm /home/zaurus/*
rmdir /home/zaurus

Start XQt (can't remember which icon).

Hit menu key, select 'Full Screen'

Use fn-tap to get Blackbox menu.

Use shift tap to select items on the menu - random?

Seems to work fine, time for bed.


Si
Bundabrg
I might just add that the first 2 ipk's are at the following url: -

http://www.mithis.com/zaurus/ipkgs/oz-compat_0.5_arm.ipk
http://www.mithis.com/zaurus/ipkgs/oz-comp...pie_0.1_arm.ipk

I'm giving it a bash now myself. What are the advantages/disadvantages to X/QT versus GPE on another VT?

(Update: Works like a charm)

- BRG
CoreyC
lardman,

Thanks for the instructions, works great smile.gif
adf
Lardman,
I can't seem to get blckbox to open anything, even rxvt.
I did rm -rf of th the directory, rather than remove files with a wildcard then remve the dir. that shouldn't have caused the problem?
all else seems fine.
I think Blacbox installed stuff to a sharprom void.
Help?
adf
lardman
QUOTE
I can't seem to get blckbox to open anything, even rxvt.
I did rm -rf of th the directory, rather than remove files with a wildcard then remve the dir. that shouldn't have caused the problem?
all else seems fine.
I think Blacbox installed stuff to a sharprom void.
Help?


The rm/rmdir isn't important, I just didn't want stuff lying around on my Z.

Are you sure you used exactly the following command:

cp /home/zaurus/.* /root

Note the .* (as the files you're copying have names like '.xinitrc'.

That said, blackbox starts up so these files are probably okay. I'd be tempted to ssh in and try from there so you can see the output; there may be a missing dependency I suppose.


Si
adf
I'll give it a shot. I'm installing to sd, though. Wouldn't that cause issues with the whole home/zaurus thing? (though it almost works). I'll mess with it for a bit. If you have some sudden inspiration about this though, let me know.
adf
adf
so far....
xterm needed a bogus ncurses link..... it wanted libncurses.so.4 and oz provides ...so.5.4 make a symlink in the /lib called libncurses.so.4 that points to the newer oz libncurses and xterm works. (I hope this is accurate it is off the top of my head)
rxvt wants some fonts that i haven't tracked down yet.

I'm on a 5600 with most things on sd, btw.

Any one have a good idea regarding desktop navigation? even xterm comes up much larger than the 5600 window, and can only be moved about by grabbing the topbar. not nice. The pointer device would work better....
papercrane
QUOTE(Bundabrg @ Sep 27 2004, 10:15 PM)
I might just add that the first 2 ipk's are at the following url: -

http://www.mithis.com/zaurus/ipkgs/oz-compat_0.5_arm.ipk
http://www.mithis.com/zaurus/ipkgs/oz-comp...pie_0.1_arm.ipk

I'm giving it a bash now myself. What are the advantages/disadvantages to X/QT versus GPE on another VT?

(Update: Works like a charm)

- BRG

And how would one get gpe running on another VT?
ced
Opie&GPE
Teletubbie
rxvt needs xqt-fonts-misc
cheers,
Sam
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.