Help - Search - Members - Calendar
Full Version: Hotplug issue Slackware 10
OESF Forums > General Forums > Desktop Operating Systems Issues > Linux Issues
uberjoe
I'm trying to get hotplug to setup my usb0 interface when I put the z in the cradle. I put this script
QUOTE
#! /bin/bash
typeset -i num
num=`ifconfig | grep usb0 | wc -l`
if [ $num -eq 0 ] ; then
ifconfig usb0 192.168.129.200 netmask 255.255.255.255 up
route add -host 192.168.129.201 usb0
fi

in /etc/hotplug/usb and called it usbdnet and usbnet, neither one worked. If I run the commands in the script manually as root, I am successful, but the script itself does not seem to work for me. Here is my relevent info
QUOTE
pc: 192.168.129.200 mask 255.255.255.255 route 192.168.129.201
z: 192.168.129.201 mask 255.255.255.0 route 192.168.129.200


The script is in /etc/hotplug/usb and my user's group has permission to execute it. Any thoughts on how to get this working?
uberjoe
*bump*
Howitzer
This may be relevant despite my gettting this working in CentOS 4.

I had to change the ifconfig and route lines to:

/sbin/ifconfig
/sbin/route

and the filename had to be usbnet, not usbdnet.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.