Help - Search - Members - Calendar
Full Version: SNES Emulator Guide
OESF Forums > General Forums > General Support and Discussion > Software
webdave
Is there a guide that tells you how to run a SNES emulator on a c860 with Cacko's ROM?

I can't seem to get my roms to work.
stupkid
I put this in another thread in this forum:

The way that I run snes9x is by creating a small shell script containing something like /home/QtPalmtop/bin/earthworm_jim.sh:

#!/bin/sh
/home/QtPalmtop/bin/snes9x -xs 320 -ys 240 "/home/zaurus/snes-roms/Earthworm_Jim_US.zip"

Then I create a link under games link like earthworm_jim.desktop:

[Desktop Entry]
Comment = snes9x
Exec = earthworm_jim.sh
Icon = earthworm_jim
Name = Earthworm Jim

Then click on the icon under games and it runs great with sound and all on my c860.

I also created a shell script that uploads my game configurations as they are created:

#!/bin/bash
#
# This script will update all the SNES game shell scripts and icons
SHDIR=/home/QtPalmtop/bin/
ICONDIR=/home/QtPalmtop/pics/
DESKTOPDIR=/home/QtPalmtop/apps/Games/

# Shell script update

for sh in *.sh; do
cp $sh $SHDIR/
chmod 755 ${SHDIR}/${sh}
done

# Icon image update

for icon in *.png; do
cp $icon $ICONDIR/
chmod 644 ${ICONDIR}/${icon}
done

# Desktop update

for desktop in *.desktop; do
cp $desktop $DESKTOPDIR/
chmod 644 ${DESKTOPDIR}/${desktop}
done

This seems like a pain, but it has consistently worked on my Z.

YMMV!

If you want to use the exact same package I'm using you can get it from my feed at:

http://www.bryandeluca.com/feed

Hope this helps...
webdave
Thanks I'll try that when I get home.
webdave
Does it matter what extension the rom is in. I noticed your example was .zip. I have all of my ROMS unzipped, should they still work?
kic
Provided you have the emulator installed and it's not complaining about missing packages/dependencies, you could just install zemufe and not worry about a script for each game. Much easier. Should be on the feed posted above. I'm using it right now for zgnuboy and snes9x without problem.

There's a thread on the board here somewhere that details what each script for zemufe is in case you want to edit those. (It uses a script for each type of rom to load the appropriate emulator, rom, and settings.)

On a moderately related note, I wish the emulation was a little faster. 10-15 fps is pretty dismal, but surprisingly, FF6 is still playable. Only one I've yet to try. (I somehow doubt Super Metroid will be playable at that frame rate.)
stupkid
Using my method above super metroid is quite playable on my c860.
kic
So it is. It hovers around 20 fps, give or take a few.

Still, my point was more broad, in that I'd love to see 30+ fps. Unless I have some badly botched installation, I'm guessing that 20 fps is about the best I can expect (except during cut scenes and low action scenes).

But now I'm getting somewhat off-topic. tongue.gif
chaokuo
running SL5500 on oz 3.5.1, after I installed both snes9x and libSDL from your feed http://www.bryandeluca.com/feed, I get:

snes9x: symbol lookup error: /opt/QtPalmtop/lib/libSDL-1.2.so.0: undefined symbol: cmd__12QPaintDeviceiP8QPainterP13QpDevCmdParam

Any ideas? sad.gif
iamtheb
I'm also having problems getting snesx to work. I'm on a C700 with Cacko 1.21b..

znester works fine, and I can even get vba to work (altought the performance is terrible).

however snesx simply behaves strange. If I launch it from ZEMUFE, the game shows up on the left hand side of the screen in 3 tiny boxes and then quits. Launching from the command line simply changes the resolution, and then quits as well. sad.gif


I'm using the following:

libsdl_1.2.5-slzaurus20031201_arm.ipk
snes9x_SDL-1_arm.ipk

both are installed on a etx2 partition on my SD.

(libSDL_1.2.6-zports-5_arm.ipk didn't work at all -- just a black screen).

Anyone have any ideas? Am I missing something? Thanks in advance..
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.