Help - Search - Members - Calendar
Full Version: E-mail/IM?
OESF Forums > General Forums > General Support and Discussion > General Discussion
rikiya
I just love the fact that I can use internet
wirelessly on my Z now! Yet, the problem is that
I can't use my hotmail account on the internet because it only allows IE 5 or up /Netscape. HELP! Is it possible to do some magic on the e-mail program and get it working? I'm not too bright on the POP and all that great stuff some people can do... If it's not possible at all... Is it possible to use a TELUS|(Canada) e-mail? One more thing... Is it possible to do msn messenger or a IM program to use my hotmail account??????????

Thanks!

P.S. It was nice posting since I haven't posted for about 2 months! smile.gif

Rikiya
Chaos
Hotmail... Sorry, I don't really know. I don't think so, though, unfortunatly...

Telus shouldn't be a problem. You'll probably just have to fill out the correct fields in QTMail's account setup. You'd just have to find out the POP3 or IMAP server, and the SMTP server (and of course that e-mail account's username and password). If you use non-webmail on whatever "main" computer you use, you probably have this info already...

And for IM, qpe-gaim might work (http://qpe-gaim.sf.net/), which is unfortunately problematic and a seemingly dead project... Or maybe Kmerlin, which seems dead on the Zaurus front too (http://www.killefiz.de/zaurus/showdetail.php?app=294).

Maybe someone with enough knowledge should revive qpe-gaim? The original devel (chipx86) seems to have dropped off the planet.
choonhow
QUOTE
I can't use my hotmail account on the internet because it only allows IE 5 or up /Netscape. HELP! Is it possible to do some magic on the e-mail program and get it working?


Hi rikiya,

If you are trying to access Hotmail through a browser, I believe you can do that by using Opera 7.30.

hope that helps.


cheers
Chaos
Or the (even newer) Opera 7.55. wink.gif I haven't tried it with Hotmail (I avoid MS-anything), but if 7.30 works, why not 7.55?

Anyone curious, it's just included in IBM's multimodal stuff now. Newer version got silently slipped in sometime.
ashikase
You can (or at least could at one time, haven't tried in a while) access Hotmail using NetFront. The trick is to change the User Agent to match something which Hotmail will accept; for example, the User Agent string for the current version of Firefox is:

CODE
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10


The setting can be found under Tools->Browser Setting->Misc tab->Advanced Setting button. (the option is called Customized User Agent).

- ashikase
anpachi, gifu, japan
lardman
QUOTE
And for IM, qpe-gaim might work (http://qpe-gaim.sf.net/), which is unfortunately problematic and a seemingly dead project...


I spoke to the author yesterday - he's been busy with work. The source is available on the sourceforge site for all but the latest qpe-gaim (0.4) release, and I've asked him to provide this too so someone else can have a go with it if they want (and so it can be added to OE).

In any case, gaim works (or at least did a couple of weeks ago when I last used it) fine for me.

QUOTE
Hotmail... Sorry, I don't really know. I don't think so, though, unfortunatly...


Is it possible to change the User Agent string to pretend to be IE? Or is ths a functionality problem?


Si
rikiya
I don't know hotmail's Server or Proxy which i probably need to know in order to use the IM program (I chose TipicME Pro) does anyone know? or how to know? or should I send an e-mail to the hotmail staff for this help?

Thks
Chaos
Don't need proxy settings. Doesn't it have like a Hotmail account setup thing or something? The server info should be there automatically if it does... If it doesn't then that's a bit... Well, sloppy.

And I don't think Hotmail staff would take too kindly to 3rd party apps. And looking at the ZSI, it might have the same issues that Kmerlin have with the different version of the MSN protocol, judging from the date.
acpkendo
QUOTE(lardman @ Oct 13 2004, 03:01 AM)
The source is available on the sourceforge site for all but the latest qpe-gaim (0.4) release, and I've asked him to provide this too so someone else can have a go with it if they want (and so it can be added to OE).


I believe gaim itself is in the OZ feed already, although this might be a version compiled to work with GPE.
rikiya
Sorry for asking so much questions but...

I now installe gaim with all the requirements that was written on the gaim site including:

-gconv-tiny
-libgaim-protocol-gg
-libgaim-protocol-msn
-libgaim-ssl
-libcrypt1
-liblib2.0
-libgnutls7
-qpe-gaim
-zlib

Did I miss anything cause when I press the icon for gaim, it doesn't show up but it looks like it tries to and then shuts off without anything on the screen...

any help?

Thks
lardman
QUOTE
I believe gaim itself is in the OZ feed already, although this might be a version compiled to work with GPE.


Yeah, this version is for X11.

QUOTE
Did I miss anything cause when I press the icon for gaim, it doesn't show up but it looks like it tries to and then shuts off without anything on the screen...


You probably need to use the compat libs. If you're already doing this then try it from the command line and post the output.


Si
rikiya
I didn't know anything about terminals and etc. but thanks to lardman's suggestion I tried and typed "gaim" on terminal and viola this thing came out and said that there wasn't this file and I installed it and again it said another file so i installed it and repeated like 4 times and there you go it worked! YAY! Finally I can do IMMMMMMMM! Was it because I use the original ROM with japanese ?(I need to be able to type japanese) ?

Thanks everyone for the help!

P.S. Thanks to the person who suggested Opera! It worked! and also the person who suggested to change the browser mablobber in netfront to make it work! it worked great! thank you thank you!
javab0y
Hi folks...

I was (and am) very interested in reviving the qpe-gaim project. I unsuccessfully tried to get ahold of chipx86 and could not get him to respond. I tried IRC and email.

Without him, my first plan of attack was to get the qpe-gaim source and libgaim. The source I got was a .5 version...and perhaps did not seem that complete. I got it from the qpe cvs repository. It seemed dependent on a new libgaim that it needs.

Libgaim was very hard to track down. I got the old-old version from chipx86's subversion server. It was too old to work with the newer .5 version and too new to work with the .3 version. The most up-to-date version is found on the Adium (mac IM) cvs server (1.0.2). However, it seems like its patched heavily for the Mac (I could be wrong). So getting it to compile was fruitless.

What I need to do is get the old libgaim source to compile the new gaim source code to produce a libgaim binary. Once this is done, I should be able to get the .5 version of qpe-gaim to compile against the library. I hope that this will allow qpe-gaim to have new life.

I will try to continue to get ahold of chipx86. If I cannot get ahold of him, I will take the qpe-gaim source and libgaim source and create a new open-source project on sourceforge.

The bottom line is we really need a patched libyahoo...and we can have qpe-gaim working again.

Anybody here have any objections, questions, or tips? Any input would be appreciated.
lardman
I think this is the most up to date version: http://sourceforge.net/projects/qpe-gaim/

The qpe-gaim frontend source is only available for 0.3, but there don't look to have been that many changes between that and 0.4.

The libgaim diff file is there for not-quite the latest version; I think this has to be applied to an older version of gaim, not sure where to get old gaim source tarballs.

I'm all for it being updated.


Si
acpkendo
gaim (not qpe-gaim) is available in the OZ feed. The front end may need work, but perhaps you could leverage the work of the OZ/OE folks and produce a new qpe/opie gaim based on these libraries? IIRC the libgaim there is fairly recent.

Correction

Hmmm. . . looks like maybe there is not a libgaim, but rather it's included as a static package with the gpe frontend. . .
javab0y
Yeah I have been working with the gaim people (crashing in on the irc). They have been helpful. Apparently Chipx86 is out of town. The libgaim is not official...but will be a part of gaim 2.0. There are 3 unofficial versions, Chipx86, AdiumX, and Proteus. They are all thier own "hack jobs". I can compile Chip's, but not AdiumX. AdiumX is XCode based (yes I have a Mac), and does not appear to use a normal make file. Proteus, I think, is semi private.

I can probably cobble togather a 1.0.2 version of libgaim. But it will take a bit of time. I am still getting used to the API. I want to chat with Chipx86 before I get too deep into this. I began hacking the qpe-gaim to use a newer API (at least .79). The buddy list code is significantly different, so I need to examine those API changes first.

I feel confident I will have a new qpe-gaim, but I would really like to coordinate this with Chip and the gaim team. It makes no sense to fragment this and have 4 libgaims.

Again...input and comments are recommended, suggested, and very much appreciated.
javab0y
Ok..some progress...

I got the adiumx libgaim code and hacked up the Makefiles pretty heavily. After several hours, I finally have a qpe/arm version of libgaim version 1.0.2, the same as stable gaim. I had to also get rid of a few Adium GaimBuddy declarations and hope this wont cause any harm.

Now I just need to get my hands on qpe-gaim .4 source...then hack that to use the new buddy API and any other API changes and I *think* we will have an up-to-date qpe-gaim.

But then again, I could be way off. But at least we are in the right direction.
kcurrie
Yesterday I compiled Gaim 1.0.2 with (http://gaim-encryption.sourceforge.net/Gaim-Encryption 2.32 *and* the Meanwhile (Sametime) plugin and put it online here:
http://undertow.2y.net/zaurus/bin/

Note this is the X version, so you either run it under fbvnc (best option, IMHO) or maybe X/QT.
It's a big install, (I put it under /opt/gaim so as to not conflict with any Debian packages installed) , so making a cramfs image of it is a good idea. Unfortunately since it's a GTK app you can't compress it via UCLX, but at least with a cramfs image you compress the rest of the files like the libs which are quite large.

javab0y, I'd be interested in getting my hands on whatever code you now have-- I really need Sametime and gaim-encryption functionality, although it's likely that my existing plugins would work with your new QPE version.

Free free to email me at: kcurrie (a...t) undertow.2y.net
javab0y
Yeah, my code should accept your plugins as long as they are not dependent on the X libs. I configured it "--without-x" for qpe.

I am also thinking about activating rendezvous too. But I will take it a step at a time first. I think I will have tremedous bugs I will need to deal with.
lardman
QUOTE
I am also thinking about activating rendezvous too.


Great!

Keep us posted, and let me know if I can help at all,


Si
Teletubbie
Hi guys,
well I am noncoder and can just follow your discussion as such, so exuse me if I got something wrong.
From the support of the hentges rom users I am aware that there are lot of OZ folks waiting for gaim (there are some little hacks with compatlibs etc).
Is there any hope to get your stuff up to the openembedded framework so we can provide the folks with. Since there are still people out there using the hentges 3.3.6-pre1 hentges rom I still have a 3.3.2 toolchain running here and would recompile it for that rom. Coredump is running the 3.5.1 toolchain and would (I assume heavily) compile qpe-gaim for 3.5.1
Thanks,
Sam
lardman
Don't worry, I'd be looking to stick it in OE as I'm an OZ boy through and through ;-)


Si
javab0y
When all said and done the new qpe-gaim will run on both Sharp and OZ ROMs...so no problem.

I have not heard from ChipX86 (I have sent him email, irc, etc).

So I am just going to move forward and hack what was in CVS. Someone PMd me and said they had the .4 version on source and I would rather work from this, but I have not received it. So, starting tomorrow I will hack the cvs code with libgaim 1.0.2 (adiumx).
shrguy
Hotmail is easy if you use the mobile version. I had the main version working (not sure if I was running the Sharp ROM -> Opera 6.0, or Watapon -> Opera 7.55 at the time). It didn't fully work, but I wasn't really stopped because of the User-Agent. You can find the mobile version at: http://mobile.msn.com/pocketpc/menu.aspx

I found it (and Yahoo's mobile version) from PDA Hotspots: PDA Hotspots. Googling for "PDA friendly sites" was about the best thing I ever did on the Z. smile.gif

Good to hear that someone is picking up qpe-gaim, I just started with the Z last month and I'd really like Yahoo IM to work...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.