Help - Search - Members - Calendar
Full Version: Java is only 320x240 on SL-6000
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Personal Java/Jeode/J2ME Personal Profile
wchall01
I have written a few Java applications for the SL-6000 now and when the program is loaded it is only using a screen resolution of 240x320. My application's window size is 480x640, so this means I have to grab the title bar and slide it around to see my entire application. That is, its as if i have a "virtual desktop" of 480x640 with only a visible area of 240x320.

I am using the PersonalJava engine to launch as follows:
$QPEDIR/bin/evm -XappName=run-MyApp -cp $INSTALLDIR/java MyApp

Has anyone else experienced this? If not I can post a chunk of the source (maybe its me).

If this is a known issue, anyone have a fix?

Does this happen with the Sun J2ME download?

Any help is appreciated.

UPDATE

Looks like the SL-6000 is pre-installed with the J2ME PP 1.0 and if I invoke my same application from the command line with the following command it recognizes the 480x640 resolution. Wooo Hooo!

/opt/Qtopia/j2me/bin/cvm MyApp

Regarding Jeode, still not fixed, but for now I'll use J2ME PP.
trejkaz
I just found the same issue on the SL-C860. All the launcher icons seem to launch Java in 240x320 (as opposed to normal, 640x480 landscape mode.)

The best thing is, the Z reboots as soon as the applet viewer exits. :-/

But again, running it outside of the launcher works fine. Go figure. I think something in the file the launch script sources must be at fault here. Investigating. :-)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.