Help - Search - Members - Calendar
Full Version: Ann: EDICT and update to KANJIDIC
OESF Forums > General Forums > General Support and Discussion > Software
halx
I recently converted EDICT (based on JMdict V2004-02 14 August 2004) to EPWING format. The output is very similar to the online version at Monash university (and mirrors), i.e. information about word type, part of speech, kana/kanji irregularitites, etc. are displayed.

I also updated KANJIDIC with a lot of improvements over the previous version: kanji are links now (when searched by reading) and ordered according to their stroke count, keyword search (conditional search) is also supported now. Also some bugs have been eredicated (see ChangeLog). I recommend an update, but please note that file sizes have increased.

For download visit my Zaurus webpage.
Stubear
Halx,

You rock!

thanks for these - makes my life easier cause I can't get freepwing to work properly on my system - something to do with my perl version it seems.

Stu
nanpanman
Thanks halx!

I installed the new kanjidic and I love the kanjilinks!

I also replaced my old edict but your new one is actually about 10MB smaller that the previous one I got from your site? seems to work great though. happy.gif
halx
QUOTE(nanpanman @ Oct 16 2004, 07:46 PM)
I installed the new kanjidic and I love the kanjilinks!

I also replaced my old edict but your new one is actually about 10MB smaller that the previous one I got from your site?

You can also combine all readings (first line) with all codes (third line) in a conditional search (keyword search). Doesn't make much sense with most dictionary codes because their are unique but you can do something like

(reading stroke count, e.g.)
"ken" (in kana) "S5" (as from the third line)

to search kana readings "ken" with a stroke count of 5 (double quotes denote actual search keys).

As for EDICT, this is my first release! You probably mean ENAMDICT (Japanese and foreign name dictionary)?
halx
QUOTE(Stubear @ Oct 15 2004, 07:11 PM)
makes my life easier cause I can't get freepwing to work properly on my system - something to do with my perl version it seems.

Which Perl version are you using? For me it works both with 5.8.0 and 5.8.5. AFAIK the minimum requirement for FreePWING is 5.005
Stubear
QUOTE(halx @ Oct 16 2004, 10:12 PM)
Which Perl version are you using? For me it works both with 5.8.0 and 5.8.5. AFAIK the minimum requirement for FreePWING is 5.005

Perl 5.8.5 with freepwing 1.4.3, must be missing something cause it won't run any of the fpwmake files I've found on the web.

Maybe I'll spend some time later today to give it another try

Stu
Ezekiel
Oh my God, you're the greatest Halx! Thanks a million smile.gif
keisangi
hi there, i would like to install kanjidic and the large exemple dic.
i have both zten and ztenv up and running.
but i dunno where to put the dicts ?
and if i should untar them? (think yes , but..)

someone could help me a bit or tell me where to find some help on installing thoses dicts?

thanks a lot
halx
QUOTE(keisangi @ Oct 21 2004, 01:59 AM)
i have both zten and ztenv up and running.
but i dunno where to put the dicts ?
and if i should untar them? (think yes , but..)

Just untar them in one of the following directories
/home/zaurus/dict/ (main memory)
/mnt/card/dict/ (SD card)
/mnt/cf/dict/ (CF card)
/mnt/net/dict/ (network)

and restart zten(v).
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.