Help - Search - Members - Calendar
Full Version: hostap channel hop broken ?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
gen2
[reposting this here with more appropriate subject heading]

kismet on hostap fails with: "FATAL: Failed to set channel 11 22:Invalid argument", which is weird, cause it worked fine with orinoco, and weirder, cause I can
"iwconfig wlan0 channel 11"
and that changes channels as expected. Confused...

# cardctl scheme resume

doesn't help, subsequent run of kismet gives same error. I deleted channel 11 from the kismet.conf channel list, and it threw the same error, but with the next available channel. Seems to implicate channel-hopping in general...

Also set up a new "open" profile (every entry blank)...loaded it, and still no change...

# kismet -X

works fine, only channel hopping seems to fail

Any ideas?
Thanks!!
rgrep
It works fine for me except that I can't use the channels above 11 (i.e. 12, 13 and 14) otherwise I get a similar error to you. I also get the error when I try iwconfig manually on those channels, e.g. iwconfig wlan0 channel 12. Channel 11 works fine for me.

What source line are you using in your kismet.conf? I use:
CODE
source=hostap,wlan0,hostapsource
gen2
QUOTE(rgrep @ Oct 18 2004, 06:04 PM)
It works fine for me except that I can't use the channels above 11 (i.e. 12, 13 and 14) otherwise I get a similar error to you.  I also get the error when I try iwconfig manually on those channels, e.g. iwconfig wlan0 channel 12.  Channel 11 works fine for me.

What source line are you using in your kismet.conf?  I use:
CODE
source=hostap,wlan0,hostapsource

I'm using exactly that source line, and if I try to use iwconfig to manually set 11, it works just like yours, and so too if I try 12+ I get the exact same error as you (which is the same error that appears for channel 11 while running kismet).

To reconfirm:
Kismet with hostap/without channel hop works perfectly.
Kismet with orinoco works perfectly in all cases.
Problem reproducible on WCF12 and Pretec WLBXX

Thanks for the help
rgrep
I have a Linksys WCF12 and Kismet channel hops fine for me. What lines did you add to /etc/pcmcia/hermes.conf?
gen2
QUOTE(rgrep @ Oct 19 2004, 04:16 AM)
I have a Linksys WCF12 and Kismet channel hops fine for me.  What lines did you add to /etc/pcmcia/hermes.conf?

# vi /etc/pcmcia/hermes.conf

device "hostap_cs"
class "hermes"
module "hostap", "hostap_cs"

card "Pretec CompactWLAN Card 802.11b"
version "Pretec", "CompactWLAN Card 802.11b", "2.5"
bind "hostap_cs"

card "Linksys CompactFlash Wireless Card"
version "Linksys", "Wireless CompactFlash Card"
bind "hostap_cs"
gen2
QUOTE(gen2 @ Oct 19 2004, 04:50 AM)
QUOTE(rgrep @ Oct 19 2004, 04:16 AM)
I have a Linksys WCF12 and Kismet channel hops fine for me.  What lines did you add to /etc/pcmcia/hermes.conf?



Re-installed rc5, problem disappeared.

cool.gif
wario
Has anyone successfully determined WEP keys using the WCF12 + kismet + airsnort/dwepcrack ?

I keep getting "no valid packets" error. Suspect it has to do with the fact that i am using the orinoco driver.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.