Help - Search - Members - Calendar
Full Version: Tuxcards
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Chero
hi,

I was able to compile tuxcards 1.1 for pdaXrom, but when it comes to creating an ipk, i'm just not skilled enough.

I tried different ways, but always got stuck.

The compiled binary runs fine on my z, just wanted to create an ipk to share it with other people.

Maybe somebody else wants to give it a go ?
You can find the source on www.tuxcards.de

cheers,
Chero
pgas2
have you look at the howto here on the zug?

What problems are you facing, basically its just some tar cxvf?
Laze
Please also check this:
http://www.pdaxrom.org/index.php?showid=35&menuid=1
Chero
I did use the SDK-tutorial
Compiling was OK, but mkipkg didn't work.
I'll try again this evening, I'm sure I'm just missing something.

BTW - the binary runs fine, every option seems to work

Cheers,
Chero
Chero
When I try to create the ipk, I follow the Howto:

mkdir ipkg_tmp
make DESTDIR=ipkg_tmp install

Then my binary should be in ./ipkg_tmp/usr/local/bin , right?
It is not, instead it's in /usr/local/bin
Then it automatically wants to strip, I get a few errors and get stuck

Please help, I want share this :

pgas
ok, i'v try it in the Makefile i see
install_target: all
@$(CHK_DIR_EXISTS) "$(INSTALL_ROOT)/usr/local/bin/" || $(MKDIR) "$(INSTALL_ROOT)/usr/local/bin/"

so try make INSTALL_ROOT=ipkg_tmp.

Or you can copy the files by hand.

btw I try to compile it but only get
segmentation fault as a result
Chero
thanks for the advice

i'll try again on monday -left my laptop at work
I only brought my Z with me, no need for the laptop since I can put my notes in tuxcards.

cheers,
Chero
hilarycheng
any ipkg now? I wanna to try.
Chero
No, not yet.

I probably won't be able to try creating the ipk in the first two or three weeks
(I'm rebuilding my house and i'm quite busy on my job too)

Sorry for the delay.

I could mail you a working binary (both RC3 and RC5) - send me a PM or mail me at werner.vandyck@pandora.be

sorry,
Chero
Chero
just uploaded tuxcards to the unstable feed on pdaXrom.org

thanks to hilarycheng for packaging

Chero wink.gif
wmadan
What's the keyboard shortcut for inserting a new entry?
Chero
Check this one out (it isn't a archive, just rename and open in tuxcards) :

Tuxcards features

(not all are implemented yet - these shortcuts are for tuxcards 1.2 - not yet compiled for pdaXrom

good luck

Chero
scoutme
installed txcards, but it seg.faults (RC8).

Any hint?
scoutme
solved by installing in /: sure a problem of working folder or links. I'll give a look at the ipk
Chero
quite off-topic, but it would really help me (and viewing the number of downloads of the ipk, it will not only be me you'd be helping out)

I've been using tuxcards for a while now, and I really want to put it on my office box, which is running win2k.

I know there is a cygwin version around, but I'd be better off with a win2K-.exe. There are some guys at work that also would like to try it, but they know crap about linux. Wonder what would happen if I had to put cygwin on their computers ... Please don't make me do this.

Is there someone around here that can compile qt3 apps for win2K ?

Chero.
ZDevil
Also has anyone come up with a new (1.2) compiled version? smile.gif
This app should be yet another killer app in the realm of X. Thanks!
Chero
QUOTE(ZDevil @ Oct 6 2005, 05:01 PM)
Also has anyone come up with a new (1.2) compiled version?  smile.gif 
This app should be yet another killer app in the realm of X.  Thanks!
*


I should have it somewhere. Didn't bother to post or upload it since there are not really visible changes since 1.1.
I'll check where I left it.

Chero
ZDevil
That's nice. Thanks Chero. Really looking forward to that, coz I saw there are numerous improvements in the 1.2 desktop version. smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.