Help - Search - Members - Calendar
Full Version: have a dhcp lease from my access point, but...
OESF Forums > General Forums > General Support and Discussion > General Discussion
heldbak
Hey,

I just bought the Zaurus SL 6000L and am trying to get its wifi capabilities to work. I'm using the sharp rom and used the network app to fill in the correct info about my network (ssid, use dhcp, wep etc). I can connect, I get an IP from the dhcp server, but I can't ping my gateway or any server on the Internet. I turned ip forwarding on, but still no success. I'm not using WEP at the moment, so that isn't affecting anything. And I dont have iptables/ipchains, so no firewall is preventing me from accessing the Internet. What could the problem be? Any suggestions will be greatly appreciated. I _have_ searched this site and many others for an hour or two, but can't find anything relevant to my problem. If you know of a site/tutorial, just point me in the right direction. Thanks.
heldbak
here's some more information:

i ran dmesg and nothing seems out of the ordinary other than the message "tx attempt prior to association, frame dropped". but i ran iwconfig and it has the correct ssid, frequency, etc. one thing i did notice, however, that could be a problem is this:
QUOTE
Warning: Driver for device wlan0 has been compiled with version 12 of Wireless Extension, while this program is using version 13. Some things may be broken...
sounds bad. if i were to just flash OZ and get rid of the sharp rom, would this cure my problems?
nico
check your /etc/sysconfig/network file and make sure it says NETWORK=yes and FORWARD_IPV4=true. if dhcp is assigning you an IP and setting up your gateway you shouldn't need to add anything else to it. not sure about that error though, someone else can probably atest to that problem.
heldnak
yeah, i've done that. i've decided to do everything manually and not to rely on the network config tool that comes w/ the sharp rom. so here is what i've done:

-created a wlancfg-<ssid> file w/ the correct settings
-edited wlan.conf to work for my setup
-ran "usbctl on 1"
-ran /etc/wlan/wlan-setup
-ran "ifconfig inet <ip> netmask <mask>"
-ran "route add default gw <gw>"
-added servers/search path to /etc/resolv.conf

i try pinging my gateway, but all the packets get dropped (its not a resolver issue since i'm not pinging a hostname). iwconfig and ifconfig have the proper settings. ip forwarding is turned on. there has to be something small im missing. so if someone could point that out, it'd be appreciated.
heldbak
nevermind, i figured out the problem and am posting this from my Z. wlan0 wasn't being assigned an IP, however, i could've sworn it was.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.