Help - Search - Members - Calendar
Full Version: 860 in an unusual brick-like condition
OESF Forums > General Forums > General Support and Discussion > General Discussion
KAShirow
SL-C860, apparently new. Don't ask me, got the last one available and was in no position to choose.

During experiments in picking a better version of SDL, I tried a package taken from a japanese site. Soon into running an SDL program, the machine went out. Attempts to turn it on normally failed.

Attempts to get to the Japanese Service Menu failed as well.

The D+M English Service Menu, which I've used just a few days ago to make a NAND backup, works just fine. However, restoring from a NAND backup I made days ago still does not produce a living machine.

After restore, NAND Bad Count results in zero bad blocks, however, a NAND checksum check results in red NGs starting with KERNEL1.

I have a few specific questions:

1. Will a 'NAND Flash Erase' still leave me with the D+M English Service Menu to try restoring a NAND backup?
2. Will flashing a japanese NAND image I found on the net improve the situation?
3. Does anyone have experience in using the recovery kit at http://pocketworkstation.org/files/recover/ on a real live SL-C860 and what were the results?

Prompt and quick answers would be very much appreciated, since I have to go to work in about five hours and I'll really need my Zaurus. smile.gif
Omicron
Which I could help you, but I would recommend searching all the forums for the word "Brick"


This should yield some results:

Search results for BRICK
KAShirow
QUOTE
Which I could help you, but I would recommend searching all the forums for the word "Brick"


That's what I started with. smile.gif I couldn't find the answers to these three questions in there.

It was what allowed me to ask them though. smile.gif
KAShirow
A bit more on my research - even if nobody comes by with the answers, doesn't mean I shouldn't detail the ones I've discovered. smile.gif

As detailed in http://www.h5.dion.ne.jp/~rimemoon/zaurus/memo_006.htm (I wish I could understand more of it, but all of my japanese-speaking friends are not available at the moment) apparently, you can recover the kernel files referred to in NAND Checksum with the D+M service menu, and not using the blind rom method described in http://pocketworkstation.org/files/recover/ recovery kits, for which a CF card with the same files will be necessary.

Unfortunately this page does not provide any links to files which would definitely work in a 860, or I'd go for it.

Reading more into it, the failed checksum of KERNEL1 means that the main linux kernel that runs the boot process is screwed, but the maintenance kernel KERNEL2 is still intact which allows me access to the service menu. I do wonder what are the ROFLSYS and INFO files for though.

Reading yet more into it, it appears that erasing NAND will not cause ill effects IF it is restored from backup immediately afterwards, since the service menu program will keep running in RAM. I'm not very certain of that interpretation though, so I'll have to leave this as the last resort.

More interesting news. According to http://externe.net/zaurus/forum/viewtopic.php?t=1297 the recovery kits from pocketworkstation.org do NOT work for 860, since they were assembled from earlier versions and don't actually match.

That makes me think NAND backups from other sources for the same model actually have a chance of solving my problem, though.

After restoring from a japanese NAND backup, the machine still did not boot. NAND Checksum displays a NG on PARAM partition, but no clue as to why would this prevent it from booting, or what to try next. Restoring with my old image after that still produces no improvement.
KAShirow
Suddenly discovered I can actually boot into console by holding D+B.

Can anyone tell me how to exploit that to improve my chances of recovery?

As far as I can see, it doesn't help much. I can command it to 'reboot' and it will boot into qtopia with normal kernel.

Unfortunately it will still not turn on normally from powered down position.
KAShirow
Looks like it got unbricked now (crossing fingers).

The key to turning it on was pressing both the on button and power on button on the keyboard together, which caused it to boot normally for the first time.

There appear to be some unusual battery problems though, which cause it to shut down unexpectedly for no good reason. Let's see if the battery level adjustments help in any way.

*proceeds with reinstlaling cacko rom and cursing the japanese people who don't know their way around SDL*
waalkman
QUOTE
Looks like it got unbricked now (crossing fingers).


Excellent!


QUOTE
There appear to be some unusual battery problems though, which cause it to shut down unexpectedly for no good reason. Let's see if the battery level adjustments help in any way.


I was having wierd battery problems the other day, the unit had a dead battery and wouldn't charge up off of the cable. I put the battery in the external charger and left it there until it was fully charged and have had no more problems since.

Odd though... (and a good thing that I had the external charger).
ag0ny
I had the same problem with an empty battery. Your Z will not start booting (also when AC plugged in) when battery is empty. Normally, when AC is plugged in, the battery should normally get loaded and the Z should turn on after waiting a minute or so. But this did also not happen for me.

Finally the guys over at Trisoft found out that my internal electronic for charging the battery is broken from a bad AC-Power Adapter. Now i use some external batterycharger and the Z is just working fine When the battery is full and the AC-Power plugged in i can use it for ever without getting an empty battery.
iamasmith
JFYI the NAND erase really does erase everything except the Service menus that you use for NAND restore etc.

It erases the second stage bootloader and japanese utility menu that you would normally see upon starting the unit with the OK button held in.

In this state the Z powers on, shows a blank white screen and the mail light flashes. - It won't do anything else until you restore a NAND image to it.

BTW: Doing a Complete NAND flash test returns it to this same state.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.