Help - Search - Members - Calendar
Full Version: Unable to charge SL-C750
OESF Forums > General Forums > General Support and Discussion > General Discussion
EricDonovan
I have a problem with my newbought Zaurus model SL-C750.
I can't charge the battery.
I have tested two different adapters. One cheap, and another a bit more expensive with regulator.
With both adapters, when used the battery-diod is litten for about 20-30 minutes, then goes out. No matter how much I try to charge the battery it won't be charged.
A friend of mine has the same model and charged my battery in his Zaurus. This succeded, and he was able to make software installs.
He clamed that he later charged my battery in my own Zaurus, and it worked fine.
Although, it doesn't seem to be working from my apartment.
I can't start my Zaurus, and I can't charge it.
Is there anyone that knows what to do with my kind of problem?
Is it something wrong with the battery? Or the SL-C model itself?
I have tried everything I can do. Can someone help me, please?


Eric*
Xumbi
Does it turn on with your AC adapter plugged in?
nanpanman
Hi,

Maybe this will help.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.