Help - Search - Members - Calendar
Full Version: WiFi with Airport Internet Sharing
OESF Forums > General Forums > Desktop Operating Systems Issues > Mac Issues
ralphrmartin
Using MacOS X 10.3.x, I used to be able to share my internet connection from Ethernet to Airport (using WEP security), and using a WiFi card in my Zaurus c860, I was able to get onto the net.

This all worked fine up until Aiport 3.4.2 and later. With these later versions, it seems Apple changed from "Open System" to "Shared Key", and I can no longer get access.

(I know the Zaurus is OK because I also used the same setup to connect using a wireless Draytek router, and that still all works fine, unchanged.)

Has anyone had any success connecting a Zaurus to the net through Apple's Internet Sharing with Aiport 3.4.2 or later? If so, I'd be grateful if you would tell us all how!
ralphrmartin
OK, I'll answer my own post.

It seems that if you use a 40 bit WEP key, it doesn't work.

If you use a 128 buit WEP key, you can get it to work, as follows:

On the Zaurus:
Put in a 26 character hex string
Set the mode to Shared Key

On the Mac:
Put in the password in the form
0x follwed by the 26 hex characters
eji
I was experiencing the same trouble. Your advice on the HEX key etc helped a great deal.

But I still find that I'm unable to connect to the Web. It looks up the host name, connect to the host, but the "sending request" portion just hangs indefinitely. E-mail, on the other hand, works just fine.

Any solutions?
ralphrmartin
Cant get what to conect? Your Web Browser? Which one?

Opera and NetFront seem OK here. If email is working, I don't expect its your network connection as such.

Have you set up proxies in the wrong way (e.g. trying to access your employer's proxy from your home connection is likely to fail)?
eji
I can't get Opera to connect to the Web. It's the oddest thing. As I mentioned in my earlier post, it looks up the host name, connects to the host, and then it hangs on "Sending request to www.XYZ.com"

I've tried about fifty different WiFi settings combinations both on the Z and the Mac (proxies, DHCP, auto/manual IP assignation, auto/manual DNS), but none work. E-mail, GAIM and package feeds are all receiving and transmitting just fine.

What I find even stranger is that I was surfing a few days ago using the preinstalled Opera on the Z and then the newer multimodal version (7.55) from IBM. The connection was finicky and sometimes took a few attempts before the page loaded, but it worked. Now I can't surf at all. Any chance it has anything to do with a dynamic IP?

I had disabled the WEP key, but maybe I'll reinstate it to see if I have better luck. If you can think of any reason why this might be happening, I'd love to know.
eji
Just wanted to report on my progress here.

I did get wireless working with my Graphite ABS some time ago. I just had to manually list the DNS servers (62.26.26.62 and 195.185.185.195) on each device -- my iBook, my Z and the ABS itself. Since then things have worked relatively well, except that the signal on my ABS regularly drops out and I have to restart it. But this, I think, is an AirPort issue and has nothing to do with my Z.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.