Help - Search - Members - Calendar
Full Version: NFS problems
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > 5x00 General discussions
I can't get NFS to work, I have the server on a Fedora Core2 box, have exports file and hosts.allow.

On the Zaurus SL-5600 Sharp ROM I created a /mnt/nfs directory, I enter:
mount -t nfs -o nolock /mnt/nfs

and the response is:

mount: RPC: Unable to receive; errno = No route to host
mount: nfsmount failed: Bad file descriptor
mount: Mounting on /mnt/nfs failed: Invalid argument

I get a similar response from a SL-5500 with OZ 3.3.6-pre1

I can ping from the Zaurus
Try dropping off the options and just issue the command
mount /mnt/nfs

I've not had to specify any options to mount nfs shares on my own network.
Shdwdrgn, thanks for the suggestion but it still doesn't work. I thought it may be a Wifi problem but I have tried it with my CF ethernet card and still the same problem. I am wondering if it is not something to do with my Belkin wireless router, I can ping my desktop, so it is letting ICMP through, but maybe not regular packets?? I looked at the router setting and didn't notice anything that should cause this problem.

I am not one to tire easily, I got my GPS up and running with gpsd and roadmap and flite, but this is something that should be really trivial, just can't figure it out sad.gif

I'll try it on another Linux, maybe Mandrake.

BTW on my desktop I run the nfs script .. should I be running anything else
[root@localhost init.d]# ./nfs start
Starting NFS services: [ OK ]
Starting NFS quotas: [ OK ]
Starting NFS daemon: [ OK ]
Starting NFS mountd: [ OK ]

[root@localhost init.d]# cat /etc/exports
[root@localhost init.d]#
OK, after writing the previous post-- it all became clear - my firewall was blocking it smile.gif Stopped the firewall on the desktop and it works -- I'll have to ammend iptables -- not sure why I was letting ICMP through.
Glad to see you got it worked out. Now I wish I were so lucky... I still have not been able to get roadmap working under 3.5.1, either opie or gpe. dry.gif
I thought of upgrading to 3.5.1 but haven't so far. If you let me know where you are stuck with roadmap lperhaps I can help. I'd suggest trying to get gpsd up and running and test it wirh QCfGps to see if your setup is communicating with the satellites and then try and get roadmap working.
Well zroadmap was working fine under 3.2, but I haven't seen any newer ipk files for it. I'm currently running the gpe image and have roadmap 1.0.7 installed. GPSD is running, and when I plug in the serial GPS, the data starts scrolling across the bottom of the roadgps screen. It gets maybe a line or two of info, then the program crashes with the error:
WARNING **: Invalid UTF8 string passed to pango_layout_set_text()
I'm guessing this is happening as soon as the satellite data starts reading in.

I would really like to stick with the gpe image, but roadmap is one of my primary apps, so I may have to go back to an older version of opie.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.