Help - Search - Members - Calendar
Full Version: crosscompile ... ld problems ... on SuSE 9.2
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Martin
Hi ...

I'm trying to crosscompile the nice gpsdrive program from www.ganter.at ... but got problems when crosscompiling ...

running from inside /opt/arm/runzgcc-vfp.sh ... running ./configure with parameters ...

But linker got errors with reading symbols from /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status

...
sh-3.00$ dir -l /opt/arm/3.3.2-vfp/lib/libgobject-2.0*
-rwxr-xr-x 1 iwona users 875 2004-10-06 18:29 /opt/arm/3.3.2-vfp/lib/libgobject-2.0.la
lrwxrwxrwx 1 iwona users 25 2004-10-29 20:13 /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so-> libgobject-2.0.so.0.400.6
lrwxrwxrwx 1 iwona users 25 2004-10-29 20:12 /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so.0 -> libgobject-2.0.so.0.400.6
-rwxr-xr-x 1 iwona users 205476 2004-10-07 16:38 /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so.0.400.6
...

Any ideas?

Thanks a lot
Martin

----------------------------------------------------
mazi1802@linuxnote1:~/GPSdrive-downloads/gpsdrive-2.10pre2> /opt/arm/runzgcc-vfp.sh
pdaXrom cross developer tools 1.1.0 softfloat(VFP)
Type 'exit' for leave shell.

Cross prefix is 'armv5tel-linux-'

Predefined variables:
X11INC - X11 include path
X11LIB - X11 libraries path
QTDIR - QT basedir path

sh-3.00$ LDFLAGS="-Wl,-rpath-link,/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/lib"
sh-3.00$ ./configure --host=armv5tel-cacko-linux --build=i686-linux --x-includes=/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/include --x-libraries=/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/lib --disable-debug --prefix=/usr/local
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for armv5tel-cacko-linux-strip... armv5tel-cacko-linux-strip
checking build system type... i686-pc-linux
checking host system type... armv5tel-cacko-linux
checking for style of include used by make... GNU
checking for armv5tel-cacko-linux-gcc... armv5tel-cacko-linux-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... yes
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether armv5tel-cacko-linux-gcc accepts -g... yes
checking for armv5tel-cacko-linux-gcc option to accept ANSI C... none needed
checking dependency style of armv5tel-cacko-linux-gcc... gcc3
...
----------------------------------------------------
/bin/sh ../libtool --mode=link armv5tel-cacko-linux-g++ -g -O2 -o gpsdrive gpsdrive.osplash.o navigation.o speech_out.o friends.o battery.o track.o settings.o garmin_data.o garmin_serial_unix.o garmin_application.o garmin_link.o garmin_util.o gpsdrivegarble.o garmin_legacy.o gpssql.o gpskismet.o LatLong-UTMconversion.o gpsserial.o gpsnasamap.o gpsmisc.o -Wl,--export-dynamic -pthread -L/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0 -liconv -L/usr/lib -lpcre
armv5tel-cacko-linux-g++ -g -O2 -o gpsdrive gpsdrive.o splash.o navigation.o speech_out.o friends.o battery.o track.o settings.o garmin_data.o garmin_serial_unix.o garmin_application.o garmin_link.o garmin_util.o gpsdrivegarble.o garmin_legacy.o gpssql.o gpskismet.o LatLong-UTMconversion.o gpsserial.o gpsnasamap.o gpsmisc.o -Wl,--export-dynamic -pthread -L/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgtk-x11-2.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgdk-x11-2.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libatk-1.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgdk_pixbuf-2.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libpangoxft-1.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libpangox-1.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libpango-1.0.so -lm /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so /opt/arm/3.3.2-vfp/lib/libgmodule-2.0.so -ldl /opt/arm/3.3.2-vfp/lib/libgthread-2.0.so -lpthread /opt/arm/3.3.2-vfp/lib/libglib-2.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libiconv.so -L/usr/lib /usr/lib/libpcre.so -Wl,--rpath -Wl,/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib -Wl,--rpath -Wl,/opt/arm/3.3.2-vfp/lib -Wl,--rpath -Wl,/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib -Wl,--rpath -Wl,/opt/arm/3.3.2-vfp/lib
/opt/arm/3.3.2-vfp/lib/libgobject-2.0.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [gpsdrive] Fehler 1
make[2]: Leaving directory `/home/mazi1802/GPSdrive-downloads/gpsdrive-2.10pre2/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/mazi1802/GPSdrive-downloads/gpsdrive-2.10pre2'
make: *** [all] Fehler 2

----------------------------------------------------
seachicken
You need to be linking to:

/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgobject-2.0.so

CODE
[finch@localhost ~]$ file /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgobject-2.0.so.0.400.6
/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgobject-2.0.so.0.400.6: ELF 32-bit LSB shared object, ARM, version 1 (ARM), not stripped


rather than:
/opt/arm/3.3.2-vfp/lib/libgobject-2.0.so

CODE
$ file /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so.0.400.6
/opt/arm/3.3.2-vfp/lib/libgobject-2.0.so.0.400.6: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), stripped


Andy
Martin
Hi ...

Thanks :-) but had no time the last few days ...


... could not get the linker use /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgobject-2.0.so instead of /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so

sh-3.00$ ./configure --host=armv5tel-cacko-linux --build=i686-linux --x-includes=/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/include --x-libraries=/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/lib --disable-debug --prefix=/usr/local

runs well creating makefile ... but could not verify where this wrong linked lib comes from

---------------------------------------------------------------------------
/bin/sh ../libtool --mode=link armv5tel-cacko-linux-g++ -g -O2 -o gpsdrive gpsdrive.osplash.o navigation.o speech_out.o friends.o battery.o track.o settings.o garmin_data.o garmin_serial_unix.o garmin_application.o garmin_link.o garmin_util.o gpsdrivegarble.o garmin_legacy.o gpssql.o gpskismet.o LatLong-UTMconversion.o gpsserial.o gpsnasamap.o gpsmisc.o -Wl,--export-dynamic -pthread -L/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0 -liconv -L/usr/lib -lpcre
armv5tel-cacko-linux-g++ -g -O2 -o gpsdrive gpsdrive.o splash.o navigation.o speech_out.o friends.o battery.o track.o settings.o garmin_data.o garmin_serial_unix.o garmin_application.o garmin_link.o garmin_util.o gpsdrivegarble.o garmin_legacy.o gpssql.o gpskismet.o LatLong-UTMconversion.o gpsserial.o gpsnasamap.o gpsmisc.o -Wl,--export-dynamic -pthread -L/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgtk-x11-2.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgdk-x11-2.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libatk-1.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgdk_pixbuf-2.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libpangoxft-1.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libpangox-1.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libpango-1.0.so -lm /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so /opt/arm/3.3.2-vfp/lib/libgmodule-2.0.so -ldl /opt/arm/3.3.2-vfp/lib/libgthread-2.0.so -lpthread /opt/arm/3.3.2-vfp/lib/libglib-2.0.so /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libiconv.so -L/usr/lib /usr/lib/libpcre.so -Wl,--rpath -Wl,/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib -Wl,--rpath -Wl,/opt/arm/3.3.2-vfp/lib -Wl,--rpath -Wl,/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib -Wl,--rpath -Wl,/opt/arm/3.3.2-vfp/lib
/opt/arm/3.3.2-vfp/lib/libgobject-2.0.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [gpsdrive] Fehler 1
make[2]: Leaving directory `/home/mazi1802/GPSdrive-downloads/gpsdrive-2.10pre2/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/mazi1802/GPSdrive-downloads/gpsdrive-2.10pre2'
make: *** [all] Fehler 2
---------------------------------------------------------------------------


LDFLAGS not set in Makefile ... :-(

Thanks for help
Martin ph34r.gif
Martin
Hi :-)

Nobody any idea ? I cannot believe :-(

Martin
lardman
QUOTE
... could not get the linker use /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/libgobject-2.0.so instead of /opt/arm/3.3.2-vfp/lib/libgobject-2.0.so


The two should be the same; one is a symlink to the other.

Once you source the env-var script (or do you have to run a script which starts a new bash shell?), what does ld point to? Is it the cross-toolchain version, or your native one (that's what I'd guess).

To fix this, add whichever of: /opt/arm/3.3.2-vfp/armv5tel-cacko-linux/bin and /opt/arm/3.3.2-vfp/bin is not already in the path, to the front of the path. One of these (and I can't remember which is which) contains binaries called armv5tel-cacko-linux-gcc (and so on), the other will contain a plain gcc which is symlinked to the other one (or perhaps the symlink goes the other way?).

This will sort your problem out. That said, you might be better to edit the makefile to ensure that the $LINKER variable points to the correct version: armv5tel-cacko-linux-ld.

Regards,


Simon
Martin
@simon

Hi :-)

As you can see in my starting post I'm using that /opt/arm/runzgcc-vfp.sh script from pdaXrom sdk ... starting a new shell ...

starting ./configure with ./configure --host=armv5tel-cacko-linux --build=i686-linux --x-includes=/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/include --x-libraries=/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/lib --disable-debug --prefix=/usr/local

make

Thanks
Martin


------------------ set inside /opt/arm/runzgcc-vfp.sh ----------------------------
...
export BASEDIR=/opt/arm/3.3.2-vfp
export SDK_VERSION="1.1.0 softfloat(VFP)"

export X11DIR=$BASEDIR/armv5tel-cacko-linux/X11R6
export X11INC=$X11DIR/include
export X11LIB=$X11DIR/lib

export QTDIR=$BASEDIR/armv5tel-cacko-linux/qt
#export QMAKEDIR=$QTDIR/mkspecs
#export QMAKESPEC=linux-arm-g++
export PATH=$BASEDIR/bin:$QTDIR/bin:$X11DIR/bin:$PATH
export LD_LIBRARY_PATH=$BASEDIR/lib

#export LDFLAGS=$BASEDIR/armv5tel-cacko-linux/lib

export PKG_CONFIG_PATH=$BASEDIR/armv5tel-cacko-linux/lib/pkgconfig:$X11LIB/pkgconfig:$QTDIR/lib/pkgconfig
...
-------------- set inside script-shell ----------------------
mazi1802@linuxnote1:~/GPSdrive-downloads/gpsdrive-2.10pre2> /opt/arm/runzgcc-vfp.sh
pdaXrom cross developer tools 1.1.0 softfloat(VFP)
Type 'exit' for leave shell.

Cross prefix is 'armv5tel-linux-'

Predefined variables:
X11INC - X11 include path
X11LIB - X11 libraries path
QTDIR - QT basedir path

sh-3.00$ pwd
/home/mazi1802/GPSdrive-downloads/gpsdrive-2.10pre2
sh-3.00$ set
ACLOCAL_FLAGS='-I /opt/gnome/share/aclocal'
BASEDIR=/opt/arm/3.3.2-vfp
BASH=/bin/sh
BASH_VERSINFO=([0]="3" [1]="00" [2]="0" [3]="1" [4]="release" [5]="i586-suse-linux")
BASH_VERSION='3.00.0(1)-release'
COLORTERM=
COLUMNS=91
CPU=i686
CVS_RSH=ssh
DESKTOP_LAUNCH=kde-open
DESKTOP_SESSION=default
DIRSTACK=()
DISPLAY=:0.0
DM_CONTROL=/var/run/xdmctl
EUID=500
GNOME2_PATH=/usr/local:/opt/gnome:/usr
GNOMEDIR=/opt/gnome
GNOME_PATH=:/opt/gnome:/usr
GPG_AGENT_INFO=/tmp/gpg-taytwv/S.gpg-agent:4454:1
GROFF_NO_SGR=yes
GROUPS=()
GTK2_RC_FILES=/etc/opt/gnome/gtk-2.0/gtkrc:/opt/gnome/share/themes/Qt/gtk-2.0/gtkrc:/home/mazi1802/.gtkrc-2.0-keramik:/home/mazi1802/.kde/share/config/gtkrc
GTK_RC_FILES=/etc/opt/gnome/gtk/gtkrc:/opt/gnome/share/themes/Geramik/gtk/gtkrc:/home/mazi1802/.gtkrc-keramik:/home/mazi1802/.kde/share/config/gtkrc
G_BROKEN_FILENAMES=1
HISTFILE=/home/mazi1802/.bash_history
HISTFILESIZE=1000
HISTSIZE=1000
HOME=/home/mazi1802
HOST=linuxnote1
HOSTNAME=linuxnote1
HOSTTYPE=i386
IFS='
'
INFODIR=/usr/local/info:/usr/share/info:/usr/info
INFOPATH=/usr/local/info:/usr/share/info:/usr/info
INPUTRC=/etc/inputrc
JAVA_BINDIR=/usr/lib/jvm/jre/bin
JAVA_HOME=/usr/lib/jvm/jre
JAVA_ROOT=/usr/lib/jvm/jre
JRE_HOME=/usr/lib/jvm/jre
KDEHOME=/home/mazi1802/.kde
KDE_FULL_SESSION=true
KDE_MULTIHEAD=false
KDE_NO_IPV6=1
KONSOLE_DCOP='DCOPRef(konsole-5277,konsole)'
KONSOLE_DCOP_SESSION='DCOPRef(konsole-5277,session-1)'
LANG=de_DE@euro
LD_HWCAP_MASK=0x20000000
LD_LIBRARY_PATH=/opt/arm/3.3.2-vfp/lib
LESS='-M -I'
LESSCLOSE='lessclose.sh %s %s'
LESSKEY=/etc/lesskey.bin
LESSOPEN='lessopen.sh %s'
LESS_ADVANCED_PREPROCESSOR=no
LINES=26
LOADEDMODULES=
LOGNAME=mazi1802
LS_COLORS='no=00:fi=00:di=01;34:ln=00;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;3
;01:or=40;31:ex=00;32:*.cmd=00;32:*.exe=01;32:*.com=01;32:*.bat=01;32:*.btm=01;3
:*.dll=01;32:*.tar=00;31:*.tbz=00;31:*.tgz=00;31:*.rpm=00;31:*.deb=00;31:*.arj=0
;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.zoo=00;31:*.z=00;31:*.Z=00;31:*.gz=00;
1:*.bz2=00;31:*.tb2=00;31:*.tz2=00;31:*.tbz2=00;31:*.avi=01;35:*.bmp=01;35:*.fli
01;35:*.gif=01;35:*.jpg=01;35:*.jpeg=01;35:*.mng=01;35:*.mov=01;35:*.mpg=01;35:*
pcx=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01;35:*.ppm=01;35:*.tga=01;35:*.tif=01;3
:*.xbm=01;35:*.xpm=01;35:*.dl=01;35:*.gl=01;35:*.aiff=00;32:*.au=00;32:*.mid=00;
2:*.mp3=00;32:*.ogg=00;32:*.voc=00;32:*.wav=00;32:'
LS_OPTIONS='-N --color=tty -T 0'
MACHTYPE=i686-suse-linux
MAILCHECK=60
MANPATH=/usr/local/man:/usr/share/man:/usr/X11R6/man:/opt/gnome/share/man:/opt/kde3/man:/opt/gnome/man
MINICOM='-c on'
MODULEPATH=/usr/share/modules/versions:/usr/share/modules/modulefiles
MODULESHOME=/usr/share/modules
MODULE_VERSION=3.1.6
MODULE_VERSION_STACK=3.1.6
NNTPSERVER=news
OPENWINHOME=/usr/openwin
OPTERR=1
OPTIND=1
OSTYPE=linux
PAGER=less
PATH=/opt/arm/3.3.2-vfp/bin:/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/qt/bin:/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/X11R6/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/opt/kde3/bin:/usr/lib/jvm/jre/bin
PIPESTATUS=([0]="0")
PKG_CONFIG_PATH=/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib/pkgconfig:/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/X11R6/lib/pkgconfig:/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/qt/lib/pkgconfig
POSIXLY_CORRECT=y
PPID=6304
PROFILEREAD=true
PS1='\s-\v\$ '
PS2='> '
PS4='+ '
PWD=/home/mazi1802/GPSdrive-downloads/gpsdrive-2.10pre2
PYTHONSTARTUP=/etc/pythonstart
QTDIR=/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/qt
SDK_VERSION='1.1.0 softfloat(VFP)'
SESSION_MANAGER=local/linuxnote1:/tmp/.ICE-unix/4540
SHELL=/bin/bash
SHELLOPTS=braceexpand:emacs:hashall:histexpand:history:interactive-comments:monitor:posix
SHLVL=4
SSH_AGENT_PID=4455
SSH_ASKPASS=/usr/lib/ssh/x11-ssh-askpass
SSH_AUTH_SOCK=/tmp/ssh-BcPAXe4407/agent.4407
STYLE=keramik
TERM=xterm
TEXINPUTS=::/home/mazi1802/.TeX:/usr/share/doc/.TeX:/usr/doc/.TeX:/home/mazi1802/.TeX:/usr/share/doc/.TeX:/usr/doc/.TeX
UID=500
USER=mazi1802
USE_FAM=
WINDOWID=54525959
WINDOWMANAGER=/usr/X11R6/bin/kde
X11DIR=/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/X11R6
X11INC=/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/X11R6/include
X11LIB=/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/X11R6/lib
XCURSOR_SIZE=
XCURSOR_THEME=crystalwhite
XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
XKEYSYMDB=/usr/X11R6/lib/X11/XKeysymDB
XMODIFIERS=@im=local
XNLSPATH=/usr/X11R6/lib/X11/nls
XSESSION_IS_UP=yes
_=pwd
no_proxy=localhost
sh-3.00$
--------------------------------------------
lardman
Try editing the following line in the /opt/arm/runzgcc-vfp.sh script:

Change:
export PATH=$BASEDIR/bin:$QTDIR/bin:$X11DIR/bin:$PATH

to:
export PATH=$BASEDIR/bin:$BASEDIR/armv5tel-cacko-linux/bin:$QTDIR/bin:$X11DIR/bin:$PATH


Si
Martin
@simon ... again

THANKS ... but did not change anything :-(

... which user/group do all the sdk crosscompoiler files have? root/root ... or root/users <anyexistinguser>/users ???

... trying to install SDK crosscompiler again ... helps nothing ...

... getting sources again ... helps nothing ...

... as you see the libs are NOT the same and NOT a link only in this two different lib-directories ... and there are several files existinmg only in one of the directories :-(

I'm now at the end of my knowledge :-(((

Martin

----------------------/opt/arm/3.3.2-vfp/lib---------------------
-rwxr-xr-x 1 root users 875 2004-10-06 18:29 libgobject-2.0.la
lrwxrwxrwx 1 root users 25 2004-10-29 20:13 libgobject-2.0.so -> libgobject-2.0.so.0.400.6
lrwxrwxrwx 1 root users 25 2004-10-29 20:12 libgobject-2.0.so.0 -> libgobject-2.0.so.0.400.6
-rwxr-xr-x 1 root users 205476 2004-10-07 16:38 libgobject-2.0.so.0.400.6
...
lrwxrwxrwx 1 root users 13 2004-10-29 20:12 libz.so -> libz.so.1.1.4
lrwxrwxrwx 1 root users 13 2004-10-29 20:12 libz.so.1 -> libz.so.1.1.4
-rwxr-xr-x 1 root users 51728 2004-10-07 16:38 libz.so.1.1.4
...
-------------------/opt/arm/3.3.2-vfp/armv5tel-cacko-linux/lib------------------------
lrwxrwxrwx 1 root users 25 2004-10-29 20:15 libgobject-2.0.so -> libgobject-2.0.so.0.400.6
lrwxrwxrwx 1 root users 25 2004-10-29 20:14 libgobject-2.0.so.0 -> libgobject-2.0.so.0.400.6
-rwxr-xr-x 1 root users 222491 2004-10-06 18:31 libgobject-2.0.so.0.400.6
...
lrwxrwxrwx 1 root users 13 2004-10-29 20:14 libz.so -> libz.so.1.1.4
lrwxrwxrwx 1 root users 13 2004-10-29 20:14 libz.so.1 -> libz.so.1.1.4
-rwxr-xr-x 1 root users 66341 2004-10-06 18:25 libz.so.1.1.4
...
-------------------------------------------
Mickeyl
Not wanting to sound like a smartass, but why-o-why are you fumbling manually with that stuff ?

There's a shitload of metadata waiting for you to use in the OpenEmbedded repository. We already solved lots of cross compilation problems in a general way - new packages can be added _very_ easily and this is the reason why every OE generated feed now features over 2000 packages. We did this all with just a handful of people because the OpenEmbedded build system is so powerful.

You could add the necessary infrastructure to build pdaXrom packages pretty easily if you were motivated to look into it. All communities would benefit from that.
Martin
@mickeyl

... nice but not very helpful your stupid comments ... hope they will lock your acount ...

Martin
lardman
QUOTE
@mickeyl

... nice but not very helpful your stupid comments ... hope they will lock your acount ...

Martin


I presume that comment just came out wrong; I'd be very hesitant before making a comment like that, especially when you're talking to someone who knows what they are talking about.

In any case I agree with Mickey, it would be a far less painful process if you (and by that I mean all the pdaXrom people) used OE, it would also produce benefits for both sides as each could use the others' packages, etc.

Back to your problem briefly: it should work (in my limited experience at least), if it doesn't then there's either something wrong with your toolchain (I don't know why those two files are different sizes for example), or you've made a mistake.

Regards,


Simon
Martin
@simon

thanks for your comment ... but I'm not very familar with OE ... does not know what do you mean with manually ...

Is there a good paper reading about OE ... for crosscompile with pdaXrom ... I have problem to get right with allll these automatisms with doing everything automatic ;-) ... I a programmer from the first time running everything by hand ... not getting the benefits of ++ in my head *smile*

@mickeyl
sorry for my biting backward comment ;-) ...

Thanks a lot and hope to get it right
Martin
BVer
Martin,

in one of your previous posts you wrote:
QUOTE
starting ./configure with ./configure --host=armv5tel-cacko-linux --build=i686-linux --x-includes=/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/include --x-libraries=/opt/arm/3.3.2/armv5tel-cacko-linux/X11R6/lib --disable-debug --prefix=/usr/local

which assumes $BASEDIR is "/opt/arm/3.3.2", but otherwise it looks like you are using "/opt/arm/3.3.2-vfp". Perhaps mixing VFP and pre-VFP SDK versions?
runzgcc-vfp.sh and configure.sh must use the same base dir i think.

-bver
Martin
@BVer

Thanks for your post ... I think it is an older post of mine where I use pdaXrom 1.0.5 for the first time ... very happy about pdaXrom :-) ...

... at the moment I'm using pdaXrom 1.1.0 Kathrin RC5 ... deleted all other stuff, older generic ARM linux SDKs too ...

... at the moment I'm erasing everything on my linuxbox which is from ARM (cross-)compile SDKs or something has to do with it ... installing pdaXrom SDK again from scratch ...

... installing , using new sourecodes for my crosscompile Apps ... hoping it will solve my problems ...

Thanks
Martin
gromituk
QUOTE(Martin @ Nov 25 2004, 02:56 AM)
Is there a good paper reading about OE ... for crosscompile with pdaXrom

Yes - as someone new to the SDK who has just read this thread, if you tell me what to do I will try it!
Martin
@gromituk

What do you want to say with your post? I could not really understand!

Thanks
Martin
gromituk
Sorry - I wasn't clear. I was quoting you to emphasise what you said to Mickeyl.
ScottYelich
blah!

I think mickeyl's post was extremely poignant!

2000 packages.... compare that to a feed we have now for pdaxrom.

Scott
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.