Help - Search - Members - Calendar
Full Version: Gaim
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 6000 - Tosa
Pages: 1, 2
zipmaster
ok I've installed all the packages that are on there .4 feed and it loads fine but there are no icons or anything. I also tried the libpng fix they have on the site.
eurojeff
I had the same problem.


No pictures display when I run Gaim.

The version of libopie that Gaim requires is not compatible with the libpng on many ROMs, such as the Sharp ROM. To fix this, download libpng.so.2.1.0.9 and place it in your /usr/lib directory. Then, from a terminal, symlink the library as follows:

cd /usr/lib
ln -sf libpng.so.2.1.0.9 libpng12.so
ln -sf libpng.so.2.1.0.9 libpng12.so.0
ln -sf libpng.so.2.1.0.9 libpng12.so.0.1.2.5

GAIM FAQ:
http://qpe-gaim.sourceforge.net/faq.php#libpng

works like a charm now.

eurojeff
zipmaster
yeah i did that and it still doesnt work
tumnus
You don't need to install libpng. It is compiled into the Qtopia library and is compatible with libopie, so all you have to do is run the following command as root:

ln -sf libqte.so.2.3.2 /usr/lib/libpng12.so.0

I don't have any other reference to libpng and this works fine for Gaim.
naoyaru
QUOTE(zipmaster @ Nov 9 2004, 12:37 AM)
yeah i did that and it still doesnt work

Just in case
did you su after make the changes?
zipmaster
tunnus: thanks ill try that now. [edit] just tried it still no go sad.gif [/edit]

nao: im sorry i dont know what u mean
tumnus
Are you using this libopie? Don't use any other as they have not been compiled for the Sharp ROM.
zipmaster
oh it seems i have an old one ill get that one and install it tonight

[edit] it seems that site is down so can someone post the file for me?[/edit]
zipmaster
ok i got the package now and well its not working still. hmm maybe i should del all these libpng links i have in my lib directory?
sgtron
Ok, I downloaded the many files and installed all of them. Then I put in the sim links above. Now GAIM loads without crashing, shows icons... but doesn't connect to Yahoo. I have Qazoo on my Z and it works fine, so I looked at the settings. I found GAIM was using scs.yahoo.com for messaging, while Qazoo had scs.msg.yahoo.com. I made the change on GAiM but nothing... still can't get yahoo to connect with GAIM.

AIM & MSN connect fine, it's only Yahoo I have trouble with.

Any thoughts?
zipmaster
hey sgtron which libpng system link methiod you use?
sgtron
I used the 3 links from the above post which are the same as the ones on the gaim web page.. then i threw in the 4th for good measure.. still no yahoo..
zipmaster
i only got this to work and can confirm that yahoo doesnt work. this is because yahoo changed there login resently i believe so gaim has to update its yahoo plugin to go with the new protocal.
sgtron
Glad to hear there are others having problems with this and not just me.. Qazoo still works though.. I wish yahoo et. al. wouldn't keep changing their protocols.. just accept that gaim and others will adapt sooner or later anyway and just settle on a standard.. sheesh...
GuruGeek2002
I have followed the directions on the sourceforge page and I have followed the instructions in this thread. When I click on the gaim icon I get a screen that says, please wait, but then eventually it drops back to the desktop. I never see anything in regards to Gaim actually launching or working....

Any ideas?

Thanks,
Roger
sgtron
Interesting scenario.. I wonder if you made all the correct links..
What worked for me (apart from yahoo) was to follow the directions on the gaim website.. which were echoed here on this page.

If I were you, I'd try to launch gaim from the command line and see what kind of errors I got.. that may give us some insight as to what's happening.
GuruGeek2002
I launch the terminal and then type su.

I then type gaim and press enter...

gaim: error while loading shared libraries: libopie.so.1: cannot load shared object file: No such file or directory

I'm guessing this means I need to install libopie.so.1 ?
sgtron
It's possible, I have libopie1 installed, maybe that's what you need. I don't remember installing it for GAIM, but couldn't swear to it... give it a try.
GuruGeek2002
I installed the libopie1.so package and now Gaim launches fully.

But, now the problem is, I don't have any menus to add contacts. There is no file, edit, or view menu at the top, nor are there any icons to work with.

I'm going to try the ln stuff again. Maybe I mistyped one or perhaps it would work better now that I have all the necessary files.....

If you can think of anything else I should try, please let me know!

Thanks,
Roger
GuruGeek2002
Ok, GAIM works for me now. Added libopie1 and that libpng.so.2.1.0.9 thing and then redo the symbolic links.

I have icq running. Trying to remember my AIM password.....and when connecting to yahoo, It stays at 1% forever but never connects.

Thank you for the help!!!

Let me know if you ever get yahoo to work...
sgtron
Congratulations... now you're in the same boat as the rest of us...

For Yahoo, I'm using Qazoo, it would be better for GAIM to do it all, but in the meantime, you can just use the two programs.
tumnus
I use Jabber through Gaim to get to Yahoo, MSN and AOL. You just need to use an up-to-date Jabber server and then you don't have to worry about updating Gaim or whatever IM client all the time as the Jabber server handles all that.
zipmaster
QUOTE(tumnus @ Dec 9 2004, 01:44 AM)
I use Jabber through Gaim to get to Yahoo, MSN and AOL. You just need to use an up-to-date Jabber server and then you don't have to worry about updating Gaim or whatever IM client all the time as the Jabber server handles all that.

i never understood how jabber handled aim and all the other protocols but maybe thats a different thread right?
sgtron
Probably should be a different thread, but to answer your question, Jabber servers keep (can keep) multiple chat protocols for you to access with a Jabber client. You just have to register through your client with an open Jabber server and away you go.

see http://www.jabber.org/user/publicservers.php for a better understanding
saakmotu
I've gotten Gaim running on my 6k with the stock Sharp ROM, but I am not getting any "notify" on messages. Neither the LED or the buzzer.

Anyone else?

====

Edit..

My bad.. the buzzer (or more appropriately "horn") does work...

But I still don't see any LED indication... at least not yet..

I suppose that's subject to change. wink.gif
GuruGeek2002
Strangely enough, I don't get a sound, buzzer, or bell when I get a new message with gaim....with icq or aim.......I don't get a blinking icon either...no way to know unless I double click on persons username....strange.....I even went into the "edit account" screen and checkmarked "new mail notification". Still nothing...
saakmotu
Just to make sure you have your volume on, not muted and the "alarms" checkbox in the volume applet checked.

My first attempts which failed to give me a sound/buzzer were IMs I sent to myself on the Z from the Z.

Then I sent from my desktop to the Z and it honked at me.
GuruGeek2002
Yep....alarm box has a checkmark in it....and the z is not muted. :-)
zipmaster
for me it only alarms the buzzer that is when im not looking at the tab of the person that just sent me the msg. in other word when the contact is out of focus
oyku
I've followed the instructions and downloaded libpng from gaim FAQ linkand created symbolic links. Gaim now works fine and changing the magnification setting from the desktop icon it looks great. However I cannot connect to Yahoo neither from Z nor from my desktop gaim. I think it is a gaim issue. Maybe you have noticed already but the application dies when I hit the group chat button (I guess) the secondone from top left. I can live without it. although.. just for the records..

cheers
Tehas
Straight connect to Yahoo broke quite a while ago - hasn't been any maint to this version of Gaim to fix it. I use qazoo for Yahoo IMs.

I noticed that if you open a second chat window that it fails if the conversation window in the background gets a message.
soundwave106
Yahoo changed their Instant Messenger protocol, I think it was about a year ago and basically broke every one of the IMs out there. I remember old Trillian versions for instance wouldn't work without a patch.

I use Qazoo as well, I actually find that to be a much nicer program than Gaim overall.
GuruGeek2002
Could someone check and let me know what msn is using for a login server and port? My zaurus gaim has messenger.hotmail.com at port 1863. It's not connecting. When I click on the connection button, nothing happens. I don't even see a progress bar as with icq or aim.

Thanks,
Roger
xjqian
MSN on Gaim is also very tricky for me. So far I get it worked out but crashes often when I try to edit the MSN protocol setting. Anyway, the default setting just works fine and after successfully checked auto-login and saved pwd on some rare cases, I just leave it alone. Trying to check the email notification give me nightmare several times (crashes upon gaim startup). I have to uninstall everything and start from the very beginning. So I'm not going near that anymore.

GuruGeek: the default works fine for me: messenger.hotmail.com at port 1863

The following are my experiences after numorous try-n-error. Not neccesary correct as I have next to zero backgroup on Linux, but just works for me (stock sharp rom 1.12). (There shouldn't be any warning if installing by the listed order). All libs and qpe-gaim should be installed in the internal memory, otherwise MSN on gaim crashes upon startup or connecting.

zlib 1.1.2 (zlib 1.2.1 causes msn login no response)
libopie1 1.0.2
libglib
gconv-tiny
libgcrypt1
libgnutls (requires libopie1 1.0.2)
libgaim-ssl (requires libopie 1.0.2)
libgaim-protocal-msn

libpng + fix (icon display)
cd /usr/lib
ln -sf libpng.so.2.1.0.9 libpng12.so
ln -sf libpng.so.2.1.0.9 libpng12.so.0
ln -sf libpng.so.2.1.0.9 libpng12.so.0.1.2.5

libgaim
qpe-gaim (requires libgaim)
worri
QUOTE(xjqian @ Dec 20 2004, 07:21 AM)
MSN on Gaim is also very tricky for me. So far I get it worked out but crashes often when I try to edit the MSN protocol setting. Anyway, the default setting just works fine and after successfully checked auto-login and saved pwd on some rare cases, I just leave it alone. Trying to check the email notification give me nightmare several times (crashes upon gaim startup). I have to uninstall everything and start from the very beginning. So I'm not going near that anymore.

GuruGeek: the default works fine for me: messenger.hotmail.com at port 1863

The following are my experiences after numorous try-n-error. Not neccesary correct as I have next to zero backgroup on Linux, but just works for me (stock sharp rom 1.12). (There shouldn't be any warning if installing by the listed order). All libs and qpe-gaim should be installed in the internal memory, otherwise MSN on gaim crashes upon startup or connecting.

zlib 1.1.2 (zlib 1.2.1 causes msn login no response)
libopie1 1.0.2
libglib
gconv-tiny
libgcrypt1
libgnutls (requires libopie1 1.0.2)
libgaim-ssl (requires libopie 1.0.2)
libgaim-protocal-msn

libpng + fix (icon display)
cd /usr/lib
ln -sf libpng.so.2.1.0.9 libpng12.so
ln -sf libpng.so.2.1.0.9 libpng12.so.0
ln -sf libpng.so.2.1.0.9 libpng12.so.0.1.2.5

libgaim
qpe-gaim (requires libgaim)

Thank you xjqian! it works now.

but it can't show Chinese character both in buddy list and in im window, also I can input Chinese character.

Any advice?
GuruGeek2002
I made sure I have all of the packages you listed. There were a couple I did not have.

Now MSN connects biggrin.gif

Thanks for the help!!
Roger
eji
What sort of response should I get in the terminal when I make the symbolic links?

For example, when I type "ln -sf...." and so on, and hit hard return, what notification will I get that the link has been created? Will I be able to see the symlink using a file explorer application?

I was having the same trouble as many of you have had, i.e., with the libpng image display issues, but that seems to have been resolved in spite of not being able to verify the symlink. Now when I type "su" and then #"gaim" in the terminal, I get something like, "OE/Embedded is not owned by user 0." Is this some kind of permissions issue? How do I resolve it? I have all the libraries.
oyku
You would not get get any responses. That's more Linux than Zaurus. in the directory you've created links type "ls -l" then you'll see in the listing.

Hope this helps
eji
I've made all the symlinks and I keep getting the messge "ln: file exists." I suppose I'll go through and delete them and see what happens.

As for su'ing GAIM from the terminal, I get the error: "Qt/Embedded data directory is not owned by user )." What can fix this? I've tried running GAIM as root, but the problem persists.
soundwave106
Can you run GAIM *not* as root? I've noticed that some programs for some reason don't like you to run as root when the installed directory, or any configuration files, is owned by the zaurus user. Not sure of the technical details.

If you have problems with both, you can use the chown Unix command to set all the directories to (preferably) zaurus.
eji
Running GAIM as root or non-root makes no difference. No icons display in the GUI, and working from the terminal I get the same error msg: "Qt/Embedded data directory is not owned by user 0."

On my iBook I'd simply run a permissions fix from the Disk Utility and it would probably clear this issue up. On the Z it's not as easy.

What exactly would I type in to the terminal to chown the appropriate files? And what files am I looking for exactly? Am I taking serious risks if something goes awry while revising the permissions?

Thanks, everyone, for all the tech help. I'm desperately trying to get the hang of this.
soundwave106
OK, I think I know what's going on. I tried running GAIM from the su user and got the same error.

Firstly, GAIM was never meant to be set up to be run under the su account. So don't do that. smile.gif (At least I get the same QT/Embedded data directory error, whatever that means. tongue.gif ).

When you run it under the standard Zaurus account, do you get a bunch of messages stationg that it cannot open /home/zaurus/.gaim type stuff? Like: "accounts: Error reading accounts: Failed to open file '/home/zaurus/.gaim/accounts.xml': Permission denied"? With my relatively standard GAIM install, I do not get the QT/Embedded data directory, but got this instead.

The problem in this case is that, for some reason (it seems this way on my box!), the standard GAIM installation set the owner of /home/zaurus/.gaim/ as root. This was where all of the settings were installed. Bad idea, as the zaurus account couldn't write or read anything in this directory under the standard permissions. People got around this by running GAIM as "root" via the Qtopia GUI (which seems a little different than the su account, I don't know why). And it worked. However, it means you can't run GAIM under the terminal this way.

To diagnose:

1) Type the following command in:

ls -la /home/zaurus

(UNIX 101: ls = list a directory. -l option = verbose listing, show file size, owner, permissions, etc. -a option = show "hidden" files, which on UNIX is all files beginning with a .)

One of the entries *SHOULD* look like this:

drwx------ 3 zaurus qpe 0 Jan 3 11:51 .gaim

This is the .gaim directory where all settings are stored.

The owner of this directory should be zaurus. GAIM, however, will not run under the "standard" account when the directory looks like this:

drwx------ 3 root qpe 0 Jan 3 11:51 .gaim

(The column that changed is the owner of the file. That column on the left shows you permissions and says that only an owner can *R*ead, *W*rite, and e*X*ecute a file in this directory.)

To fix this, do the following:

1) su to log in as root
2) Type the following command in:

chown -R zaurus /home/zaurus/.gaim

[You can get an explanation of chown by typing in chown -? in the command prompt. Net summary, I'm changing the ownership of everything in the /home/zaurus/.gaim directory (recursively) to the zaurus user.]

3) Log out of root, you should be back in the zaurus account.
4) Try running gaim under the zaurus account.

Now it should at least come up without bombing out!

If it doesn't run, you may have missed something else in the installation, or have the wrong library (I remember that GAIM was one of the finickiest installs for my SL-6000L.). Report back what you find.

I hope this helps a bit. smile.gif
eji
According to a speed-reading of the slew of terminal errors (where are log files on this thing?), it seems as if it's got everything to do with libpng incompatibility.

What I'm getting specifically is this: "Application was compiled with png.h from libpng-1.0.9.... Application is running with png.c from libpng-1.2.5"

I don't understand what went wrong. I thought I had made all the symlinks.

I suppose I showed my ignorance by trying to run under the su account. I only just figured out what it must stand for: superuser. Doh! I had simply been punching in advice I saw posted elsewhere in this thread.

Soundwave106, I can't thank you enough for spelling everything out. Instead of typing the strings of code, I can make sense of what I'm doing, even if it doesn't necessarily have the best outcome. dry.gif

I'll try making the symlinks again. [Scartch that. Just did and it didn't work.] Should I reinstall the buggy GAIM libpng.so.0.1.2.5 and work from there, or doesn't it matter? Should I delete existing symlinks, and if so, how?
eji
Success! I had to create the symbolic links as su. Now I've got GAIM up and running on the Z. Thanks for everyone's help!
soundwave106
Yeah, that too. smile.gif I'm surprised the system allowed to create the symlinks as zaurus.

And even though my post was in the wrong direction, no problem. I'm glad it helped! (If for nothing else giving you a few basic Unix commands to help out.)
dfisher
This seems like quite an odyssey. Do we need a how-to for this? How does one go about adding a How-To to the ZUG?
xjqian
some alternatives:

*gaim in debian
once you figured out debian, gaim installation is a bleeze

*www.e-messenger.net
working nicely on opera, the extra feature over the gpe-gaim is the emotion and it accepts chinese character once I got chinese support on my opera. "secure login" will crash though.

*Kmerlin
should have the full features as in the original MSN messenger, such as emotion, different fonts, etc. However, still trying to figure out how to make it work in 6K. see my other post in the software section. please let me know how you figured it out.

XXX webmessenger.msn.com
won't work with opera, neither firefox in debian. well, what do you expect from M$ wink.gif
lek
"I installed the libopie1.so package and now Gaim launches fully."



Hi there,
where did you find "libopie.so.1"

Cheers,
lek
adf
has anyone tried qazoo for yahoo on a 6k (or at all for that matter)?
xjqian
QUOTE(adf @ Jan 24 2005, 01:59 AM)
has anyone tried qazoo for yahoo on a 6k (or at all for that matter)?
*


my friend had Qazoo on his 6K, it works pretty well for him.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.