Help - Search - Members - Calendar
Full Version: Can a CF card be chowned?
OESF Forums > General Forums > General Support and Discussion > General Discussion
ShiroiKuma
Hi:

I've formatted my CF card with ext2 and probably did something wrong. I can't create files, write to CF as zaurus. Only root can write.

Also, not sure if it's associated with this, but seems like: I'm using the ext2fsd driver on my PC to access the ext2 files from Windows and I can read the card but not write to it.

Can the whole card somehow be currently chowned by root or something?

How can I fix this?
Stubear
The perms of a mounted filesystem can be set for the whole filesystem, but more usually for the individual directories/files on the filesystem (vfat however must be mounted as a particular user as it doesn't support permissions properly)

However if you were root when you copied files to the card you most probably made all the directories owned by root, therefore zaurus user won't be able to create files.

cd to /mnt/card and run
CODE
chown -R zaurus.qpe ./
to give zaurus ownership of all files and directories (this may take some time)

Most of the ext2 drivers for windows that I tried before I changed to reiserfs were read-only by default - some of them had options that allowed read-write but some of them didn't. Check the options available for your driver (beware some ofthe ones I tried were maga-dodgy and hosed my filesystems)

Stu
ShiroiKuma
Yes, I think this ext2fsd driver supports writing to ext2 volumes.

However I'm still running into permissions problems. I chowned everything to zaurus, however since in Windows I'm not logged in as zaurus, still can't write files.

Is there a way to say chown a directory, so that everyone could write to it?

I tried chowning to my Windows username, however it says: User XXXXX not know.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.