Help - Search - Members - Calendar
Full Version: Irda Nokia Connection
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
nontrivial
Howdy Folks,

I am generally having fun with RC5 on my c750, but I am trying to get irda working to use my Nokia 8290 as a modem. I found a page (http://www.insomniq.com/files/zaurus/IrDA-HOWTO.html) so I think it is theoretically possible. I have gotten further with my Zaurus than with my laptop, though. :-)

First prong of attack is to us a conventional approach. Namely, the pdaxrom PPP tools and /dev/ircomm0. I go to dial and the connection tool tells me what I can go do with myself.

The second prong of attack is to use gnokii. I have used the SDK and now have 0.6.4 installed. xgnokii is waaaaaaay cool running on the zaurus, BTW! Anyway, I can talk to the phone just fine, jack with contacts, send SMS's, etc. When I run gnokiid a gnokii device is created as expected. When I point pppd at it I get much further, namely an OK back, but then I get an ERROR and it goes downhill after that.

So, my main question is, does anybody else using thier Nokia as a modem via IR? I don't have much experience with dialup. Does anybody have any suggestions? Does anybody have a minicom IPK handy so that I can poke about?

James
nontrivial
Well, I guess this is an update. I have given up on gnokiid since it never reports that it connects. Using straight up irda I can connect to my ISP with minicom, but when I try to connect with pppd I get the following:

chat: Nov 21 20:00:48 CONNECT 9600
Serial connection established.
Using interface ppp0
Connect: ppp0 <--> /dev/ircomm0
Modem hangup
Connection terminated.
bash-3.00#

The annoying thing is that it seems that no pppd option that I try seems to have any effect. Any help would be appreciated.

James
Foxdie
If you provide more information I will try and help you (I work for Vodafone lol).

What init string are you using?
What dialup number are you using?
What cell operator are you using?
What country are you in?
How are you trying to connect? GPRS or CSD?

Your script should look something similar to the following:

QUOTE
# cat /etc/ppp/peers/VodaGPRS
/dev/rfcomm0
115200
connect '/usr/sbin/chat -s -v ABORT "NO CARRIER" ABORT "NO DIALTONE" ABORT "BUSY" "" at+cgdcont=1,"IP","internet" OK ATDT*99# CONNECT'
crtscts
noipdefault
modem
user "web"
usepeerdns
defaultroute
connect-delay 6000
remotename VodaGPRS
nontrivial
Well, looks like I'm going to be too busy to work on this for a while. I can get it to work pretty easy under windows, so my next step is to get irda working on my laptop under linux and try it with that. As for my settings, I am dialing into a computer at work, so I pretty much control both ends. My coworker has no problems using linux and a traditional modem, which is why I thought it might be something wrong with pdaXrom. His setup won't work on my zaurus. I guess I just need to spend a few more nights figuring out what the problem is.

James
Chero
@ nontrivial:

Thanks for the link, xgnokii on pdaXrom is really cool indeed !!

(It took some time to figure out how it works, but I've got it up and running !)
- found a .gnokiirc file on the web : Gnokiirc
- also found out that I had to open my irda (/etc/rc.d/init.d/irda start) before running xgnokii.

For those interested in the download link:
Read this thread

Thanks a lot !
Chero.
Chero
Some nice info about gnokii in here, ipk uploaded in other thread.

Just bringing this info out of the dust.
karlto
Not quite the same hardware, but I have my (old) Nokia 6385 working fine with my SL6000 via IR. I just use the ppp dialer, but it needed patching to remove the second set of double quotes around the password (I think there is a bug report on the pdaXrom site). Also need specific initialisation string for the phone to work without hanging up (Nokia has these somewhere on the net).
Chero
QUOTE(karlto @ Dec 13 2005, 09:15 PM)
Not quite the same hardware, but I have my (old) Nokia 6385 working fine with my SL6000 via IR. I just use the ppp dialer, but it needed patching to remove the second set of double quotes around the password (I think there is a bug report on the pdaXrom site). Also need specific initialisation string for the phone to work without hanging up (Nokia has these somewhere on the net).
*


Sure, I had that too, but wanted to be able to handle phone-books and send sms using the Z.
I uploaded gnokii here

Chero
henrysviper
@nontrivial

Try running pppd with the debug option and see what you get.

You may have a similar situation to mine: I get this "modem hangup" message initially, but if I use my mobile to connect with windows XP it works, and after that the mobile works also with the Zaurus (until I switch it off). So my solutiion is: switch the mobile on, connect through it on Windows, and then never switch the mobile phone off!

(BTW: I explain better my situation in this thread )
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.