Help - Search - Members - Calendar
Full Version: Python For Arm Feed
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Python
aki
I am trying to download the package python-distutils_2.3.2-oz1_armv4l-strongarm.ipk from
python for arm-linux feed, but can't get the ipk to install properly using the Add/Remove app. I also tried downloading and saving the file, but tar fails to open with the message "wrong gzip magic".
Anybody knows what's up with that?
Stubear
The ipks were created by OE and hence are ar compressed ipks rather than the gzip compressed ipks used by the Sharp Rom.

Search the forums - there are plenty of posts on converting between the 2 types.

Stu
kopsis
Somewhere on ZSI (Zaurus Software Index) there is an ipkg-new package that will give you a command line ipkg-new tool capable of installing the ar style packages in the Python feed. I found that to be simpler than trying to convert the packages to the old tgz ipk format.
Mickeyl
I've rebuilt my Python distribution with Version 2.4.0 both for SharpROM and for modern distributions. I can't test it for the SharpROM though since I no longer have any devices running a SharpROM (clone). The feed URI for SharpROM is http://vanille.de/feed/python/sharprom/

I'd appreciate some feedback.
dreadlocks
QUOTE(Mickeyl @ Mar 21 2005, 06:37 AM)
I've rebuilt my Python distribution with Version 2.4.0 both for SharpROM and for modern distributions. I can't test it for the SharpROM though since I no longer have any devices running a SharpROM (clone). The feed URI for SharpROM is http://vanille.de/feed/python/sharprom/

I'd appreciate some feedback.
*


while trying to get comprec 0.02 (http://unimut.fsk.uni-heidelberg.de/demi/comprec/index.html) working I got your python for the SharpROM, all went fine but when I try to run the program I get this error:
QUOTE
ImportError: /usr/lib/python2.4/site-packages/qt.so: symbol __register_frame_info, version GLIBC_2.0 not defined in file libc.so.6 with link time refrence


any idea why?

and another question, can you make a package for python-libgmail? It would be cool to use gmailfs on the Zaurus
Mickeyl
the glibc problem is odd, i'll look into it.
I just packaged libgmail and it'll show up later tonite in the SharpROM feed.
TimW
I generally use the oz version of the feed (which is excellent 8^) - I would have given feedback on that earlier but this thread seems to be specifically about the Sharp ROM version) but I'm using the Sharp ROM for a specific project so I tried installing python-base but when I run python I get

Cannot load shared object librt.so.1

Got past that by symlinking to libqte but now I'm stuck at the __register_frame_info problem (but mine is from time.so, which is the first extension library to be loaded).
dreadlocks
ya I had the librt dependency problem too, ive got an ipk of it in my unstable feed (along with the python packages)
http://www.nayr.net/zaurus/feed/unstable/

wished this worked on the sharp rom..
Mickeyl
Updated to 2.4.1. Please report your findings to the other (slightly newer thread).
ztep
I'm trying to compile rekall 2.3 in the Zaurus. It said that python-devel is needed.

Mickeyl, can you add that package to your python arm feed. Thanks.

Rekall also use scons to be build, I have instaled the scons version on your feed but it does not work in the first aproach. The first line in /usr/bin/scons shows a wrong pyton path. I have changed it to /usr/bin/python and know it works.
Mickeyl
Will take a shot at that.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.