Help - Search - Members - Calendar
Full Version: Xmms On Oz3.5.2 Or Oz 3.5.1
OESF Forums > General Forums > General Support and Discussion > Software
i keep getting the same error when trying to run xmms. If i run it from the desktop i get an hour glass blip, and nothing. So upon advice i found in these forums (thanks), a ran it from the command line to get more info. I've tried both oz/opie 3.5.1 and 3.5.2 with no luck, any ideas? on what this means or how to fix it?

root@collie:/# xmms
xmms: error while loading shared libraries: cannot open shared object file: No such file or directory

libglib-2.0-0 is installed, so then i tried to re-install that lib to (2.4.6-r1) and got a qtopia error, so i rebooted, and did a ipkg-link mount /mnt/cf (where i installed xmms). and i still have the same results, with the above shared lib error. any ideas?
QUOTE cannot open shared object file: No such file or directory

Does the file exist in /usr/lib or /usr/local/lib (it may be that you need to create a symlink from ->, etc)?

ipkg-link mount /mnt/cf (where i installed xmms)

If you installed the glib ipk to somewhere other than root (or cf as you've already done that above), you'll also need to do an ipkg-link on that mount point (ie the SD card if that's where you installed it).

ok thanks, I started out trying opie-player2 on OZ/opie 3.5.1, with no luck (kept crashing, no display at all, SIG???), then I re-flashed OZ/opie to 3.5.2, and gave it another try, with the same results. After reading some posts it appears opie-player2 has some bugs, and doesn't work (correct me if i'm wrong), and several people have gone to xmms. So i gave xmms a try on 3.5.2, and got these errors. Since 3.5.2 is still fairilly new, i reflashed back to 3.5.1 and installed xmms again, with the same error. So here i stand, LOL. its interesting that no one else has had this problem. I have a fresh copy of OZ/opie, and installed xmms, that's it, i haven't done anything else. I'm shocked that others installs went ok.

incidentally on 3.5.2, glib was already part of the package, and i did upgrade the glib package, which had no effect. On 3.5.1 (current), i attempted to upgrade glib, and it installed it on the CF instead, so i'm not sure if it was already there or not, but i thought i had glib on root. Reguardless it did have symbolic links in place from /usr/lib to /mnt/cf/usr/lib for the glib package, however...

i looked in /usr/lib and found
and the error was for
so i created that symbolic link (as you indicated, thanks)
ln -s /mnt/cf/usr/lib/ /usr/lib/
and there was already one in /usr/lib for --> /mnt/cf/usr/lib/

with that done i got rid of that error, only to receive one for the package, which i linked to /mnt/cf/opt/QtPalmtop/lib/

it seems ipgk-link umount /mnt/cf wipes out my manual links, and it doesn't completely remove the ones it added, such as the /opt/QtPalmtop/lib/xmms/ directory, when you ipkg-link mount /mnt/cf again, it complains that those files alreaady exist, just FYI, no big deal there, but irrataing that it wipes out my links.

so i created a script to put in my manual symbolic links for libglib and libxmms.

with that done i'm yet stuck again, i am receiveing the error:

Segmentation fault

You've probably found a bug in Qtopia...... etc etc

and suggestions for this step??
Updated my signature, and going to re-flash to 3.5.2 and try this all again. I really enjoy the bug fixes in 3.5.2. such as the file manager working right, and the ability to install local ipkg in the package manager.
I got xmms work on OZ3.5.2

About the libglib error.
Basically, you have to remove the broken sym link in /usr/lib

rm -rf /usr/lib/libgl*
then do a sym link where you install xmms (sd or cf) in my case (sd)

ln -s /mnt/card/usr/lib/libgl* /usr/lib

then try to start xmms from terminal to see if there are any error left.
I got some error about missing plugin..

do the same thing as above but plugins are usually located in

I hope this is usuful for you guy to get xmms to work.
Other broken appz in repository can generally use this method
I got my XMMS work(can be open)
in 3.5.2
I won't be able to any songs in the play list, and therefore, it can't play anythings. sad.gif
Do anyone have this problem
Ahhh haaaa, after playing around for 3 days at work with this thing, i struck gold. Althou perhaps an obvious thing to some, its not exsplained very well in the forums. Some not all of the additional software you install on your zaurus, if installed to an SD or CF card, will not work unless the card is formatted as EXT2 (ext2)!!!!

I reflashed my zaurus to 3.5.2 again and installed xmms, only to get the same exact library problems, and such, as above. Then i stumbled accross a user who built an complete package with an image that copies over to your SD card on boot up, comes with several programs pre-installed, including xmms. Fourm link by CoreDump. I installed that package and had the same problems, part of his post mentioned formating the SD card to ext2 (which sad.gif i skipped the first time), once i formatted the SD to ext2, eureka!! everything works beautifully, no creating sym links to libglib or any of the troubles i had before. Plus many other apps that were less important, are working now too, cool!!

So moderators or someone should put a sticky somewhere, about formatting to ext2 to make many of the apps work, as it appears if you install apps to an SD or CF, thats the only way they will work.

Please if i'm wrong here fill me in.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.