Help - Search - Members - Calendar
Full Version: Fedora Core 3 And Usb Networking
OESF Portables Forum > Everything Else > Archived Forums > Zaurus General Forums > Desktop Operating Systems Issues > Linux Issues
I'm tryiong to get a C860 w/Cacko networked via my Fedora Core three box. The good news is that USB networking is enabled by default. If I plug in the Z, ifup the interface, and add a route, then I have connectivity between the two machines.

I'd like to have hotplug bring up the interface and add the route automatically. I've googled for instructions, and found some, but I haven't fouind any that work with FC3. Simply adding a /etc/hotplug/usbdnet file doesn't do anything - it is ignored.

Likewise the iptables scripts I have seen to enable masquerading for the Z have not worked for me. The one I tried actually stopped my FC3 box from communicating with anything.

Any help with either of the above issues will be gratefully received.

In FC3 for some reason the name of the USB module is 'usbnet', not 'usbdnet', so you should change the name of your script to 'usbnet' . Also make sure the script is executable by everybody. (chmod a+x usbnet). It's working for me with this setup so let me know if it doesn't...

- Nicolas
I just upgraded to FC3 from RH9. I didn't need to change anything, my Z (C860) continued working just as before.

To get my C860 working on RH9 I had to do the following:
  • Patch the kernel: I had to patch the module usbnet.c. It already had Zaurus support built in but it didn't recognize the C860's product ID. I believe the new kernel already has this support.
  • Blacklist CDCEther by adding CDCEther to the end of /etc/hotplug/blacklist. (I also added acm to the blacklist, but I don't think it was really necessary.)
  • Create a networking script in /etc/sysconfig/network-scripts called ifcfg-usb0. The contents were:

(Note that the 22's should be changed to match your Z's address.)

I *think* that's all I did. When I plug my Z in it is automatically set-up and I can immediately get to it via the network.

Good luck.

ON FC3 all I needed to do was blacklist the CDCEther then bring up usbnet

rmmod CDCEther
( acm not needed to be blacklisted, as My cell phone needs this )
modprobe usbnet

then pop in the Z .....

-Pete F
Thanks everyone! I now have the hotplug working so I can just plug in the Z and be connected. Great. smile.gif

I'm still in the dark about getting the FC3 box to route for the zaurus, so that it has connectivity to more than just the host. Any tips there?

Don't know anything about your network situation, but maybe your workstation, where you plug your zaurus into, is itself behind a router, so you have to add another route on the router?

For example you have the following configuration:
Inet <--> Router ( <--> ( Workstation ( <--> ( Zaurus

Then you have to add the following route on the router (linux syntax):
route add -net netmask gw

The gateway of your Zaurus stays as is. (Should be, in the example.)

Additionally, you don't need any masquerading on your workstation, if your router already does the masquerading.
Just forgot:

Of course you have to turn IP forwarding on on your workstation, like this:
echo 1 > /proc/sys/net/ipv4/ip_forward
Yes, that would work where I have control of the router, however I am often in environments where I do not. I'm sure I can figure out the masquerading when I find the time to sit down and read about it and play a little. I probably would have done that this past weekend if I hadn't run into trouble installing Fedora Core 3 on a couple machines with Adaptec 2410SA SATA RAID controllers. Worked before, doesn't work now; very frustrating (but not on topic here).

Good luck.
I hope you already know this?
QUOTE(otzenpunk @ Dec 14 2004, 01:37 AM)
Good luck.
I hope you already know this?

One of the things I need to figure out is where things have changed. The scripts I have found in various HOWTO documents for the Zaurus to enable NAT have only runied connectivity for the host. I am guessing this is because they were written for something a little earlier than I am using (Fedora Core 3, Kernel 2.6.9)

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.