Help - Search - Members - Calendar
Full Version: How To Restore 6000 To Original State?
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 6000 - Tosa
Pages: 1, 2
flagar
Hi all,
now that Sharp has released the ROM used in the SL-6000 on DevNet, I think that should be good to backup it as soon as possible on ZUG here, as we know the "reliability" of DevNet.
I would like to try pdaXrom now, and maybe help the team to get a proper release for the SL-6000, starting using the Sharp kernel, and updating only the initrd.bin. 8)

I think the instructions posted on DevNet are for complete NAND update, thus is there the risk that if something goes wrong you get a brick?
If it is such a case, is there a safer way to install initrd.bin files?
Also the encsh.c script seems not working with the updater.pro file included in the zip archive for the SL-6000. Should it be safe to use, together the initrd.bin file only? Or is it better to use an updater.sh file from other ROMs for other Z models? :?

Happy hacking! :wink:
eddiectc
Sorry, but I need help please!
After downloading and flashing the rom downloaded from http://zaurus.thegrantclan.org/download/za...20041029.tar.gz
My Zaurus 6000 can't startup, even I perfromed a hard-reset...nothing can see on the screen. Please tell me how to recover it.

Please help, Thanks!
hubcapboy
I've had a few scares actually...

can you get it to respond to anything? for starters, does the battery light still come on when plugged in? if you used the "OK boot" to do your update, you might want to try a diagnostic boot, which is the letters d and p held on the keyboard while you hard reset. if you get a diagnostic message, you're golden. let me know if you have luck with any of this so we can tell you what kind of file you'll need to restore it.

PS i love zaurus user group. every other message board i've posted to would deal punishing blows to someone shouting in the title of one of thier first post. you all rock.
eddiectc
Thanks hubcapboy.

I can go into the Maintenance menu,
but nothing happen when i do the "poweron" or "reset" or "hard-reset"...

Is that I need the original Sharp rom in order to get my Zaurus back?
or I can try to flash the rom sl6000-20041029.tar.gz?

Please tell me what to do next.
Really Thanks!
eddiectc
Oh yeah
I got the diag menu!
What to do next?
It seems that I can easily damage my zaurus there...
guylhem
Use nand restore from externe.net/zaurus/flash. Get the 6000L version.
eddiectc
Thanks, my Zaurus is back again!
eddiectc
Another problem...
the wireless networking doesn't work...
I have done nothing to the wireless router, and other wireless client can go online w/o any problem, so i guess is the Zaurus' problem.
It did work before, but after "restoring" the rom from externe.net/zaurus/flash, it doesn't work.
I think maybe I did something wrong?
Here is my steps:
1. get the syst0006.dbk-us and unzip it, rename it to syst0006.dbk and put it in CF
2. in Zaurus, go into the diag menu, and then "NAND restore"
3. wait until it completes the restore of the NAND, then reset
4. The Qtopia works fine, but in the SysInfo, for the section "Linux Kernel", the "ROM Version"
is "ROM Version:--.--", but I remember before is 1.12

Is that I missed something? also what is the usage of SL6000L-US-1.12.zip and how to use it for recovery?

Also, when I type "ifconfig", it returns only the lo device, is this correct?

Also2...when I do a reset, I notice something like "cramfs: wrong magic", and then following by many "pxa_sd_stopclock: clock stop time out.".
eddiectc
QUOTE(guylhem @ Nov 6 2004, 01:15 PM)
Use nand restore from externe.net/zaurus/flash. Get the 6000L version.

Hi, guylhem
I would like to know if the file http://www.externe.net/zaurus/flash/syst0006.dbk-us.bz2 is the original one. Because after restoring the NAND backup, the wireless lan doesn't work anymore.

Thanks!
hubcapboy
I can't speak for the nand file... I've got my own that I use when I fudge it up. make sure you remembered to set up the network again through settings, you've got to add a profile. If you had the network working before, you have already done it once.
eddiectc
QUOTE(hubcapboy @ Nov 8 2004, 04:34 AM)
I can't speak for the nand file... I've got my own that I use when I fudge it up. make sure you remembered to set up the network again through settings, you've got to add a profile. If you had the network working before, you have already done it once.

Hi hubcapboy, Can you share the NAND backup file with me?
Coz I think the NAND backup I got is damaged.
Thanks!
eddiectc
QUOTE(eddiectc @ Nov 7 2004, 10:42 AM)
QUOTE(guylhem @ Nov 6 2004, 01:15 PM)
Use nand restore from externe.net/zaurus/flash. Get the 6000L version.

Hi, guylhem
I would like to know if the file http://www.externe.net/zaurus/flash/syst0006.dbk-us.bz2 is the original one. Because after restoring the NAND backup, the wireless lan doesn't work anymore.

Thanks!

I think the NAND backup is somehow modified.
I need to manually insmod p80211.o and prism2_usb.o
and then the wifi works again.

Can someone please share the original NAND backup of the Zaurus SL-6000L?
nevarrie
QUOTE(eddiectc @ Nov 7 2004, 11:13 PM)
Can someone please share the original NAND backup of the Zaurus SL-6000L?

http://zaurus.thegrantclan.org/download/za...0217SL6V112.zip is the original sharp rom as found on sharps site. I have used it many time and then restored my backup and had my Z right back to the point it was before I started playing. The instruction from sharps website on how to uses this restore are at http://zaurus.thegrantclan.org/download/za...ashsharprom.txt.
naoyaru
It looks like eddiectc and me are in the same ship (play arround with SL-6000 and no back-up VERY BAD GUYS).
I installed the NAND backup from guylhem and its looks like theres some modifications. When i try to make work the WIFI card does not work and it changes the old boot with the one used with the modified kernel.
BTW Ambicom bluetootj card does not work anymore too.

and so
if anyone here want to share your NAND backup eddiectc and me appreciate it a LOT (we promisse to do not do play again without backup, we promise).

PD Excuse my english, "¿alguien aqui habla español ?"
naoyaru
QUOTE(nevarrie @ Nov 8 2004, 04:26 PM)
QUOTE(eddiectc @ Nov 7 2004, 11:13 PM)
Can someone please share the original NAND backup of the Zaurus SL-6000L?

http://zaurus.thegrantclan.org/download/za...0217SL6V112.zip is the original sharp rom as found on sharps site. I have used it many time and then restored my backup and had my Z right back to the point it was before I started playing. The instruction from sharps website on how to uses this restore are at http://zaurus.thegrantclan.org/download/za...ashsharprom.txt.

Does this process works only with CF and not SD?
ph34r.gif
naoyaru
Oh BTW another observation is when i go to sys info i cant see the kernel version. I go to the DP + Reset menu and do a NANA checksum and this 2 files are somewhat diferent from the one registered by the system
kernel1 and kerne2
another test tell me there are two sectors damaged in the NAND, are this related with the test? anyone here knows?
thanks
nevarrie
QUOTE(naoyaru @ Nov 8 2004, 11:04 AM)
Does this process works only with CF and not SD?
ph34r.gif

that is correct...I have thought about looking at thier updater.pro file so I can see what they are doing to add it into the updater.sh so you can do the NAND flash from sd instead of cf but I finally bought a cf card and have been using it...before that I used a friends cf card...
naoyaru
thankx for the help smile.gif fully restored
brought a cf card and only takes few minutes to get done
hubcapboy
eddie-

do you still need a backup? my current wifi is a little flaky so I'm going to have to wait until late tonight when I get back to campus to download Fedora Core 3.

post if you don't need it, I'm making you a "fresh" nand rather than sending you one with all of MY playing around included.

as long as we're all trading nands, does anyone have a nand flash with the cpu scaling kernel included? I've tried it three or four times but every time have run out of space somewhere along the way, or run into some other hang up.
eddiectc
QUOTE(hubcapboy @ Nov 9 2004, 04:30 AM)
eddie-

do you still need a backup? my current wifi is a little flaky so I'm going to have to wait until late tonight when I get back to campus to download Fedora Core 3.

post if you don't need it, I'm making you a "fresh" nand rather than sending you one with all of MY playing around included.

as long as we're all trading nands, does anyone have a nand flash with the cpu scaling kernel included? I've tried it three or four times but every time have run out of space somewhere along the way, or run into some other hang up.

Thanks for hubcapboy first!

I think nevarrie's rom backup should be working well. But I didn't have time to try it, I think i'll try it tonight.
However, if you can donate your NAND backup, it's better coz guylhem's backup got some problem.
hubcapboy
howdee howdee... uploading now. I'll post the link when it's ready to come out of the oven.

EDIT 10:04 Pacific: yeesh... a whole 20kb/s. expect it in an hour. probably shouldn't have bothered to try over the grocery store's network... but there you go.
hubcapboy
Stocker SL-6000 NAND

There ya go. If someone wants to make it a permanent download, they may want to mirror it somewhere... I'm going to pull it down after 24 hours.

eddie let me know when you've got it. it's something like 70 megs.
eddiectc
Thank you very much!
The NAND backup is working great!
guylhem
Ooops. Sorry I just realised I had put online a *test* backup (with the fast kernel, other modules stuff etc.)

hubcapboy, if you don't mind, I did put yours instead (wow 600kb/s) on externe.net (to avoid me flashing back a stock rom, then doing a nand backup, then doing a nand restore to my own rom)
hubcapboy
yea we've got some blazing servers at school, especially the student server, as very few history majors are hogging bandwidth.

you're kosher posting my stocker on externe, but could you leave the modified one up there and label it so I can find it? I'd like to try the turbo kernel, but I've been frustrated the last few times I've worked throught it. NAND flash to take a look would be sweet.
guylhem
I'd be very happy to have a nand flash of all the nice utils + the fast kernel, but what was hosted was just a bad mix :-/

I'll try to clean up my homedir (remove some apps etc) and do a nand backup

But it you follow instructions (remove opera pdf plugin to have enough space for the modules) everything works fine.
neuroshock
Pardon me while I expose my Linux ignorance yet once again...

I'm getting ready to flash my 6000L to the overclockable kernel and have a quick question before I do. If I do a complete backup using the backup utility provided by Sharp can I restore from that backup after I have installed the new kernel or will it be incompatible?

Feel free to school me on this. I've wondered for a long time how the kernel is dependant or independant and if it resides in the "Backup" file or is unnaffected by it. My inclination is that it must be seperate or ppl wouldn't have to go through the flashing process to update the kernel they could just restore from a Backup of a kernel updated Zaurus and not have all the hassle. However my inclinations have caused me great grief in the past *cringe*.

Thanks a bunch,
-NeuroShock huh.gif
smuelas
I'm not a "master". Just I've done what you say and the answer is the bad one. Your backup will serve you if you come back to the actual kernel inside your machine. Sorry.....
smuelas
neuroshock
Arrgh, dissapointed but thank you VERY much Smuelas for your response! If someone more enlightened than the two of us cares to expand on why this is I'd still be greatful.

Thanks Again,

-NeuroShock
crow
Hi All,

I just got an SL-6000L and was looking for Sharp's ROM images and kernel source and found they don't seem to be available on Sharp's web site. Nor do they seem to be available through ZUG downloads. Has anyone archived and made them available on a public web/ftp site or know where I can get them? Any help is appreciated. Thanks.

crow
BarryW
From nevarrie's site, the 1.12 rom.

http://zaurus.thegrantclan.org/download/zaurus/roms/tosa/
crow
BarryW, a big thank you to both you and nevarrie!
jbruno
I'd like to experiment with other ROMs on my new 6000, but I don't know how to restore it to its original state (i.e., ROM as shipped from factory.)

Is there some document somewhere that shows how to do this? I've just left the ROM on there that came with it, out of fear of breaking the thing.

Any help would be appreciated!
soundwave106
I think a hard reset does that? (Press the "reset" button on the back while holding power on + rec)
fhann36
Press d and P keys while resetting, it will take you to a menu to restore NAND.
Not sure If you need the original ROM though
fhann36
First backup your NAND. This will be the ROM you use to restore the original sharp ROM after your done experimenting
jbruno
Thanks, everybody. I'll try this tomorrow (backing up what I have) and immediately restoring before getting my feet we w/new roms.

I did this with my 5000 many times, but I am being more careful with the 6000 - it was more expensive!
antoine
I've flashed my (new) SL-6000L with the OpenZaurus ROM v3.5.2 and it worked, unfortunately, I haven't a chance to backup it before sad.gif too soon to happy to get it... and maybe too stupid also I am.
Now I'd like to come back to original stuffs (especially for wifi and opera support), could you please help me finding out the original Sharp ROM. I mean what is DevNet, do you have an URL or something.
Please advise, I'm lost (mainly sad), thank you.
byzantium
Hi, see Link to Sharp 6000 ROM or the links in previous posts.

Please try using the Search next time as well

Good luck
antoniovf
Im triing to reflash with this intructions, only i want to know that i can back to the official version if i need. But the combination reset+q+t dont work. One stupid cuestion... The reset buton are in the back of the zaurus sl-6000, isnt it? I have this doubt because in my case dont work. Or is the power button I have to push? thanks.
dlee27
I'm trying to restore back to the Sharp Rom and it doesn't work. I did this successfully before a couple of times with the instruction previosly posted, so I don't know what went wrong. When I press q+t+reset both leds light on but after a short while both leds blinks forever. I know this leds should go out after NAND restore, but they blinks.

I also tried OZ 3.5.2 and it says:
"Seriously problem!!! Your Zaurus not SL-C700/750/760/860/6000 model. Cannot install OpenZaurus on unknown, press the ENTER key for reboot."

Any suggestion? Thanks.
thaak
Hi

Just checking would it be usefull to mirror NAND backups. Have some spare bandwidth and a webserver. Am willing to put a sight together. If you intrested just give a shout. Also very off topic have four gmail accounts to give away if anyone wants. You can email me NANDS or request for gmail at zaurus6000sl@gmail.com
Padron
QUOTE(naoyaru @ Nov 8 2004, 05:02 PM)
It looks like eddiectc and me are in the same ship (play arround with SL-6000 and no back-up VERY BAD GUYS).
I installed the NAND backup from guylhem and its looks like theres some modifications. When i try to make work the WIFI card does not work and it changes the old boot with the one used with the modified kernel.
BTW Ambicom bluetootj card does not work anymore too.

and so
if anyone here want to share your NAND backup eddiectc and me appreciate it a LOT (we promisse to do not do play again without backup, we promise).

PD Excuse my english, "¿alguien aqui habla español ?"
*
Padron
Sorry about that last post. I usually read and try installing software, and rarely request information because most questions are aswered and found with reading the threads and posts.

I've just purchased the 6000L . I'm new to the board and have been reading the posts and installing apps.

I installed the extreme.net nand and now my wifi doesn't work. Running a df shows /dev/root at 100%

I want to install the original sharp rom.
The problem is the link to "http://zaurus.thegrantclan.org/download/za...0217S6V112.zip" times out.

Is there an alternate site available where one could download the original sharp rom?

Thanks

6000l
512mb Sandisk SD
1gb sandisk CF
TRENDnet CD 10/100 ethernet adapter
Padron
QUOTE(Padron @ Jan 22 2005, 05:08 PM)
Is there an alternate site available where one could download the original sharp rom?

Thanks

6000l
512mb Sandisk SD
1gb sandisk CF
TRENDnet CF 10/100 ethernet adapter
*


Found it at http://www.externe.net/zaurus/flash/
zipmaster
hey can i get a quick run down to make my own image like the one found in the site mentioned above. i went to the diag and did nand backup but that gave me a dbk file and i didnt get all the bins and stuff. any help would be great
jeffbarish
Well, I thought I could figure this out, but I guess I can't. I'm trying to restore the Sharp ROM (OZ installed now). I've read all the posts here, but I can't get my Zaurus 6000L to flash. Here's what I did. First, I ran fdisk to format the CF. I formatted it with one partition, defaults for start and stop cylinder. I set the type to FAT16 (0x06). I wrote the table and exited. Next I ran mkdosfs on the CF. Next I copied all files from SL6000L-US-1.12.zip (ffffffff.bin initrd.bin mainte.bin nanddiag.bin updater.pro initfs.bin initrd.gz mversion.bin paraminf.bin zImage.bin) to the CF. I moved the CF to the Zaurus. I reset (amber light goes on) and then hit power while holding down Q and T. The Zaurus boots OZ. I also tried reset, power with OK. Then I select CF under Update. It boots OZ. With this procedure I get the message "/mnt/cf/update.sh not found". I can't find that file. I suspect that the message is coming from OZ anyway. With the Q-T procedure, OZ starts booting so quickly that I can't read any error messages. At http://www.externe.net/zaurus/flash/ there is a README.txt. It says that one can flash a kernel with the files updater.sh, consolescroll.sh, and zImage.bin. Only the file zImage.bin is available in the zip file and I can't find the others at the site.

I also tried following the procedure described by eddiectc (post 8) for NAND restore. I don't get an option for NAND restore (is the diag menu what one reaches by pressing power with ok held down?). If I request an update from CF, I get OZ.

I must be doing something stupid, but I need someone to tell me what it is. I bet I'm not formatting the CF correctly. I tried formatting it in my camera, but when I do that I get the same results (which is why I suspect that I'm not doing it correctly).
xjqian
QUOTE(jeffbarish @ Mar 16 2005, 07:27 PM)
I reset (amber light goes on) and then hit power while holding down Q and T.  The Zaurus boots OZ.  I also tried reset, power with OK.  Then I select CF under Update.  It boots OZ.  With this procedure I get the message "/mnt/cf/update.sh not found".  I can't find that file.
*


as the message suggested you need update.sh from here: http://www.externe.net/zaurus/kernel/flash-common/. Although the instruction may not mention it, it's always need AFAIK. I usally use power with OK, just for ease.
jeffbarish
OK, this is promising. I added the file updater.sh to the ones from SL6000L-US-1.12.zip (ffffffff.bin initrd.bin mainte.bin nanddiag.bin updater.pro initfs.bin initrd.gz mversion.bin paraminf.bin zImage.bin) on the CF.

Now I get the messages:

Flash erasing...done

0% 100%
...........................
Success!
Maser version
Success!
Please reset

At this point, I push the reset button on the back of the Zaurus, then hit power. OZ tries to boot (but fails to find many files). What am I missing now?
jeffbarish
I tried updating from the maintenance mode (d, p, reset) using the exact same files I used in my previous attempt. Using this technique, the update worked and I am now running the Sharp ROM. Thanks for all the great information posted in this thread.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.