Help - Search - Members - Calendar
Full Version: Connect To The Net With Gprs Through Bt
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
vinfong
Hi I am a new user of 860 and just installed RC8 on the machine.
I am trying to use gprs over BT.
I have a socket revH card and a SE p900 phone

I setup a ppp profile in PPP modem
phone: *99***1# (this is what I use when I connect to the phone with my laptop)
connect via: bluetooth
device: /dev/rfvomm0
init string: empty
speed: 115200
BT DUN: 00:0A:D9:EA:EC:43, 3 (I checked that with btscanner, this is my phone)
demand dailig: manual connect and disconnect

then I run PPPdialer with this profile and it shows
abort on (NO CARRIER)
abort on (NO DIALTONE)
abort ob (BUSY)
send (^M)
expect (OK)

during this time my phone shows some BT activity but it never make the GPRS connection

then the dialer show this and fail:
alram
Failed
Connect script failed

what should I do to make this work? (I have install all packet with the bluez name on it from the feed for rc8)
Thank you in advance

Vincent
r.s.r
Hi Vincent,

Try using Init String: ate0v1 in your Dial-up settings, it worked for me on a non-GPRS connection.

This turns on the 'verbose' replies on your phone's internal modem.

Cheers,

Ron.
vinfong
The connection is working now with the init string.
Thanks a lot.

Vincent
Foxdie
Hi vinfong, I know you've already solved your problem but I feel I have to add some more information here (I work for a major cellphone network)

Sony Ericssons do have a bug with their AT modem commands where verbose is off by default, they also use a different init string than most.

Whereas most AT modems will be able to connect to GPRS with the init string at+cgdcont="1","IP","internet" and the dial up number *99# (in particular Nokias use this method), Sony Ericssons use a different format.

This is what people should do to make sure they're using the right profile for dialling up on a Sony Ericsson.

Go into Menu > Connectivity menu, now on some phones at this point it varies, some people have "Data Comms", some people have "Internet". You may need to poke around a bit, what you need to do is look for "Data Accounts" or "WAP Profiles" or something like that.

Then you need to find the profile in particular that you want to connect up with, for the Vodafone network (I work for them) you need to find the profile with the word "Internet" in it if you're a contract (pay monthly) customer or "Vodafone PrePay" profile if you top up your phone's credit in advance. Find the right profile and view the info on it, it'll give you an ID number, for 99% of Vodafone Sony Ericssons the "Internet" profile will be ID number 3.

Then you use the init string atz or the one listed above, and the dialup number *99**ID# where ID is replaced with the profile ID. That should get you set up.

If you need the multimedia (picture messaging) settings, CSD or GPRS (both wap) settings for your handset you can obtain them from the following links depending on manufacturer sent as a sms (text) message to your phone:

Nokia: http://www.nokia.co.uk/nokia/0,,54551,00.html
Sony Ericsson: http://www.sonyericsson.com/spg.jsp?cc=glo...ate=ps3&zone=ps
Motorola: http://secure.mouse2mobile.com/clients/hel...et=dfjksntr89we

There are others, I just can't remember the pages smile.gif
gene
Guys,

I need your help. I'm trying to do DUNthrough my treo 650 with a socket revision h. When i do pppdialer it says :

failed to open /dev/rfcomm0: no such device.

I am sure the bluetooth is working because when i run hciconfig i get information and a mac address for the card. Also, I was able to pair it with the treo from the treos end. Any ideas would be welcome. Thanks!!!

p.s. although it is strange that when i do:

sdptool browse i only get the mac address i dont get more information like im supposed to, like the channel for example.!
gene
Guys,

My problem still persists any kind souls out there with experience in this willing to offer any words of wisdom would be much thanked in karma points and anything else I can provide..... free hosting?
sonicbuddha
Greg:

I don't know if you've figured this out by now since its been several months, but I've been looking at the Treo series myself, thinking about a purchase, and I can tell you that I have yet to find a provider that sells a Treo with the bluetooth DUN profile enabled (but there are hacks and patches). I'd check to see if your phone supports DUN first or get the patch.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.