Help - Search - Members - Calendar
Full Version: Un-busted Sl5500
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
selfabuse
Figured I'd put this here in case anyone else runs in to the same problem. A coworker of mine tried to flash back to an older sharp rom because some software he was trying to work didn't run properly on tcKrom 1.0 - apparently at some point he messed something up, because it didn't work. He tried to put tck back on, and it started hanging at the "INIT: version 2.68 starting" (something like that - don't remember it exactly unfortunatley) line - we tried putting every different rom I could think of back on it, but none of them ever got any farther. I noticed I could still get to the reset-D-P menu, so I ran all the internal flash diagnostics there, and everything seemed kosher. Grabbed an OLD (like 1.something old) romimage, flashed it, and the lights only stayed on for like 2 seconds - after some digging, I found that contrary to what the downloads section here says, old roms need to be named ROMIMAGE rather then Ospack (newer ones seem to be Ospack though) Got a 1. rom on, but it wouldn't even turn the power light on (I think it may have been a 5000 rom, after I did some more digging) so I grabbed 2.12 (I think it was 2.12) flashed from the reset-D-P menu, and this time I got much farther - got a screen full of errors and then a 'enter root passwd or press ctrl-d to continue' screen - when I get that on any of the servers at my office, it tends to mean the drive needs a good fscking but that didn't seem to be the case here. Since I had got much farther, I reflashed the newest OZ on a hunch, and wouldn't you know, the thing works like a charm now.

I had tried *EVERYTHING* and we were about to send the thing back to sharp

sorry for the long read, but hopefully this will help somebody out, and perhaps save a zaurus that's on it's way to the scrap heap.
robphil777
Thanks for the info - Had a similar problem for about 2 weeks now with my Z-5500. I was just about to call sharp when I say this posting. I'd like to add info for others who may this problem.

The old sharp images can be found here: http://www.zaurususergroup.org/UpDownload.phtml under "ROMS" then "Sharp".
-If the file downloads as a "ROMIMAGE-Ver_NO.Etc" rename it to "ROMIMAGE"(without quotes). If "Ospack-Ver_NO.Etc" rename to "OSPACK"
-Flashing Instructions are here:
http://www.oesf.org/index.php?title=5x00_ROMs
- I flashed a old sharp rom of V2.38, my Z kept rebooting but it flash for longer then the 3-4 secs it was flashing before. I then flashed the 3.10 as "Ospack" and it took.

I think that Sharp V3.10 rom is a update only so if you have problems you should try at least V2.38. Hopefully if you are experimenting with different roms and have a problem you can always revert back to the original Sharp configuration.

Hope this helps too. smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.